Page 1 of 1

Posting DirectX 10 problems in thread

PostPosted: 28. Jun 2009, 21:37
by Serpardum
I am not sure if this is the correct place to post findings with DirectX under vista.

Such as Counter Strike Source gives me black screen. Red Orchestra gives me option screen but mouse jumps around too sensitive and unusable. World of Goo (2D) Works. Sims 3 is all blue and when I tried print screen to capture the print screen key seemed stuck and kept opening capture window and had to turn off computer.

Host kubuntu 9.04 64 bit Guest Vista Home Premium 32.

If not here, where?

Re: Should I post Vista DirectX 10 problems here?

PostPosted: 28. Jun 2009, 22:25
by Perryg
Are you using VirtualBox 3.0.0 b1 or b2?

Re: Should I post Vista DirectX 10 problems here?

PostPosted: 28. Jun 2009, 22:27
by Serpardum
b2

Version 3.0.0_BETA2 r49051

Re: Should I post Vista DirectX 10 problems here?

PostPosted: 28. Jun 2009, 22:33
by Perryg
Then this is the place. Thank you!

Re: Posting DirectX 10 problems in thread

PostPosted: 28. Jun 2009, 22:46
by Serpardum
Sims 3: Starts, I see the Sims movie in blue (not full color like it should be). After movie is over or stopped, I hear the music in the background, but black screen (same as CSS).

I tried sending screenshot and log as attachments but it only seemed to attach the log. Here is link to screenshot: http://webpages.charter.net/jimmlangsto ... ms%203.png

Re: Posting DirectX 10 problems in thread

PostPosted: 29. Jun 2009, 01:33
by Serpardum
Dark Messiah Might and Magic through Steam gives error: A required security module can not be activated. This program can not be executed (3000). Please have a look at: http://www.securom.com/message.asp?m=module&c=3000 for further more detailed information.

It seems that Dark Messiah is somehow giving a false positive for "SoftICE" which I guess is used to hack games. Other steam games didn't give this error (blank scree, ran 2d as listed) so it seems to be specific to Dark messiah.

Re: Posting DirectX 10 problems in thread

PostPosted: 29. Jun 2009, 06:16
by Serpardum
Assassin's creed: When it installs it displays a warning: Image

http://webpages.charter.net/jimmlangsto ... sCreed.png

When it runs it shows the movie fine, no problem, then it closes. Probably not too surprising considering the recourses it wants.

Re: Posting DirectX 10 problems in thread

PostPosted: 29. Jun 2009, 07:34
by Serpardum
Well, that's about it for all my games. There are some others but looking at the specs given by Assassin's Creed and the results returned for the emulated hardware I can tell that right now that the directx emulation isn't going to cut it yet for modern games. The nvidia 5xxx cards wouldn't run a game 5 years ago.

I'll be going back to native vista for now. So long and thanks for all the fish.

I'll be using virtualbox on Vista to run kubuntu though.