Vista won't return to non-seamless mode correctly.

Postings relating to old VirtualBox pre-releases

Vista won't return to non-seamless mode correctly.

Postby Serpardum » 28. Jun 2009, 03:37

Host OS Kubuntu 9.04 Jaunty 64bit. Guest OS Vistal Home Premium 32 bit. This problem also existed in version 2.2.2-OSE and 2.2.4 Sun

I can go into seamless mode and for the most part it works. However, when I try to come back from seamless mode things are not right as shown in this screen shot: http://webpages.charter.net/jimmlangsto ... 0vista.png

Here is the log: http://webpages.charter.net/jimmlangsto ... VBox.log.1

It's very irritating because the only way to get vista back into non-seamless mode is to restart vista.
Serpardum
 
Posts: 14
Joined: 24. Jun 2009, 20:40
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Vista

Re: Vista won't return to non-seamless mode correctly.

Postby Perryg » 28. Jun 2009, 04:28

Perryg
Site Moderator
 
Posts: 34373
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Vista won't return to non-seamless mode correctly.

Postby Serpardum » 28. Jun 2009, 04:49

I looked at the link given and all those refer to Cairo Dock breaking the transparency as I don't have Cairo Dock installed or running (I just checked PS -A). This also wouldn't work in 2.2.2 or 2.2.4 so I'm fairly sure that it is probably something wrong in my setup as I don't see this bug going on without being resolved that long.
Serpardum
 
Posts: 14
Joined: 24. Jun 2009, 20:40
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Vista

Re: Vista won't return to non-seamless mode correctly.

Postby Perryg » 28. Jun 2009, 05:31

This also effects compiz. Try the suggestion and see if it works for you as well.
Or you can turn off effects when going into seamless.
Perryg
Site Moderator
 
Posts: 34373
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Vista won't return to non-seamless mode correctly.

Postby Serpardum » 28. Jun 2009, 07:35

I don't seem to have compiz running either. You do understand that when I first run vista in the windowed mode it's fine. It's only when I seemless then un-seemless it's that way. I'm not sure what graphics manager I'm using, I tried the suggestion that seems to work for everyone: env XLIB_SKIP_ARGB_VISUALS=1 VirtualBox, with the same results. Vista comes up fine in window, I seamless and back and it's all wrong.

kbuntu seems to have another effects program. I am not 100% positive that I'm not using compiz, I just don't see it in the process list ps -A

I do have compiz installed, however, so perhaps it is being used. ps -A | grep compiz produces no output for me.
Serpardum
 
Posts: 14
Joined: 24. Jun 2009, 20:40
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Vista

Re: Vista won't return to non-seamless mode correctly.

Postby Sasquatch » 28. Jun 2009, 14:34

To disable effects in KDE, which uses Kwin for it, open the settings of your Window Manager and disabled Composite Manager, or similar. I don't use KDE, so the name can be different, but the idea/setting should be the same.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: Vista won't return to non-seamless mode correctly.

Postby Serpardum » 28. Jun 2009, 21:20

It seems to be Computer -> System Settings -> Desktop -> uncheck Enable desktop effects.
As long as that's the right setting. However, it seems to have no effect on the VirtualBox window not restoring. I had tried a few suggestions with no help and before I even changed this now when I try to restore it the window is totally invisible. Disabling desktop effects makes no change to this.

I am willing to break my Kubuntu to try to get this to work.
Serpardum
 
Posts: 14
Joined: 24. Jun 2009, 20:40
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Vista

Re: Vista won't return to non-seamless mode correctly.

Postby Sasquatch » 28. Jun 2009, 22:55

What happens if you right click on the task list entry of the VM and let it minimize, then restore? Also try a maximize, so the VM has to repaint the whole screen again.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: Vista won't return to non-seamless mode correctly.

Postby Serpardum » 28. Jun 2009, 23:13

Well, somehow yesterday when working on it I had made it worst, not better. Now when I go non-seamless the window disappears completely. When I full screen the tab it actually goes half seamless again. The windows start bar is half hidden by the Kubuntu bar and the windows gadgets appears back on the right. If I go to seamless from here the windows start bar jump up to above the kubuntu start bar, but is all gray and the windows gadget still shows up. If I hit the windows key I see most of the windows optons (all programs, etc.. ) with some blocked at the bottom.

No idea how I messed it up trying to follow the instructions on the link given. It still works windowed if I start it in that mode. It just doesn't want to go back there.
Serpardum
 
Posts: 14
Joined: 24. Jun 2009, 20:40
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Vista


Return to Old Beta Postings

Who is online

Users browsing this forum: No registered users and 2 guests