Several bugs in 3.0 Beta 2

Postings relating to old VirtualBox pre-releases

Re: Several bugs in 3.0 Beta 1

Postby michael » 19. Jun 2009, 12:55

Re the black screens, I have to admit that so far I haven't a clue. So my next request is for the guest's xorg.conf files and the Xorg.0.log corresponding to the failing gdm session.
michael
Oracle Corporation
 
Posts: 683
Joined: 10. May 2007, 09:46

Re: Several bugs in 3.0 Beta 1

Postby sovok.kpss » 19. Jun 2009, 17:17

Wow, I got my guest Fedora 11 working!
When the gdm is loading I have black screen with the line of some video trash at the top. Using my extra-human ability to work with blind eyes :D I pushed "Enter" button(because by default my Username is selected and waithing for my choose) and typed the password and then again pushed "Enter". Then a system loading as usual without any errors and crashes. And after that I restarted again and noticed that a line of some trash is the normal screen but with scaled height to be a small line at the top.
System boot normal with both enabled and disabled 3d acceleration.

here xorg.conf and Xorg.0.log as you wish =)
Attachments
xorg.conf.log
(307 Bytes) Downloaded 14 times
Xorg.0.log
(74.35 KiB) Downloaded 15 times
sovok.kpss
 
Posts: 10
Joined: 17. Jun 2009, 20:38
Primary OS: Linux other
VBox Version: PUEL
Guest OSses: Windows 7(64-bit), Ubuntu 10.04(64-bit), CentOS 5.5(64-bit)

Re: Several bugs in 3.0 Beta 1

Postby sovok.kpss » 19. Jun 2009, 18:22

In addition to my previous post:
When I increased a processors number up to 2 the system didn't load at GDM stage as I described above, disabling 3d acceleration didn't help. It loads only background and nothing else.
Attachments
Xorg.0.log.old.log
(15.1 KiB) Downloaded 14 times
sovok.kpss
 
Posts: 10
Joined: 17. Jun 2009, 20:38
Primary OS: Linux other
VBox Version: PUEL
Guest OSses: Windows 7(64-bit), Ubuntu 10.04(64-bit), CentOS 5.5(64-bit)

Re: Several bugs in 3.0 Beta 1

Postby danielkza » 21. Jun 2009, 12:39

I can confirm the issue, tested on both Fedora 11 and Ubuntu 9.04. Works fine right after installation to hard-drive. On the first HD boot, the first thing I've done is install the needed packages, the guest additions, then reboot. Then, in the moment GDM should kick-in (as already mentioned), I get a black screen with random garbage at a small line in the top. I'll try to do a blind login to check if it works.

Code: Select all   Expand viewCollapse view
[Host]
Windows 7 RC1, Core 2 Duo E7300

[Guest]
Fedora 11, Ubuntu 9.04
Base Memory: 1GB
Video Memory: 16MB
PAE/NX: On
HW Virt: Off
SMP: Off

3D Acceleration: On/Off (no change)
danielkza
 
Posts: 1
Joined: 21. Jun 2009, 12:31
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Linux, Windows XP, Windows Server 2008

Re: Several bugs in 3.0 Beta 1

Postby aamukahvi » 21. Jun 2009, 17:14

Hi,

I noticed that resizing the guest window somehow repairs this situation. Then if I set a "real" resolution (1366x768) from Kubuntu 9.10 screen settings, it gets screwed again.
aamukahvi
 
Posts: 1
Joined: 21. Jun 2009, 17:11
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Linux, Windows

Re: Several bugs in 3.0 Beta 1

Postby sovok.kpss » 21. Jun 2009, 18:51

aamukahvi wrote:Hi,

I noticed that resizing the guest window somehow repairs this situation. Then if I set a "real" resolution (1366x768) from Kubuntu 9.10 screen settings, it gets screwed again.


Yes, but not at GDM loading stage.
sovok.kpss
 
Posts: 10
Joined: 17. Jun 2009, 20:38
Primary OS: Linux other
VBox Version: PUEL
Guest OSses: Windows 7(64-bit), Ubuntu 10.04(64-bit), CentOS 5.5(64-bit)

Re: Several bugs in 3.0 Beta 2

Postby sovok.kpss » 25. Jun 2009, 15:20

UPD2: Beta 2:
1) Additions don't work on Fedora 11 as Guest. It gives only black screen on reboot after additions installing
This problem is still happen, but now after installing additions it is a full black screen(with no line of trash in the top e.t.c.). The way I can get the Fedora 11 working doesn't work now
sovok.kpss
 
Posts: 10
Joined: 17. Jun 2009, 20:38
Primary OS: Linux other
VBox Version: PUEL
Guest OSses: Windows 7(64-bit), Ubuntu 10.04(64-bit), CentOS 5.5(64-bit)

Re: Several bugs in 3.0 Beta 2

Postby sej7278 » 25. Jun 2009, 15:28

sovok.kpss wrote:UPD2: Beta 2:
1) Additions don't work on Fedora 11 as Guest. It gives only black screen on reboot after additions installing
This problem is still happen, but now after installing additions it is a full black screen(with no line of trash in the top e.t.c.). The way I can get the Fedora 11 working doesn't work now


this might actually be a fault with fedora11 not virtualbox as i was getting the corrupted gdm screen on a real fedora11 machine when i installed the nvidia drivers, and switching to a tty (similar to resizing a guest) fixed it, and like you, once i blindly logged in, display was fine.

using the default nouveau drivers worked fine, so maybe fedora11 has an issue with 3rd-party drivers like nvidia/virtualbox....?
sej7278
Volunteer
 
Posts: 1003
Joined: 5. Sep 2008, 14:40
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Solaris, Linux, Windows, OS/2, MacOSX, FreeBSD

Re: Several bugs in 3.0 Beta 2

Postby sovok.kpss » 25. Jun 2009, 16:41

sej7278 wrote:this might actually be a fault with fedora11 not virtualbox as i was getting the corrupted gdm screen on a real fedora11 machine when i installed the nvidia drivers, and switching to a tty (similar to resizing a guest) fixed it, and like you, once i blindly logged in, display was fine.

using the default nouveau drivers worked fine, so maybe fedora11 has an issue with 3rd-party drivers like nvidia/virtualbox....?


Maybe there is something wrong in Fedora 11 ;)
But again, when I turned off SMP all seems to be right.
sovok.kpss
 
Posts: 10
Joined: 17. Jun 2009, 20:38
Primary OS: Linux other
VBox Version: PUEL
Guest OSses: Windows 7(64-bit), Ubuntu 10.04(64-bit), CentOS 5.5(64-bit)

Re: Several bugs in 3.0 Beta 2

Postby sej7278 » 25. Jun 2009, 17:02

sovok.kpss wrote:Maybe there is something wrong in Fedora 11 ;)
But again, when I turned off SMP all seems to be right.


ah didn't see you mention it being an smp issue in the thread - my real f11 box was smp too.

turning off smp does seem to fix most of the problems i've seen in both beta's.

maybe 2.2.5 should be released with the bugfixes backported from the betas and 3.0.0 final with smp should be held back for a few months, i can't see this coming out of beta any time soon with stable smp.
sej7278
Volunteer
 
Posts: 1003
Joined: 5. Sep 2008, 14:40
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Solaris, Linux, Windows, OS/2, MacOSX, FreeBSD

Previous

Return to Old Beta Postings

Who is online

Users browsing this forum: No registered users and 2 guests