Page 1 of 1

Can't mount shared folders in 6.1

PostPosted: 11. Jan 2020, 05:37
by Mauricio Fagundes
I have a VM with Arch Linux (created with VirtualBox 6.0). It was fine until I tried to mount a folder from my host it returned the error /usr/bin/mount.vboxsf: mounting failed with the error: No such device.

I found that the problem was with the kernel 5.4 and installed the LTS kernel (4.19.94-1-lts), what worked fine. However, after upgrading Virtual Box and VBoxAdditions to 6.1, both kernels broke and I can't mount any shared folders.

I reinstalled VBoxGuestAdditions and runned setup (/opt/VboxGuestAdditions-6.1.0/init/vboxadd setup), with no luck.

Any thoughts?

UPDATE: i solved the problem by uninstalling VBoxGuestAdditions (the previous installation made using the iso provided with VirtualBox), and, following directions in this post, reinstalled from pacman. In Machine Settings > Shared Folders unchecked Auto Mount and included the shared folders in fstab. As the cited post states, the VBoxGuestAdditions CD works fine in other distributions (I used it in a Ubuntu Server, without any problems) but, due to the rolling-release nature of Arch, it doesn't work.

Mauricio Fagundes

Re: Can't mount shared folders in 6.1

PostPosted: 22. Apr 2021, 21:27
by josivan
I am facing the same problem. But on windows 10 as host and Linux Elementary as guest.

I don't want to restore to the previous version!

Someone some idea?

Re: Can't mount shared folders in 6.1

PostPosted: 23. Apr 2021, 10:20
by mpack
This was never an "OS X Hosts" question. Topic moved to "Linux Guests".

Shared folders work fine, provided the GAs are installed (see user manual ch4). Nothing more to say until someone provides a VM log.

Re: Can't mount shared folders in 6.1

PostPosted: 2. May 2021, 00:03
by josivan
]It still does not work.

That is the log:

00:04:44.916294 VMMDev: Guest Log: vboxguest: Successfully loaded version 6.1.22 r144080
00:04:44.916339 VMMDev: Guest Log: vboxguest: misc device minor 58, IRQ 20, I/O port d040, MMIO at 00000000f0400000 (size 0x400000)
00:04:44.920232 VMMDev: Guest Log: vboxsf: g_fHostFeatures=0x8000000f g_fSfFeatures=0x1 g_uSfLastFunction=29
00:04:44.920659 VMMDev: Guest Log: vboxsf: Successfully loaded version 6.1.22 r144080 on 5.4.0-72-generic SMP mod_unload modversions (LINUX_VERSION_CODE=0x50465)
00:04:45.011270 VMMDev: Guest Log: vboxsf: SHFL_FN_MAP_FOLDER failed for '/ponte': share not found

The shared folder is there.

Re: Can't mount shared folders in 6.1

PostPosted: 3. May 2021, 22:15
by josivan
I solved...
I just choose another folder name. instead of the suggested one!

Re: Can't mount shared folders in 6.1

PostPosted: 3. May 2021, 23:53
by scottgus1
The "log" posted is just the merest snippet that leaves all the important stuff out. A full log, zipped, and posted with Upload Attachment is much better.

It might have mentioned that Onedrive is having trouble with Virtualbox on your host, which happens sometimes. Your posted shared folder, though quite unnecessarily obfuscated, does mention it is in the Onedrive path.

All of the above is pure speculation because you revealed neither the failing shared folder path, the succeeding one, nor a valid log. So we cannot even start to tell why one folder failed and another succeeded.

But it's good you're up and running! Please keep the principles above in mind for future posts.

Re: Can't mount shared folders in 6.1

PostPosted: 4. May 2021, 17:41
by josivan
Hey, thanks scottgus1.

Yes, that is true, it is a subfolder in onedrive. Obfuscating it was my decision, and it does not make difference, I think.

Regarding the log, I had uploaded a snippet from the VirtualBox's log, and I think you mean the guest log, right? Which one should I upload if required? I can do it if you want to start some investigation.

Finally, it is working now. My only change was instead of using the same name suggested (the lastest selected folder), I choose another one.

For example, I was chosen the folder "ponte", kept the name as "ponte" and the folder/mounting point in the guest also as "ponte".

I just renamed the shared name to a different name and kept all the others as "ponte".

:) :D