Linux guest not booting properly

Discussions about using Linux guests in VirtualBox.

Linux guest not booting properly

Postby hoonkim » 25. Aug 2019, 07:09

I've been having trouble with getting to boot my Linux box through VirtualBox on my Windows 10 host. It is especially strange considering that my Windows 10 guest works without any problem.

The hardware I am using is Ryzen 5 3600, with MSI x570-a pro motherboard. I've toggled the settings (enabling AMD virtualization from the motherboard and disabling Windows Hyper-V) so that I can host 64 OS on VBox. My Windows 10 guest works without any problem, but anytime when I am trying to install Linux (Kubuntu 19 to be precise) it will stay still in the initialization (loading) screen forever. And when I import a preconfigured OVA (this time Kali Linux and Debian), it would display a bunch of [Failed to start] errors (the system fails to start the kernel and almost every systemd stuff) and would just stay in the initialization screen.

I've installed the extension pack, I've played around with the guest settings for more than a week, I've reinstalled VBox more than once, and I feel like I tried everything I can do within VBox, I'm wondering if this is a problem with my computer settings or something of the sort. Or it could be just me missing something very obvious and acting like a dummy.

Any help would be much appreciated!
hoonkim
 
Posts: 2
Joined: 25. Aug 2019, 06:47

Re: Linux guest not booting properly

Postby socratis » 25. Aug 2019, 10:05

hoonkim wrote:I've toggled the settings (enabling AMD virtualization from the motherboard and disabling Windows Hyper-V) so that I can host 64 OS on VBox
Can you? Can you actually create a 64-bit VM? That's good news, that's what it's supposed to happen if AMD-V is enabled in the BIOS, and Hyper-V is disabled.

hoonkim wrote:anytime when I am trying to install Linux (Kubuntu 19 to be precise) it will stay still in the initialization (loading) screen forever
Look at the status bar of your VM. Do you have the "slow" icon (Image), or the proper hardware virtualization icon (Image)? If you have the "slow" one then some Hyper-V component is still active. Look at the topic "I have a 64bit host, but can't install 64bit guests" for some Hyper-V enablers that we're aware of so far.

If that doesn't work, we need to see a complete VBox.log, from a complete VM run, where the problem occurs:
  • Start the VM from cold-boot (not from a paused or saved state) / Observe problem / Shutdown the VM (force close it if you have to).
  • With the VM completely shut down (not paused or saved), right-click on the VM in the VirtualBox Manager and select "Show Log".
  • Save only the first "VBox.log", ZIP it and attach it to your response. See the "Upload attachment" tab below the reply form.
Image
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25308
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Linux guest not booting properly

Postby hoonkim » 26. Aug 2019, 06:23

Thanks for your response. I've attached the error log for both Kali Linux and Kubuntu, I hope this helps, if not, I'll provide with more information

Edit: The icon on VBox shows the hardware virtualization icon and not the slow icon
Attachments
errors.zip
(67.22 KiB) Downloaded 3 times
hoonkim
 
Posts: 2
Joined: 25. Aug 2019, 06:47

Re: Linux guest not booting properly

Postby socratis » 28. Aug 2019, 12:27

00:00:01.549225 NumCPUs <integer> = 0x0000000000000006 (6)
00:00:02.029059 CPUM: Physical host cores: 6
00:00:02.029330 Full Name: "AMD Ryzen 5 3600 6-Core Processor"
You have assigned all your CPUs to the VM. The host is going to run low on resources, since VirtualBox cares about physical processors (cores), not logical ones (threads). See "CPU Cores versus threads" and "Why is it a bad idea to allocate as many VCPUs as there are physical CPUs?".

00:00:01.549329 ICH9 <integer> = 0x0000000000000001 (1)
Any particular reason why you decided to override the template defaults, and go with an unsupported, experimental, OSX-guests-only option? Just hover over the control and read the tooltip. Please change it back to the default PIIX3. Do not change the defaults unless you know what you're getting into.

00:00:01.549431 VMSVGAEnabled <integer> = 0x0000000000000001 (1)
You have the VBoxSVGA option enabled (default for Windows guests), again a deviation from the suggested template defaults, I honestly don't know why you're messing with the proposed settings and then you complain that it doesn't work. Please change it to the default VMSVGA, which is the default for Linux guests.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25308
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5


Return to Linux Guests

Who is online

Users browsing this forum: No registered users and 6 guests