Page 2 of 2

Re: Dual monitor set-up not working anymore since upgrading to VBox 6.0.10

PostPosted: 23. Jul 2019, 19:04
by socratis
Confirmed on an OSX 10.11.6 host with a Mint19-64 Cinnamon guest.

Moving to "Linux Guests" from "Windows Hosts", as this is not exclusively a Windows-host issue...

Re: Dual monitor set-up not working anymore since upgrading to VBox 6.0.10

PostPosted: 31. Jul 2019, 12:31
by gnome.gemini
I have the exactly same problem. One workaround is to use another gpu but you can also install the 6.0.8 guest additions which solves the multi screen problem.

Re: Dual monitor set-up not working anymore since upgrading to VBox 6.0.10 (#18872)

PostPosted: 17. Sep 2019, 14:14
by schoenborno
I have the exact same problem but an odd twist which might be useful for devs to debug: I have two VMs and one works with VMSVGA and the other does not! Details:
  • both VMs are identical as far I can tell from the settings (same HW like memory etc, same OS, same guest additions) EXCEPT that I had to set one VM to use VSVGA
  • both VMs run Ubuntu 18.04.3
  • host is Windows 10 Pro
  • VirtualBox 6.0.12, guest additions version 6.0.12
  • the VM that I had to set to VSVGA has following behavior when I try to run it with VMSVGA:
    • after powering up, the 2 displays appear but display 1 (the main desktop) is not full screen, display 2 is full screen and shows second ie extended desktop;
    • if I resize display 1 (not even to full screen, just anything), it disappears and display 2 shows the main desktop
    • the very first time I started this vm, display 1 was full screen so I was unable to get display 2 to show up at all, the Enable button would stay available etc as described in other posts, then I think I changed its size and restarted and this time display 2 showed up as described in previous item
    • if I make the display 1 full screen and power down, and start again, I cannot make the second display appear, regardless of what I do with the View menu

If there is any comparison of log files or such that would be useful to you, let me know, since one VM works!

Re: Dual monitor set-up not working anymore since upgrading to VBox 6.0.10 (#18872)

PostPosted: 17. Sep 2019, 15:18
by tsela
Any progress on this issue? I just upgraded to 6.0.12 and the VMSVGA graphics controller still does not function correctly with two screens. The issues are identical to what I reported earlier so I don't need to repeat myself. Still using the legacy controller for the time being but it would be nice to have an ETA on when this will be solved, especially given the warnings that the legacy controller will be removed from version 6.1 of VirtualBox.

Re: Dual monitor set-up not working anymore since upgrading to VBox 6.0.10 (#18872)

PostPosted: 18. Sep 2019, 11:05
by socratis
tsela wrote:but it would be nice to have an ETA on when this will be solved

There's never an ETA, so don't expect one... Keep on trying the latest test builds or the new 6.1.0b1, those are your best options...

Re: Dual monitor set-up not working anymore since upgrading to VBox 6.0.10 (#18872)

PostPosted: 18. Sep 2019, 21:36
by benmaxrei
Still don't work with 6.1.0 beta_1.

When i activate the second monitor, the first one scales to minimun resolution.