[Solved] Shared folders will not mount in guest

Discussions about using Linux guests in VirtualBox.

[Solved] Shared folders will not mount in guest

Postby Raspero » 26. Apr 2019, 21:24

I am running an Arch Linux virtual machine in VBox 6.0.5. The host is Ubuntu 16.04

I have installed the Mate desktop. Two shared folders ("stuff" and "pictures" were selected to mount automatically. They show up in the little icon in the system tray at the bottom, but are not being mounted in /media.

I ran the following command as described in the Vbox manual:
[richard@Richard ~]$ sudo mount -t vboxsf stuff /media
[sudo] password for root:
/usr/bin/mount.vboxsf: mounting failed with the error: No such device
[richard@Richard ~]$

Then I re-installed Guest Additions as described below.
Verifying archive integrity... All good.
Uncompressing VirtualBox 6.0.5 Guest Additions for Linux........
VirtualBox Guest Additions installer
Removing installed version 6.0.5 of VirtualBox Guest Additions...
Copying additional installer modules ...
Installing additional modules ...
VirtualBox Guest Additions: Starting.
VirtualBox Guest Additions: Building the VirtualBox Guest Additions kernel
modules. This may take a while.
VirtualBox Guest Additions: To build modules for other installed kernels, run
VirtualBox Guest Additions: /sbin/rcvboxadd quicksetup <version>
VirtualBox Guest Additions: or
VirtualBox Guest Additions: /sbin/rcvboxadd quicksetup all
VirtualBox Guest Additions: Kernel headers not found for target kernel
5.0.8-arch1-1-ARCH. Please install them and execute
/sbin/rcvboxadd setup
VirtualBox Guest Additions: Running kernel modules will not be replaced until
the system is restarted
Press Return to close this window...

I ran the commands: "/sbin/rcvboxadd quicksetup 5.0.8-1"
and "/sbin/rcvboxadd quicksetup all"
as suggested above.

It seems to be asking for headers for kernel 5.0.8-1. This machine is running kernel 5.0.8-1, but the Arch pacman repositories don't list headers for 5.0.8-1. The latest they list is 5.0.7-1

What am I doing wrong?

Last edited by Raspero on 27. Apr 2019, 18:49, edited 2 times in total.
Posts: 18
Joined: 29. Oct 2018, 00:35

Re: Shared folders will not mount in guest

Postby Raspero » 27. Apr 2019, 18:49

My previous post documenting the problem was yesterday. Today I checked Arch pacman again and the kernel headers 5.0.8-1 are now available in a repository.

I installed it, ran the command:
sudo /sbin/rcvboxadd setup

When I rebooted the shared folders were mounted and available.

Posts: 18
Joined: 29. Oct 2018, 00:35

Re: [Solved] Shared folders will not mount in guest

Postby socratis » 27. Apr 2019, 19:27

Glad you got it going. And thank you for marking the topic as [Solved]... ;)
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Site Moderator
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Return to Linux Guests

Who is online

Users browsing this forum: Google [Bot] and 13 guests