Page 1 of 1

VM will not run

PostPosted: 25. Apr 2019, 07:33
by VirtualSA
I cannot get my virtual machine to start. Every time I try, I get the message "A critical error has occurred while running the virtual machine and the machine execution has been stopped." I've tried changing settings within Settings, but none of them ever resolve this issue. Any advice would be greatly appreciated! I have attached the Log file and the PNG screenshot.

Thanks!

Re: VM will not run

PostPosted: 25. Apr 2019, 16:49
by scottgus1
When you get a "Guru Meditation" error you can open the log and search for the words "Guru Meditation" and it will take you right to the problem. Yours is:
00:00:11.971274 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
00:00:11.971275 !!
00:00:11.971275 !! VCPU0: Guru Meditation 1155 (VINF_EM_TRIPLE_FAULT)
00:00:11.971317 !!
00:00:11.971322 !! Skipping ring-0 registers and stack, rcErr=VINF_EM_TRIPLE_FAULT


Triple fault errors mean that the guest operating system tried something really dangeroulsy unusual and Virtualbox says no way.

You can search the forums by entering the CAPITALIZED_UNDERSCORE_SPACED words in a search engine then add "site:forums.virtualbox.org" to restrict the search to these forums, like this:

VINF_EM_TRIPLE_FAULT site:forums.virtualbox.org

Lots of suggestions will come up. A few links suggest that non-optimal guest System settings or a physical hard disk with issues may be part of the problem. Check here: https://www.virtualbox.org/wiki/Guest_OSes to see if this OS is a supported guest OS. Try a disk check & repair in the host OS on the physical disk the guest drive is stored on, and since it's Linux, try a new guest. Be sure to pick the right template. For example, I start the new guest wizard and begin typing the name "Fedora" into the guest Name box. Soon as I get "fe" the template turns to Linux Fedora. Leave what the template picker chooses for now. In the guest's System settings, don't modify any "extended features" or the Acceleration tab unless an error message at the bottom of the Setting windows tells you to. See if Fedora boots then.

Re: VM will not run

PostPosted: 25. Apr 2019, 19:39
by VirtualSA
Thanks for the help and advice. I really appreciate you taking the time to explain it!

Re: VM will not run

PostPosted: 28. Apr 2019, 21:02
by socratis
00:00:02.207307 [/Devices/piix3ide/0/Config/] (level 4)
00:00:02.207308 Type <string> = "ICH6" (cb=5)
This for example goes to the heart of what 'scottgus1' said about modifying the template defaults, this should be PIIX4, not ICH6.

00:00:01.649455 File system of 'E:\VMs\VirtualBox VMs\rrt-ecommerce-001\rrt-ecommerce-001.vmdk' is ntfs
Did you install that VM yourself? Or did you get it from somewhere else? If you installed it yourself, why did you chose the VMDK format? And what's up with the "001" part?

PS. Moving to "Linux Guests" from "Windows Hosts"...