Page 1 of 1

Julia 1.1.0/openblas crash on startup

PostPosted: 3. Apr 2019, 22:03
by pjc
I have VirtualBox 5.2.26 r128414 running on ubuntu 16.04 with a ubuntu 16.04 guest.

I can run julia fine on host and other machines but get the following when attempting to run in the virtualbox guest:
Invalid instruction at 0x7facc73018c2: 0x62, 0xf1, 0x7d, 0x48, 0xef, 0xc0, 0x41, 0x56, 0x41, 0x55, 0x41, 0x54, 0x55, 0x53, 0x48

signal (4): Illegal instruction
in expression starting at no file:0
dot_compute at /home/pjc/opt/julia/JuliaPro-1.0.3.1/Julia/bin/../lib/julia/libopenblas64_.so (unknown line)
unknown function (ip: 0xf)
Allocations: 59755 (Pool: 59740; Big: 15); GC: 0

Julia has exited. Press Enter to start a new session.

I am assuming that the issue lies with my VirtualBox settings somehow because runs fine on host but maybe not?

Any suggestions?

Re: Julia 1.1.0/openblas crash on startup

PostPosted: 3. Apr 2019, 22:45
by socratis
pjc wrote:I can run julia
Julia, as in https://julialang.org/downloads/ and the "Generic Linux Binaries for x86", version 1.1.0? The 32- or the 64-bit one? I'm gonna download the 64-bit, just out of a hunch... ;)

pjc wrote:I am assuming that the issue lies with my VirtualBox settings somehow
Well, we'd need to see them for ourselves, no? And the best way to do that is to get a complete VBox.log, from a complete VM run, where the problem occurs:
  • Start the VM from cold-boot (not from a paused or saved state) / Observe problem / Shutdown the VM (force close it if you have to).
  • With the VM completely shut down (not paused or saved), right-click on the VM in the VirtualBox Manager and select "Show Log".
  • Save only the first "VBox.log", ZIP it and attach it to your response. See the "Upload attachment" tab below the reply form.
Image

Re: Julia 1.1.0/openblas crash on startup

PostPosted: 3. Apr 2019, 23:19
by pjc
Many thanks.

Quite right, here is a more complete info

julia 1.1.0 linux generic 64: https://julialang-s3.julialang.org/bin/ ... _64.tar.gz
install, just unzip and run {julia_unzip_path}/bin/julia, see here https://julialang.org/downloads/platform.html

Re: Julia 1.1.0/openblas crash on startup

PostPosted: 4. Apr 2019, 18:44
by pjc
I've since learned that this is probably being caused by a known issue in the OpenBLAS library, see here: https://github.com/xianyi/OpenBLAS/issues/1947.

I don't run into this issue when I run julia (with this OpenBLAS lib embedded) directly on the host machine or in a docker image run on the host machine but still the error message appears identical.

I think we can wait until OpenBLAS fixes the issue.

Thanks for looking at this.