[Invalid] Debian 10 (buster) Copy paste not working (#18511)

Discussions about using Linux guests in VirtualBox.

Re: Debian 10 (buster) Copy paste not working (#18511)

Postby socratis » 1. Apr 2019, 11:40

I was editing me message to say that I'll go with the debian-buster-DI-alpha5-amd64-xfce-CD-1.iso one, but I'll download your firmware-buster-DI-alpha5-amd64-i386-netinst.iso version too and test it as well.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25828
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Debian 10 (buster) Copy paste not working (#18511)

Postby Federico M. » 1. Apr 2019, 11:45

socratis wrote:When you installed the GAs in the guest... that part, the terminal output. You can reinstall the GAs if you want and grab that output.

You know I cannot copy, but I can attach a screenshot... :D
Attachments
Capture-2.jpg
Capture-2.jpg (62.19 KiB) Viewed 356 times
Federico M.
 
Posts: 16
Joined: 27. Mar 2019, 10:32

Re: Debian 10 (buster) Copy paste not working (#18511)

Postby Federico M. » 1. Apr 2019, 11:50

You should check my video: it is better than words (and maybe you can understand the problem just watching it).
Federico M.
 
Posts: 16
Joined: 27. Mar 2019, 10:32

Re: Debian 10 (buster) Copy paste not working (#18511)

Postby socratis » 1. Apr 2019, 12:19

I did check your video! And it has absolutely nothing to do with VirtualBox!!!

It's not a question of Copy/Paste (C/P) not working with VirtualBox, that would mean that C/P doesn't work between host and guest. You can't even C/P inside your guest!!! :o

There's something fundamentally wrong not being able to C/P within the guest. And it's not VirtualBox, I can guarantee you that much.

Did you have that problem even before installing the GAs?
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25828
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Debian 10 (buster) Copy paste not working (#18511)

Postby Federico M. » 1. Apr 2019, 12:22

socratis wrote:There's something fundamentally wrong not being able to C/P within the guest. And it's not VirtualBox, I can guarantee you that much.
Did you have that problem even before installing the GAs?

I never said that I believe it is a problem due to Virtualbox... maybe yes, maybe not. I simply do not know. :roll:

And yes, I have the issue also without GAs (I said that before).
Federico M.
 
Posts: 16
Joined: 27. Mar 2019, 10:32

Re: Debian 10 (buster) Copy paste not working (#18511)

Postby socratis » 1. Apr 2019, 12:23

Federico M. wrote:And yes, I have the issue also without GAs (I said that before).

Then this is clearly not a VirtualBox issue, but a Debian issue. Just because an OS/program that runs in the context of VirtualBox has a problem, it doesn't make it a VirtualBox problem necessarily. You're having an issue that has nothing to do with VirtualBox, so my suggestion would be to treat it as such, as a native problem with the OS or the application of the guest.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25828
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Debian 10 (buster) Copy paste not working (#18511)

Postby Federico M. » 1. Apr 2019, 14:13

I plan to install it on a plain PC, to verify that it is not related to VB.

Thanks for your support.
Federico M.
 
Posts: 16
Joined: 27. Mar 2019, 10:32

Re: Debian 10 (buster) Copy paste not working (#18511)

Postby socratis » 1. Apr 2019, 16:55

I just tested the "debian-buster-DI-alpha5-amd64-xfce-CD-1.iso", since I had already downloaded it ;)
No problems found. BTW, it *does* come with its own, pre-installed version of the GAs:
00:00:09.928661 VMMDev: Guest Additions information report: Version 5.2.0 r68940 '5.2.0'
C/P was working inside the VM, and because of that pre-existing GAs, between host and guest.

I'm going to try the one that you have and see what happens...
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25828
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Debian 10 (buster) Copy paste not working (#18511)

Postby Federico M. » 2. Apr 2019, 07:51

Federico M. wrote:I plan to install it on a plain PC, to verify that it is not related to VB.

I wanted to try installing Debian Buster on a plain PC, but for my old i386 laptop there is no kernel available.

I created a topic in the Debian forum as well: http://forums.debian.net/viewtopic.php?f=10&t=141424
Federico M.
 
Posts: 16
Joined: 27. Mar 2019, 10:32

Re: Debian 10 (buster) Copy paste not working (#18511)

Postby socratis » 2. Apr 2019, 17:43


I tested both ISO. Couldn't reproduce it. Something is not right with your way of testing, but this is not VirtualBox doing it. Just as in the ticket, marking this as [Invalid].
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25828
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: [Invalid] Debian 10 (buster) Copy paste not working (#18511)

Postby Federico M. » 2. Apr 2019, 18:19

I will try to figure out with some people in the Debian forum.
Thank you for your help.
Federico M.
 
Posts: 16
Joined: 27. Mar 2019, 10:32

Previous

Return to Linux Guests

Who is online

Users browsing this forum: No registered users and 6 guests