Page 1 of 1

No start of Antergos after Update

PostPosted: 25. Feb 2019, 16:59
by an0n1mous
Hello,

Antergos won't run after a Update. I don't know, if it is the Antergos-Update or the VBox-Update or both...

But I can give you the report, VBox give me out, when I start unsuccessfull Antergos on my Antergos-Host.

One last tip. When I start an older protection point, a protection point from 22.02.2019, then Antergos start perfekt. The problem appears in that case after die date.

I hope you could help, because so I could not import any Update of Antergos and/or VBox and the system is UNSAFE! In my eyes, this is a big catastrophe. :-(

This problem is also here posted: https://forum.antergos.com/topic/11432/ ... ter-update

Re: No start of Antergos after Update

PostPosted: 25. Feb 2019, 17:20
by mpack
The error message highlighted is caused by upgrading VirtualBox while the VM was in a suspended state. Right click the VM in the manager and discard the saved state: the VM will behave like a physical PC after a power cut.

Re: No start of Antergos after Update

PostPosted: 25. Feb 2019, 17:26
by an0n1mous
@ mpack: Sorry, but so clever I also was.

When I delete the protection point which makes problems, then I take the working protection point vom 22.02.2019, then I make Updates and a reboot, then safing the new state of the maschine, then I close the maschine, then I start the new protection point and the problem is the same.

ONLY the old protection point works, but I am not allowed to update the old working state, because then the problem appears.

Re: No start of Antergos after Update

PostPosted: 25. Feb 2019, 17:32
by mpack
It isn't clear to me what you are saying. The error is with a saved state file trying to restore a state that is incompatible with the upgraded version of VirtualBox. If the saved state is discarded then the error cannot occur.

Re: No start of Antergos after Update

PostPosted: 25. Feb 2019, 17:48
by an0n1mous
Update:

1. I take the working protection point (the machine did not boot, the working protection point is a running (!) machine) and start all updates
2. I reboot the machine
3. I save the new state of the machine with the updates

The rest would be important:

4. I turn off the machine completely (so that the machine have to boot after starting)
5. The machine boot
6. Now Antergos ist running, without problems -> I make a new protection point of the RUNNING machine
7. I close the machine
8. I start the machine without problems :-)

WORKAROUND

Re: No start of Antergos after Update

PostPosted: 25. Feb 2019, 18:08
by socratis
Take a look at the Known Issues in the "Discuss the 6.0.0 release" post.

You are seeing the effects of saved states not being restored in 6.0.x. There are three of them (and many, many duplicates):