Page 3 of 4

Re: Mint/Cinnamon "running in software rendering mode"

PostPosted: 11. Oct 2018, 18:01
by socratis
Interesting... I use the Cinnamon version and I don't have that problem. Maybe it is indeed the host's capabilities...

Re: Mint/Cinnamon "running in software rendering mode"

PostPosted: 17. Dec 2018, 16:50
by anuadewuyi
Hi Socratis.

I am experiencing this same issue. Since this thread wasn't closed/solved, I decided to post here.

Please find my VBox.log attached as prescribed.

Here is a picture of my VB-GA installation:
VB-GA_Install.png
VB-GA_Install.png (117.75 KiB) Viewed 1229 times

Re: Mint/Cinnamon "running in software rendering mode"

PostPosted: 18. Dec 2018, 09:18
by socratis
@anuadewuyi
I couldn't find anything out of the ordinary in your log, except maybe the following:
00:00:02.918008 OpenGL Info: Render SPU: GL_VENDOR:   Intel
00:00:02.918017 OpenGL Info: Render SPU: GL_RENDERER: Intel(R) HD Graphics 630
00:00:02.918021 OpenGL Info: Render SPU: GL_VERSION: 4.5.0 - Build 23.20.16.4973

Intel GPUs are not the most powerful in the market, and their software isn't the most "textbook" implementation, they have been known to have issues with VirtualBox.

That's all I have I'm afraid...

Re: Mint/Cinnamon "running in software rendering mode"

PostPosted: 21. Dec 2018, 18:29
by Dave B
Hi anuadewuyi,

Using a recent Guest Additions test build with VirtualBox 5.2.22 should hopefully fix the issue. Alternatively, replace VirtualBox 5.2.22 with version 6.0.0 and select VMSVGA from Settings -> Display -> Graphic Controller: to prevent a display 'bloom' issue with the Cinnamon edition (using VMSVGA creates a different niggle, but that's for another thread!).

If install VirtualBox 6.0.0, don't forget to update the Guest Additions.

socratis wrote:...BTW I don't need to see a picture of a successful installation of the GAs over and over again, only if there's an error or a warning...

For fun considered adding a GA successful installation screen capture, but thought best not! :D

Re: Mint/Cinnamon "running in software rendering mode"

PostPosted: 29. Dec 2018, 02:17
by oferdavidi
The solution, to resolve the issue for me was:

Install VirtualBox 6.0.0
Graphic Controller : VMSVGA
Acceleration: 3D enabled

See attached :)

Re: Mint/Cinnamon "running in software rendering mode"

PostPosted: 15. Jan 2019, 19:35
by BlanderSQL
I was able to run Linux Mint DE 3 "Cindy" with Cinnamon DE using Virtualbox version 6.0.2 with the included Guest Additions and the graphics controller left at VBoxVGA.
I did not get the software rendering warning.

edit: well, that seemed to mess up the screensaver. So, now I'm back to VMSVGA with 6.0.3 GA and still getting software rendering mode. but the screen saver works i guess.

Re: Mint/Cinnamon "running in software rendering mode"

PostPosted: 21. Feb 2019, 18:32
by leonardopereira
oferdavidi wrote:The solution, to resolve the issue for me was:

Install VirtualBox 6.0.0
Graphic Controller : VMSVGA
Acceleration: 3D enabled

See attached :)


Hello @oferdavidi

I just installed VB 6 and did what you said, but the problem continues. At least it did not give a "black screen", but continues 'running in rendering mode' (see attachments).

In my case it is:
* VB 6.0.4
* Linux Mint 19 (Tara)

For everyone ... Another problem I noticed is that I can not use two monitors anymore. What can this be?

Thanks

Re: Mint/Cinnamon "running in software rendering mode"

PostPosted: 21. Feb 2019, 19:50
by socratis
@leonardopereira
Try with the VBoxVGA option for the Graphics controller, see how that goes...

Re: Mint/Cinnamon "running in software rendering mode"

PostPosted: 21. Feb 2019, 20:43
by leonardopereira
@socratis When I use 'VBoxVGA' black screen appears after login. I have already used nvidia410 and nvidia390, but with both these driver versions the message 'Running in software rendering mode' appears. :(

Re: Mint/Cinnamon "running in software rendering mode"

PostPosted: 21. Feb 2019, 21:14
by socratis
leonardopereira wrote:When I use 'VBoxVGA' black screen appears after login
That's interesting, because I actually have two Mint 19 VMs; one standard vanilla, and one that I've configured to build VirtualBox from source. As you can imagine, I don't have any problem with either of them.

I need to see a complete VBox.log, from a complete VM run, where the problem occurs:
  • Start the VM from cold-boot (not from a paused or saved state) / Observe problem / Shutdown the VM (force close it if you have to).
  • With the VM completely shut down (not paused or saved), right-click on the VM in the VirtualBox Manager and select "Show Log".
  • Save only the first "VBox.log", ZIP it and attach it to your response. See the "Upload attachment" tab below the reply form.
Image

Re: Mint/Cinnamon "running in software rendering mode"

PostPosted: 21. Feb 2019, 21:27
by leonardopereira
Here...

Re: Mint/Cinnamon "running in software rendering mode"

PostPosted: 23. Feb 2019, 10:02
by leop
I also cannot run Cinnamon except in the software rendering mode (Fedora FC29 guest on Win10, Vbox 6.04). I use VBoxVGA for the graphics controller. This is the hardenederror I get from the VBox log:
00:00:06.640506 supR3HardenedErrorV: supR3HardenedScreenImage/NtCreateSection: rc=VERR_BAD_EXE_FORMAT fImage=1 fProtect=0x5 fAccess=0x2 \Device\HarddiskVolume2\Windows\System32\DriverStore\FileRepository\c0318486.inf_amd64_11ba0b4b7cc81d52\atikmdag.sys: NumberOfSections=116, implementation max is 42
00:00:06.640934 supR3HardenedErrorV: supR3HardenedScreenImage/NtCreateSection: cached rc=VERR_BAD_EXE_FORMAT fImage=1 fProtect=0x2 fAccess=0x5 cHits=1 \Device\HarddiskVolume2\Windows\System32\DriverStore\FileRepository\c0318486.inf_amd64_11ba0b4b7cc81d52\atikmdag.sys

I have read the FAQ for Diagnosing VirtualBox Hardening Issues carefully and still cannot figure things out. Yes, the error is with the atikmdag.sys driver and the driver is the latest from MIcrosoft for win10. Can someone please help my old, addled mind?

Re: Mint/Cinnamon "running in software rendering mode"

PostPosted: 23. Feb 2019, 11:01
by socratis
@leop
Download the stand alone ATI drivers for your card from ATI's site and reinstall them. The drivers may be signed, but that may not be reflected in the Windows Certificate Database. A fresh re-install might jolt things back into their proper state...

Re: Mint/Cinnamon "running in software rendering mode"

PostPosted: 24. Feb 2019, 04:53
by leop
No joy. There are the same hardening errors after both removing and reinstalling the Microsoft drivers and newly installing the latest drivers from AMD. I do not understand the bad exe format for atikngag.sys and how this is related to hardening.

LeoP

Re: Mint/Cinnamon "running in software rendering mode"

PostPosted: 24. Feb 2019, 08:17
by socratis
leop wrote: I do not understand the bad exe format for atikngag.sys and how this is related to hardening.

Diagnosing VirtualBox Hardening Issues.