[Solved] Mint/Cinnamon "running in software rendering mode"

Discussions about using Linux guests in VirtualBox.

[Solved] Mint/Cinnamon "running in software rendering mode"

Postby leonardopereira » 17. Aug 2018, 19:13

Message when opening my virtual machine:
Running in software rendering mode
Cinnamon is currently running without video hardware acceleration and, as a result, you may observe much higher than normal CPU usage.
There could be a problem with your drivers or some other issue. For the best experience, it is recommended that you use this mode for troubleshooting purposes.

I'm using:
  • Window 10 Pro
  • NVIDIA GeForce 210 - Driver version 21.21.13.4201 (14/11/2016)
  • VirtualBox 5.2.16
  • Linux Mint 18.1
The virtual 'guest additions' is already up to date, as viewtopic.php?f=3&t=79486

If I set up the virtual machine to use 3D acceleration, the screen is all black. It only works if I uncheck it. How do I make the 3D acceleration of the graphics card work?

Thank you so much.
Last edited by socratis on 23. May 2019, 21:35, edited 3 times in total.
Reason: Marked as [Solved].
leonardopereira
 
Posts: 20
Joined: 16. Aug 2018, 16:42
Primary OS: MS Windows 10
VBox Version: OSE Debian
Guest OSses: Linux Mint 18

Re: Mint/Cinnamon "running in software rendering mode"

Postby socratis » 18. Aug 2018, 11:04

leonardopereira wrote:The virtual 'guest additions' is already up to date
I'd like to see some evidence of that, from a complete VM run, with 3D acceleration enabled:
  • Start the VM from cold-boot (not from a paused or saved state) / Observe error / Shutdown the VM (force close it if you have to).
  • With the VM completely shut down (not paused or saved), right-click on the VM in the VirtualBox Manager and select "Show Log".
  • Save only the first "VBox.log", ZIP it and attach it to your response. See the "Upload attachment" tab below the reply form.
leonardopereira wrote:If I set up the virtual machine to use 3D acceleration, the screen is all black. It only works if I uncheck it.
If you don't use 3D acceleration, you are going to get that original warning from Mint. It's a warning telling you that the fancy 3D animations might not work, or might not work as expected. It's not a really big issue.

But, let's try to figure out what the log says about 3D acceleration...
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25932
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Mint/Cinnamon "running in software rendering mode"

Postby lycos » 21. Aug 2018, 13:57

This isn't new. This is happening only with the Cinnamon desktop environment (DE) at least one or two years. I see the same message with Arch Linux+Cinnamon DE and with Linux Mint+Cinnamon DE guests (with Arch Linux or Window 10 hosts). But I don't see this message with xfce DE (with Arch Linux or Linux Mint xfce) or any other DE or Windows. Sad thing I mostly use the Cinnamon desktop...
lycos
 
Posts: 1
Joined: 21. Aug 2018, 13:43

Re: Mint/Cinnamon "running in software rendering mode"

Postby leonardopereira » 21. Aug 2018, 17:25

@socratis, the requested log is attached. Thanks
Attachments
VBox-2018-08-21-12-19-37.zip
(34.84 KiB) Downloaded 46 times
leonardopereira
 
Posts: 20
Joined: 16. Aug 2018, 16:42
Primary OS: MS Windows 10
VBox Version: OSE Debian
Guest OSses: Linux Mint 18

Re: Mint/Cinnamon "running in software rendering mode"

Postby mpack » 21. Aug 2018, 17:53

I'm seeing the hardware 3D acceleration loading... in fact I'm seeing it being loaded more times than I would expect in such a short runtime.

Where do you see this "running in software rendering mode" message?

I disabled your signature. Please do not use this site to disseminate your religious preferences.
mpack
Site Moderator
 
Posts: 29832
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Mint/Cinnamon "running in software rendering mode"

Postby socratis » 21. Aug 2018, 18:55

00:00:03.429908 File system of 'C:\Users\leonardo.LAMCSO\VirtualBox VMs\Mint_x64_riserWeb\
Mint_x64_riserWeb_1-disk002.vmdk' is ntfs
Did you create that VM from scratch? Or did you download it pre-instaled from somewhere? Because the name of the VM, the name of the disk (not the same as the VM), the 002 part, and the VMDK option are pointing to a premade VM.

00:00:03.425304 Guest OS type: 'Debian_64'
You might want to change that to "Ubuntu 64". Much closer relationship. You're talking brothers vs. 4th cousins. ;)

00:00:04.966308 NumCPUs <integer> = 0x0000000000000004 (4)
00:00:05.795291 CPUM: Physical host cores: 4
You have assigned all your CPUs to the VM. The host is going to run low on resources, since VirtualBox cares about physical processors (cores), not logical ones (threads). See "CPU Cores versus threads" and "Why is it a bad idea to allocate as many VCPUs as there are physical CPUs?".

00:00:04.966580 MonitorCount <integer> = 0x0000000000000002 (2)
How about starting with the default options and then go for the more advanced ones? You know, once you have established a working basis. Lower the monitor count to 1 please.

00:00:04.966594 Provider <string>  = "HyperV" (cb=7)
Hyper-V? For a Linux guest? What's going on here? Are you messing with options at random? Do you realize what that option does? If not, you shouldn't be messing with things that you don't understand completely. Again, stick with the defaults. They're there for a reason; they work.

00:00:05.813739 Host path 'C:\', map name 'C_DRIVE', writable, automount=true, create_symlinks=false, missing=false
00:00:05.814037 Host path 'D:\', map name 'D_DRIVE', writable, automount=true, create_symlinks=false, missing=false
It's a really, really bad idea to give Read/Write access to your whole hard drive! Even a bug, an issue, a mistake, could wipe important/vital files from your system. Instead dedicate a single directory for a read/write access. Even a Read-Only access to your ... everything, could be dangerous from a security point of view. Isolation, that's the keyword.

00:01:36.413895 supR3HardenedErrorV: supR3HardenedScreenImage/LdrLoadDll:
rc=VERR_CR_PKCS7_KEY_USAGE_MISMATCH fImage=1 fProtect=0x0 fAccess=0x0
\Device\HarddiskVolume2\Windows\System32\nvwgf2umx.dll: fKeyUsage=0x0, missing 0x1:
\Device\HarddiskVolume2\Windows\System32\nvwgf2umx.dll
You're having a hardening error with your NVidia drivers. They're trying to load, but they're thrown away, either because they're not properly signed, or they got updated and they didn't update the Microsoft Certificate Database (most likely).

Please read really carefully the following FAQ: Diagnosing VirtualBox Hardening Issues for some generic guidelines/ideas. I'd start by (re)downloading and installing the latest drivers for your NVidia GPU.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25932
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Mint/Cinnamon "running in software rendering mode"

Postby leonardopereira » 21. Aug 2018, 19:28

Dear @socratis, thank you for the quick answers. I'll try to answer your questions.

  1. Yes, this VM was created from scratch, but it was not me. This 002 part was because at one point I needed to expand virtual disk space using VBoxManage.exe (clonehd and modifyhd);
  2. On Ubuntu x Debian, I apologize. I'm new to this Linux world :-) I'll try to change it;
  3. On CPU cores, my machine has 8. And I use inside this parallel processing VM. But 2 cores are enough. I'll change it;
  4. I will change the number of monitors to 1 only. I did not know that would make any difference ... I saw that I had this feature and I'm using it. I'll alter it and see if it is interfering in any way;
  5. About Hyper-V, I do not know what it's all about. Since this VM was created by someone else, I do not know where that is set up. In that case, do I have to re-create the VM or just change a configuration?
  6. Thanks for your correction regarding sharing of entire disks. I'll change that now;
  7. Regarding the NVidia drivers, they are already updated. I just do not know (yet) about their signature. I'll check.
OBS .: Forgiveness also for my poor english
Last edited by socratis on 21. Aug 2018, 19:30, edited 1 time in total.
Reason: Fixed formatting.
leonardopereira
 
Posts: 20
Joined: 16. Aug 2018, 16:42
Primary OS: MS Windows 10
VBox Version: OSE Debian
Guest OSses: Linux Mint 18

Re: Mint/Cinnamon "running in software rendering mode"

Postby socratis » 21. Aug 2018, 20:09

leonardopereira wrote:On CPU cores, my machine has 8.
Well, actually...? No. It doesn't. It only has 4, sorry to disappoint you... ;)
Just take a look at your log:
00:00:05.795514 Full Name: "Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz"
That's what you have, right? Now, go to the Intel website that describes your i7-2600 @ 3.40GHz CPU. In the Performance section you can clearly see that you have 4 cores, not 8. You may have 8 threads, but VirtualBox doesn't really care about threads, it cares about cores.

Just click on the question mark next to Cores/Threads to see which one is a hardware feature, and which one is a marketing software feature. ;)

leonardopereira wrote:About Hyper-V, I do not know what it's all about.
It helps with exposing the paravirtualization interface to the VM. "Hyper-V" is used for Windows guests. For a Linux guest you should use "KVM". Or, even better, you select "Default", and you let VirtualBox do the work for you.

leonardopereira wrote:I will change the number of monitors to 1 only ... I'll alter it and see if it is interfering in any way;
No, it won't, you have a hardening error and your 3D setting cannot work. But that wasn't the point, the point was to stick with the defaults untii you have the whole thing going.

leonardopereira wrote:Yes, this VM was created from scratch, but it was not me.
If you have nothing that you care about in the VM, i would strongly urge you to delete the whole thing and start from scratch. With the appropriate disk size this time ;)

leonardopereira wrote:Regarding the NVidia drivers, they are already updated. I just do not know (yet) about their signature. I'll check.
There's a program called "SignTool.exe" from Microsoft that you can use it to verify the signatures of various files, as part of the Microsoft SDK (not sure if you need all of it). See what it has to say about the signatures...
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25932
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Mint/Cinnamon "running in software rendering mode"

Postby leonardopereira » 21. Aug 2018, 20:25

:shock:
It's ... definitely my hardware knowledge is more limited than I imagined. I will continue with my codes that I will be happier :D

socratis wrote:If you have nothing that you care about in the VM, i would strongly urge you to delete the whole thing and start from scratch. With the appropriate disk size this time ;)

I'll think seriously about this. But since this 3D acceleration problem is not a critical problem, I'll leave it for later.

socratis wrote:There's a program called "SignTool.exe" from Microsoft that you can use it to verify the signatures of various files

Thank you. If I get a different result, I'll post it here.
leonardopereira
 
Posts: 20
Joined: 16. Aug 2018, 16:42
Primary OS: MS Windows 10
VBox Version: OSE Debian
Guest OSses: Linux Mint 18

Re: Mint/Cinnamon "running in software rendering mode"

Postby leonardopereira » 21. Aug 2018, 20:29

mpack wrote:Where do you see this "running in software rendering mode" message?

As soon as the Mint desktop opens, in the upper right corner.
leonardopereira
 
Posts: 20
Joined: 16. Aug 2018, 16:42
Primary OS: MS Windows 10
VBox Version: OSE Debian
Guest OSses: Linux Mint 18

Re: Mint/Cinnamon "running in software rendering mode"

Postby leonardopereira » 23. Aug 2018, 15:07

Everything is the same. I will follow your recommendation:
socratis wrote:I would strongly urge you to delete the whole thing and start from scratch


I conclude this question. Once again I appreciate the time you have spent helping me. I learned some more with you.
leonardopereira
 
Posts: 20
Joined: 16. Aug 2018, 16:42
Primary OS: MS Windows 10
VBox Version: OSE Debian
Guest OSses: Linux Mint 18

Re: Mint/Cinnamon "running in software rendering mode"

Postby socratis » 23. Aug 2018, 16:24

Let us know how a fresh install went, so we could close the thread as [Solved].

(sort of, a re-install is not the best solution ;))
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25932
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Mint/Cinnamon "running in software rendering mode"

Postby CraigH » 26. Aug 2018, 01:23

I am having the same problem with Mint19 x64 Cinnamon. Created a log file as specified above, included with this post. This appears to have all the pertinent information about my system. Did a clean install of the guest from .iso. Have also updated to the latest virtualbox-guest-additions. Have noticed that each time I use the file/close option a greyed-out version of the working screen is displayed. If I cancel and try performing some activity, the next file/close will update the display showing the activity. Hoping you have the answers. Thanks.

Mint19 x64-2018-08-25-15-56-52.zip
3D acceleration Black Screen log
(30.9 KiB) Downloaded 39 times
CraigH
 
Posts: 3
Joined: 26. Aug 2018, 01:06

Re: Mint/Cinnamon "running in software rendering mode"

Postby socratis » 26. Aug 2018, 10:06

@CraigH
00:00:34.084887 supR3HardenedErrorV: supR3HardenedScreenImage/LdrLoadDll:
rc=VERR_CR_PKCS7_KEY_USAGE_MISMATCH fImage=1 fProtect=0x0 fAccess=0x0
\Device\HarddiskVolume2\Windows\System32\nvwgf2umx.dll: fKeyUsage=0x0, missing 0x1:
\Device\HarddiskVolume2\Windows\System32\nvwgf2umx.dll
00:00:34.085030 supR3HardenedErrorV: supR3HardenedMonitor_LdrLoadDll:
rejecting 'C:\WINDOWS\System32\nvwgf2umx.dll': rcNt=0xc0000190

You have the exact symptoms as the OP; a hardening error and your NVidia drivers get rejected. Please read really carefully the following FAQ: Diagnosing VirtualBox Hardening Issues for some generic guidelines/ideas. Remember, these are guidelines, not the exact solution, you have to use your judgement as to which program might be responsible...

I'd start by downloading and re-installing the latest NVidia drivers.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25932
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Mint/Cinnamon "running in software rendering mode"

Postby CraigH » 28. Aug 2018, 01:49

@socratis
Thanks for the quick response. After reading the link provided, I understand the problem, but there is virtually nothing I can do to solve it. I am already using the latest NVIDIA drivers (342.01 WHQL), which haven't been updated since 12/14/2106. The certificate for the nvwgf2umx.dll is out of date (since July 2018). The only other option is to build VirtualBox without the hardening option. This is something neither I nor any other normal user would be willing to try. The developers of VirtualBox should really provide an option to white-list specific dll's, or turn of hardening completely.

The workaround I have decided to use is to switch from Cinnamon to XFCE as the destop manager. XFCE is not as nice, but it doesn't use OpenGL, and therefore bypasses the issue. Have not tried Mate to see if it is also an option.
Thanks for your help.
Craig
CraigH
 
Posts: 3
Joined: 26. Aug 2018, 01:06

Next

Return to Linux Guests

Who is online

Users browsing this forum: No registered users and 12 guests