Persistent Kernel Panics on Ubuntu 14.04 LTS machines after updating Guest Additions

Discussions about using Linux guests in VirtualBox.

Persistent Kernel Panics on Ubuntu 14.04 LTS machines after updating Guest Additions

Postby RedScourge » 27. Jun 2018, 08:29


I have been using an Ubuntu 14.04 LTS guest within an Ubuntu 16.04 LTS host (running recent Intel hardware) for quite a while now, and all of a sudden when upgrading the Linux host from 5.1.20 to 5.2.20, and then the Linux Guest Additions on the guest, there was some sort of vague warning of a problem when it tried to uninstall the old Guest Additions, and then when installing the new Guest Additions, suddenly I got a kernel panic immediately once it loaded the drivers. Other than that, things seemed to work fine, until I noticed that the machine can no longer reboot when these Guest Additions are loaded into the kernel. The machine locks up before it gets to fully reboot, with no easy way to determine what was going on, requiring a forced reset of the guest. Upon restart, there is another kernel panic early in the startup, and any subsequent attempt to reboot the machine will cause it to lock again. Fully removing the Guest Additions is the only workaround I have found so far to avoid these lock-ups when shutting down or rebooting, and re-adding the Guest Additions causes the issue to appear again.

I recently had to rebuild an older Ubuntu 14.04 LTS guest because it was the only way I could bypass the issue other than leaving the Guest Additions uninstalled. I am not sure why reinstalling seems to fix it, unless perhaps fresh installs of 14.04 use a different kernel or something like that. It exhibited the exact same behavior after a previous update from 5.0.22 to 5.1.2, which I did not bother to report as I figured it was perhaps a one-off issue, and so I am hoping I will not have to rebuild this one too.

Here's a dump of uname -a of the host in question (basically, the latest kernel on Ubuntu 16.04 LTS):

Code: Select all   Expand viewCollapse view
Linux vmhost1.aplus 4.4.0-128-lowlatency #154-Ubuntu SMP PREEMPT Fri May 25 15:22:25 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Here's a dump of uname -a of the guest in question (basically, the latest kernel on Ubuntu 14.04 LTS):

Code: Select all   Expand viewCollapse view
Linux 3.13.0-151-generic #201-Ubuntu SMP Wed May 30 14:22:13 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Here is the output of the kernel panic:

Code: Select all   Expand viewCollapse view
vboxguest: module verification failed: signature and/or  required key missing - tainting kernel
vgdrvHeartbeatInit: Setting up heartbeat to trigger every 2000 milliseconds
input: Unspecified device as /devices/pci0000:00/0000:00:04.0/input/input6
vboxguest: misc device minor 57, IRQ 20, I/O port d020, MMIO at 00000000f0400000 (size 0x400000)
vboxguest: Successfully loaded version 5.2.12 (interface 0x00010004)
ACPI: Video Device [GFX0] (multi-head: yes  rom: no  post: no)
piix4_smbus 0000:00:07.0: SMBus Host Controller at 0x4100, revision 0
input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A03:00/LNXVIDEO:00/input/input7
[drm] Initialized drm 1.1.0 20060810
EXT4-fs (sdc1): mounted filesystem with ordered data mode. Opts: (null)
BUG: unable to handle kernel NULL pointer dereference at 0000000000000030
IP: [<ffffffffa01d0e0e>] drm_dev_register+0x2e/0x1f0 [drm]
PGD 80000000365ae067 PUD 35e83067 PMD 0
Oops: 0000 [#1] SMP
Modules linked in: vboxvideo(OX+) ttm glue_helper ablk_helper drm_kms_helper cryptd drm syscopyarea joydev sysfillrect i2c_piix4 serio_raw video sysimgblt mac_hid vboxguest(OX) lp parport nls_utf8 cifs fscache hid_generic usbhid hid psmouse ahci e1000 libahci pata_acpi
CPU: 1 PID: 412 Comm: systemd-udevd Tainted: G           OX 3.13.0-151-generic #201-Ubuntu
Hardware name: innotek GmbH VirtualBox/VirtualBox, BIOS VirtualBox 12/01/2006
task: ffff880036438000 ti: ffff88003656a000 task.ti: ffff88003656a000
RIP: 0010:[<ffffffffa01d0e0e>]  [<ffffffffa01d0e0e>] drm_dev_register+0x2e/0x1f0 [drm]
RSP: 0018:ffff88003656bb38  EFLAGS: 00010246
RAX: ffffffffa0265100 RBX: ffff8800d9a96800 RCX: 0000000000000003
RDX: 0000000000000000 RSI: 0000000000000000 RDI: ffffffffa01fc000
RBP: ffff88003656bb50 R08: 0000000000000046 R09: ffff88003656bad4
R10: 0000000000000010 R11: ffffffff81406b60 R12: ffff88011956d000
R13: 0000000000000000 R14: ffffffffa0265100 R15: 0000000000000000
FS:  00007f79fddd4880(0000) GS:ffff88011fd00000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
CR2: 0000000000000030 CR3: 0000000036578000 CR4: 0000000000060670
 ffff8800d9a96800 ffff88011956d000 ffff88011956d098 ffff88003656bba0
 ffffffffa01d2d92 0000000000000004 ffff88011956d140 ffffffffa02641e0
 ffff88011956d000 0000000000000000 ffffffffa0265000 ffff88011956d098
Call Trace:
 [<ffffffffa01d2d92>] drm_get_pci_dev+0x92/0x140 [drm]
 [<ffffffffa025ea75>] vbox_pci_probe+0x15/0x20 [vboxvideo]
 [<ffffffff813b839a>] local_pci_probe+0x4a/0xb0
 [<ffffffff813b9675>] ? pci_match_device+0xc5/0xd0
 [<ffffffff813b9799>] pci_device_probe+0xd9/0x130
 [<ffffffff814a7b30>] driver_probe_device+0x130/0x3e0
 [<ffffffff814a7ec3>] __driver_attach+0x93/0xa0
 [<ffffffff814a7e30>] ? __device_attach+0x50/0x50
 [<ffffffff814a5a75>] bus_for_each_dev+0x65/0xa0
 [<ffffffff814a74de>] driver_attach+0x1e/0x20
 [<ffffffff814a70c0>] bus_add_driver+0x180/0x250
 [<ffffffffa0232000>] ? 0xffffffffa0231fff
 [<ffffffff814a8544>] driver_register+0x64/0xf0
 [<ffffffffa0232000>] ? 0xffffffffa0231fff
 [<ffffffff813b7d1c>] __pci_register_driver+0x4c/0x50
 [<ffffffffa0232039>] vbox_init+0x39/0x1000 [vboxvideo]
 [<ffffffff8100215d>] do_one_initcall+0xfd/0x1b0
 [<ffffffff8105dc33>] ? set_memory_nx+0x43/0x50
 [<ffffffff810e9abc>] load_module+0x12fc/0x1b80
 [<ffffffff810e5250>] ? store_uevent+0x40/0x40
 [<ffffffff810ea4b6>] SyS_finit_module+0x86/0xb0
 [<ffffffff81749830>] system_call_fastpath+0x1a/0x1f
Code: 00 00 55 48 89 e5 41 55 49 89 f5 41 54 53 48 89 fb 48 c7 c7 00 c0 1f a0 e8 b0 e0 56 e1 48 8b 83 08 02 00 00 48 8b 90 c8 01 00 00 <48> 8b 52 30 48 85 d2 74 1a 48 89 df e8 91 f4 57 e1 85 c0 41 89
RIP  [<ffffffffa01d0e0e>] drm_dev_register+0x2e/0x1f0 [drm]
 RSP <ffff88003656bb38>
CR2: 0000000000000030
---[ end trace f7c52d6077f46c2b ]---

Here's a dump of the showvminfo command:

vboxsvc@vmhost1:~$ vboxmanage showvminfo fileserv
Code: Select all   Expand viewCollapse view
Name:            fileserv
Groups:          /
Guest OS:        Ubuntu (64-bit)
UUID:            4962a288-1c7f-4add-a26e-7cf9a9422c9a
Config file:     /srv/virtualbox/vms/fileserv/fileserv.vbox
Snapshot folder: /srv/virtualbox/vms/fileserv/Snapshots
Log folder:      /srv/virtualbox/vms/fileserv/Logs
Hardware UUID:   4962a288-1c7f-4add-a26e-7cf9a9422c9a
Memory size:     4096MB
Page Fusion:     off
VRAM size:       32MB
CPU exec cap:    90%
HPET:            off
Chipset:         piix3
Firmware:        BIOS
Number of CPUs:  2
PAE:             on
Long Mode:       on
Triple Fault Reset: off
APIC:            on
X2APIC:          off
CPUID Portability Level: 0
CPUID overrides: None
Boot menu mode:  message and menu
Boot Device (1): Floppy
Boot Device (2): DVD
Boot Device (3): HardDisk
Boot Device (4): Not Assigned
ACPI:            on
IOAPIC:          on
Time offset:     0ms
RTC:             UTC
Hardw. virt.ext: on
Nested Paging:   on
Large Pages:     off
VT-x VPID:       on
VT-x unr. exec.: on
Paravirt. Provider: Legacy
Effective Paravirt. Provider: None
State:           running (since 2018-06-27T05:35:54.045000000)
Monitor count:   1
3D Acceleration: off
2D Video Acceleration: off
Teleporter Enabled: off
Teleporter Port: 0
Teleporter Address:
Teleporter Password:
Tracing Enabled: off
Allow Tracing to Access VM: off
Tracing Configuration:
Autostart Enabled: on
Autostart Delay: 30
Default Frontend:
Storage Controller Name (0):            IDE
Storage Controller Type (0):            PIIX4
Storage Controller Instance Number (0): 0
Storage Controller Max Port Count (0):  2
Storage Controller Port Count (0):      2
Storage Controller Bootable (0):        on
Storage Controller Name (1):            SATA
Storage Controller Type (1):            IntelAhci
Storage Controller Instance Number (1): 0
Storage Controller Max Port Count (1):  30
Storage Controller Port Count (1):      4
Storage Controller Bootable (1):        on
IDE (1, 0): /usr/share/virtualbox/VBoxGuestAdditions.iso (UUID: b5344af6-001f-4669-a17f-14aba8efcd74)
SATA (0, 0): /srv/virtualbox/vms/fileserv/fileserv_root.vdi (UUID: 563421f3-2253-4cd2-9ec7-945801947f62)
SATA (1, 0): /srv/virtualbox/vms/fileserv/fileserv_var.vdi (UUID: b96dde95-508e-4e76-987c-42bd068e5fd1)
SATA (2, 0): /srv/virtualbox/vms/fileserv/fileserv_data.vdi (UUID: e5a4be2d-c219-405c-acf1-e927160d228e)
SATA (3, 0): /srv/virtualbox/vms/fileserv/fileserv.srv.vdi (UUID: 337ebe76-a7a1-4baf-aaa4-1a08f86b605a)
NIC 1:           MAC: 080027B05A14, Attachment: Bridged Interface 'p3p1', Cable connected: on, Trace: off (file: none), Type: 82540EM, Reported speed: 0 Mbps, Boot priority: 0, Promisc Policy: deny, Bandwidth group: none
NIC 2:           disabled
NIC 3:           disabled
NIC 4:           disabled
NIC 5:           disabled
NIC 6:           disabled
NIC 7:           disabled
NIC 8:           disabled
Pointing Device: USB Tablet
Keyboard Device: PS/2 Keyboard
UART 1:          disabled
UART 2:          disabled
UART 3:          disabled
UART 4:          disabled
LPT 1:           disabled
LPT 2:           disabled
Audio:           disabled
Audio playback:  enabled
Audio capture: enabled
Clipboard Mode:  disabled
Drag and drop Mode: disabled
Session name:    headless
Video mode:      640x480x32 at 0,0 enabled
VRDE:            disabled
USB:             enabled
EHCI:            disabled
XHCI:            disabled

USB Device Filters:


Available remote USB devices:


Currently Attached USB Devices:


Bandwidth groups:  <none>

Shared folders:

Name: 'common', Host path: '/srv/virtualbox/shares/common' (machine mapping), writable

VRDE Connection:    not active
Clients so far:     0

Capturing:          not active
Capture audio:      not active
Capture screens:    0
Capture file:       /srv/virtualbox/vms/fileserv/fileserv.webm
Capture dimensions: 1024x768
Capture rate:       512 kbps
Capture FPS:        25
Capture options:    ac_enabled=false

Main Samba File Server which runs on vmhost1. If you see it on any other vmhost server, it is a backup image.

Configured memory balloon size:      0 MB
OS type:                             Ubuntu_64
Additions run level:                 0

Guest Facilities:

Facility "VirtualBox Base Driver": not active (last update: 2018/06/27 05:38:23 UTC)
Facility "VirtualBox System Service": not active (last update: 2018/06/27 05:52:12 UTC)
Facility "Seamless Mode": not active (last update: 2018/06/27 05:38:23 UTC)
Facility "Graphics Mode": not active (last update: 2018/06/27 05:38:23 UTC)

Any suggestions would be appreciated. Thanks.
Posts: 4
Joined: 27. Jun 2018, 08:12

Re: Persistent Kernel Panics on Ubuntu 14.04 LTS machines after updating Guest Additions

Postby RedScourge » 27. Jun 2018, 09:09

Aha, after browsing a few other forum posts, I found one which suggested the idea of updating the kernel to one of the backported 16.04 or 18.04 distro kernels and it worked.

Apparently either Virtualbox has silently dropped support for the 3.13 kernel series, or stopped testing their Guest Additions software against it and perhaps not noticed that it no longer works. I was able to install the linux-generic-lts-xenial package and reboot, and then installing the Guest Additions worked. I guess unless you either installed fresh or just somehow knew that you needed to install a newer kernel series than the one that came with 14.04, I suppose there would be no way to easily know what the problem is.
Posts: 4
Joined: 27. Jun 2018, 08:12

Re: Persistent Kernel Panics on Ubuntu 14.04 LTS machines after updating Guest Additions

Postby socratis » 27. Jun 2018, 10:06

RedScourge wrote:Apparently either Virtualbox has silently dropped support for the 3.13 kernel series, or stopped testing their Guest Additions software against it and perhaps not noticed that it no longer works.

I honestly don't know why you're facing issues with the 3.13 kernel. As another thread (Is kernel 3.13 no longer supported for guest additions?) shows, the 3.13 is working well.

That thread is in the "Linux Guests" section, which is where I'm going to move this thread as well. The problem is with your guest, not with your "Linux Host".
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Site Moderator
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Persistent Kernel Panics on Ubuntu 14.04 LTS machines after updating Guest Additions

Postby RedScourge » 24. May 2019, 23:34

Sorry to necropost, but I have come back to update this same issue as I have experienced it with a third VM guest now. I experienced it once again and rediscovered this old thread of mine. I have now experienced it on 64-bit Ubuntu 14.04 LTS and 12.04 LTS on Linux hosts, and now also 12.04 LTS on Windows hosts. Given that this issue seems to affect OSes which are now out of support and the Virtualbox 5.2 series which is barely still in support, I figured it might be useful for me to add my "solution" for those who are maybe not that good with Linux as I was when I first started experiencing this problem.

Apparently the issue is due to the vboxvideo kernel module in the Guest Additions when installing versions of the Guest Additions in the 5.2 series on Linux guests running the 3.13 series kernels. I had set up several dev test hosts back in 2014 or so, which I occasionally use, and I only update the guest OS, host OS, Virtualbox software on the host, and Guest Additions, whenever I fire one of these up again. Apparently I still had a machine that was running the 3.13 series kernel and the 5.1 series of Guest Additions, and when I updated it to the 5.2 series I triggered this problem yet again.

I ended up "solving" (mitigating) the issue on 12.04 LTS with the advice provided in this other thread here ( viewtopic.php?f=3&t=79121#p369359 ), which basically just disables the vboxvideo kernel module:

Code: Select all   Expand viewCollapse view
dracut -o "vboxvideo" -f /boot/initramfs-$(uname -r).img $(uname -r)
echo "blacklist vboxvideo" >> /etc/modprobe.d/blacklist-vboxvideo.conf

Note that if you first have to install dracut just before doing this, it will trigger a rebuild of your boot image, which will freeze due to a modprobe of vboxvideo, so you can mitigate this by firing up another console session and killing that portion of the install process:

Code: Select all   Expand viewCollapse view
pkill -f "modprobe -q vboxvideo"

and on 14.04 LTS where newer kernels are available, I solve it by using a newer kernel with a command like this:

Code: Select all   Expand viewCollapse view
apt-get install --install-recommends linux-generic-lts-xenial
Posts: 4
Joined: 27. Jun 2018, 08:12

Return to Linux Guests

Who is online

Users browsing this forum: No registered users and 13 guests