[Fixed] Ubuntu 18.04 guest - VBox 5.2.10 - 3D video acceleration breaks X

Discussions about using Linux guests in VirtualBox.

[Fixed] Ubuntu 18.04 guest - VBox 5.2.10 - 3D video acceleration breaks X

Postby EdoardoC » 10. May 2018, 10:50

[Mod edit: This has been fixed with 5.2.12]
I created a new Ubuntu 18.04 VM on Mac High Sierra
Chose the Ubuntu desktop minimal install which uses Gnome 3
After installing the VBox extensions and restarting, the X UI fails to start (I could not find where the logs are)
The solution is to disable the 3D video acceleration box (that has always worked for me in previous Ubuntu LTS editions).

this has been reported by other users in other forums, e.g.
https://askubuntu.com/questions/1029585 ... le_rich_qa
Last edited by socratis on 11. May 2018, 00:18, edited 2 times in total.
Reason: Marked as [Fixed].
EdoardoC
 
Posts: 9
Joined: 25. Jan 2018, 19:40

Re: Ubuntu 18.04 guest - VBox 5.2.10 - 3D video acceleration breaks X

Postby socratis » 10. May 2018, 11:04

EdoardoC wrote:The solution is to disable the 3D video acceleration box
... or to choose Gnome Classic from the login cog. That works too.

Worth reading: https://www.virtualbox.org/wiki/X11Guest3D
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Ubuntu 18.04 guest - VBox 5.2.10 - 3D video acceleration breaks X

Postby EdoardoC » 10. May 2018, 19:37

not really .... I do not get to the graphical login prompt at all if 3D is enabled
Last edited by socratis on 10. May 2018, 19:38, edited 1 time in total.
Reason: Removed unnecessary verbatim quote of the whole previous message.
EdoardoC
 
Posts: 9
Joined: 25. Jan 2018, 19:40

Re: Ubuntu 18.04 guest - VBox 5.2.10 - 3D video acceleration breaks X

Postby socratis » 10. May 2018, 19:41

Hmm... That's interesting, I do. ;)
And I think I might know why. I'm using (was using) the 5.2.11 test builds, which I believe included some fixes for Ubuntu 18.10.

But... those fixes have been included in the newly released 5.2.12. Update your VirtualBox and see it that works.

PS. My ISO is called "ubuntu-18.04-desktop-amd64.iso" if that helps...
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Ubuntu 18.04 guest - VBox 5.2.10 - 3D video acceleration breaks X

Postby EdoardoC » 11. May 2018, 00:14

Thanks

VBox 5.2.12 and associated extension + guest allow the 3D setting to be checked.
Ubuntu boots graphically and I can login into the NORMAL gnome environment

cheers
EdoardoC
 
Posts: 9
Joined: 25. Jan 2018, 19:40

Re: Ubuntu 18.04 guest - VBox 5.2.10 - 3D video acceleration breaks X

Postby socratis » 11. May 2018, 00:16

Nice to hear that. A developer just got their wings back... ;)
Marking as [Fixed].
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: [Fixed] Ubuntu 18.04 guest - VBox 5.2.10 - 3D video acceleration breaks X

Postby MarkHowe » 11. May 2018, 11:39

I think I'm experiencing a similar issue with 18.04 virtualized for Windows 10 with 5.2.10 r122406.

The dots on the Ubuntu loading page tend to freeze, not always at the same point. On one occasion, when shutting down, I saw a message about unattended upgrades, so I uninstalled that package. The last time this happened I checked the journal logs, and the last line was

00:00:04.591953 GUI: UIMachineLogicNormal::sltCheckForRequestedVisualStateType: Requested-state=0, Machine-state=5

I think that, every time this has happened, I have had Chrome open and playing a video. Startup has certainly failed twice with Chrome open and then worked after I closed it.

I have 3D enabled and 2D disabled.
MarkHowe
 
Posts: 6
Joined: 11. May 2018, 11:32


Return to Linux Guests

Who is online

Users browsing this forum: Google [Bot], xorbe and 12 guests