[Solved] "Failed to open a session for the virtual machine"

Discussions about using Linux guests in VirtualBox.

[Solved] "Failed to open a session for the virtual machine"

Postby AlliumPorrum » 27. Nov 2017, 21:26

Hi!

I'm trying to re-run a few Ubuntu VM's from few years back, but I always just get this kind of an error:

Failed to open a session for the virtual machine MyVM.
VT-x is being used by another hypervisor (VERR_VMX_IN_VMX_ROOT_MODE).
VirtualBox can't operate in VMX root mode. Please close all other virtualization programs. (VERR_VMX_IN_VMX_ROOT_MODE).
Result Code: E_FAIL (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}


What might cause this issue?

My host is Win 10 + Virtual Box 5.2.2.
Last edited by socratis on 28. Nov 2017, 20:57, edited 1 time in total.
Reason: Marked as [Solved].
AlliumPorrum
 
Posts: 3
Joined: 27. Nov 2017, 21:21

Re: "Failed to open a session for the virtual machine"

Postby socratis » 28. Nov 2017, 01:16

AlliumPorrum wrote:VT-x is being used by another hypervisor (VERR_VMX_IN_VMX_ROOT_MODE).
AlliumPorrum wrote:My host is Win 10

After making 110% sure that Hyper-V is disabled in the Windows Features, you might want to make sure that Fast Boot is disabled and do a cold boot (i.e. shut down the host for a minute or two).

You also must make sure that nothing else is using Hyper-V, things like antivirus, debuggers, emulators, etc. Check out the article Diagnosing VirtualBox Hardening Issues to get some ideas...
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 12612
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: "Failed to open a session for the virtual machine"

Postby AlliumPorrum » 28. Nov 2017, 12:29

socratis wrote:After making 110% sure that Hyper-V is disabled in the Windows Features....


Ok, thanks Socratis, I did not know this... How exactly can I make sure that it is disabled?
AlliumPorrum
 
Posts: 3
Joined: 27. Nov 2017, 21:21

Re: "Failed to open a session for the virtual machine"

Postby viral » 28. Nov 2017, 13:59

Go to Control Panel (the real one, not the "Windows Settings" crap in W10), then "Programs and Features", then "Turn Windows features on or off." If Hyper-V is checked in there, it's enabled.
viral
 
Posts: 4
Joined: 28. Jul 2017, 15:56

Re: "Failed to open a session for the virtual machine"

Postby mpack » 28. Nov 2017, 16:44

You can also just go right click on the start button, run, "OptionalFeatures.exe". The "Hyper-V" box should be clear - not checked or shaded.
mpack
Site Moderator
 
Posts: 25435
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: "Failed to open a session for the virtual machine"

Postby AlliumPorrum » 28. Nov 2017, 17:42

Ok, I checked the Hyper-V, and it was already disabled. Then, as instructed, I disabled the fast boot- option (which was ON), and that did it! Thank you very much for your help!
AlliumPorrum
 
Posts: 3
Joined: 27. Nov 2017, 21:21

Re: "Failed to open a session for the virtual machine"

Postby socratis » 28. Nov 2017, 20:56

Great, thanks for the feedback. Marking as [Solved].
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 12612
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5


Return to Linux Guests

Who is online

Users browsing this forum: No registered users and 20 guests