External networking gone after upgrade

Discussions about using Linux guests in VirtualBox.

External networking gone after upgrade

Postby TwoFifty6 » 20. Nov 2017, 18:25

I'm not sure exactly what happened, but I have an Ubuntu VM that I occasionally fire up to test things out before making changes on my host machine (also running Ubuntu). It has always worked just fine, but recently I upgraded the VM from 17.04 to 17.10. I also upgraded vbox on my 17.10 host (currently running 5.2). I just installed the .deb file from the website here and used dpkg to install it as I always do. Now for some reason I cannot access the internet on my VM, but I'm not sure which upgrade broke things.

I have tried it both in NAT and bridged networking, neither of which work. The really odd thing is that (even in NAT mode), the VM can successfully access the host. For example, I can SSH to my host system just fine, but I cannot reach anything via a browser, nor can I ping any site from a bash shell.

All of the extensions and guest additions should be up to date with the latest. Any ideas what to do to troubleshoot this?
Posts: 1
Joined: 20. Nov 2017, 18:17

Return to Linux Guests

Who is online

Users browsing this forum: No registered users and 17 guests