Unable to receive snmp trap in trap receiver

Discussions about using Linux guests in VirtualBox.

Unable to receive snmp trap in trap receiver

Postby jeotte » 5. Nov 2017, 18:41

Host: Windows 10, 64 bit, 370GB free space
Guest: Fedora 24, 32 bit, 11GB Virtual Size, no guest additions

Port Forwarding set up for port 162 for tcp and udp
Network adapter: NAT, and I have run 'VBoxManage modifyvm FedoraGuest --nataliasmode1 proxyonly'

Overview of problem: I can see a v2 trap come in using Wireshark, but cannot receive it in the two trap receivers that I have tried.

Details: In Wireshark, the v2 trap looks correct. I can see the correct source IP and the packet looks as I would expect. I am trying to use net-snmp snmptrapd to receive the trap, and the daemon starts up but doesn't receive anything sent from a real device. I can send a trap within the VitualBox to itself and see it get received in the trap daemon, so I know that the receiver is running and capable of receiving traps. I have confirmed that the daemon is indeed running on port 162 by running 'netstat -anp | grep 162’. The snmptrapd.conf file has one line in it: "authCommunity log,net public". I have a coworker who set up net-snmp exactly as I have, except that he's running on a VM rather than a VirtualBox and he's able to receive traps. I have also tried installing WebNMS and using their snmpv3trapd receiver (which I've used before on my windows machine), and it's also unable to get the trap in the VirtualBox.

There must be some networking type of setting that I'm missing, but at this point, I have no idea what it would be. Any help/direction/ideas would be greatly appreciated.
Attachments
showVmInfo_details.txt
output of running showvminfo -details
(4.42 KiB) Downloaded 1 time
jeotte
 
Posts: 1
Joined: 5. Nov 2017, 18:22

Return to Linux Guests

Who is online

Users browsing this forum: No registered users and 14 guests