Page 1 of 1

SOLVED: Problem with guest additions on openSUSE 11 guest

PostPosted: 22. Jun 2008, 01:25
by carlill
Hello,

I've just installed the released version of openSUSE 11 as a guest on a Virtualbox 1.6.2 Windows XP host. All works fine, except the guest additions. What happens is this:

The installation proceeds without errors and I restart the virtual machine. The first time, the guest additions work perfectly (mouse integration, automatic resize of desktop etc.). However, if I reboot the virtual machine, the guest additions no longer work (mouse integration is gone, and the automatic resize is not functional). Reinstalling the guest additions works, for one reboot, but fails again.

An Ubuntu 8.04 guest on the same Virtualbox installation works perfectly, including the guest additions.

Can anybody help?

Thanks!

PostPosted: 23. Jun 2008, 17:01
by kill-9
I got the same issue, but it never actually works at all. I reboot after a sucessful install and no dice.

Ubuntu 8.04 host, openSUSE 11 Final guest.

PostPosted: 23. Jun 2008, 23:01
by Mangust22
Just log off and log in then...
I don't know "why", only "how to" :-)

SOLVED: Thank you, Mangust22...

PostPosted: 23. Jun 2008, 23:38
by carlill
... you reminded me that in order for the guest additions to work on openSUSE, you need to:

change RUN_PARALLEL from "yes" to "no" in the openSUSE /etc/sysconfig/boot file.

Having made this change, openSUSE 11 works perfectly under VirtualBox.