Plymouth Splash screen does not work for Debian Jessie

Discussions about using Linux guests in VirtualBox.

Plymouth Splash screen does not work for Debian Jessie

Postby Tejendra » 24. Aug 2015, 06:22

I am using Virtual Box version 4.3.30. This weird problem while using Debian Jessie (8.1.0) as my guest OS and i think this problem is with everybody using Virtual Box or VMware and running Jessie on it.
Problem: Splash Screen not working in VBox or VMware
Description: While i configure my Debian Jessie OS to show Plymouth Splash screen on bootup, It should show plymouth splash screen while bootup. But unfortunately it doesn't work.
Exceptions: Plymouth Splash screen is working if i install Debian Jessie in dual boot or on solo machine
Probable Problem: Looks like there is some problem/Limitations with "Emulation of Graphics Card in Virtual Box or VMware", as i have tested this thing both Intel and Nvidia Graphics cards but it doesn't work on either of Virtual Box or VMware, However it does work when installed in dual boot environment ( As real graphics card would be available )

I am configuring plymouth using instructions on debian's plymouth page.

Can anybody please tell my what is the exact problem by which this issue is coming and if there is any solution to it in near future ?
Last edited by Tejendra on 24. Aug 2015, 08:12, edited 3 times in total.
Tejendra
 
Posts: 6
Joined: 24. Aug 2015, 05:50

Re: Splash screen does not work for Debian Jessie

Postby loukingjr » 24. Aug 2015, 07:01

First, VirtualBox and VMWare have nothing to do with each other so if you have a problem with VMWare you need to ask why on their forums.

Second, if I enable the Splash screen on my Debian 8.1 guest it works so I have to assume yours is not configured correctly. The fact it fails on two different hypervisors seems to indicate that.
OSX, Linux and Windows Hosts & Guests
There are three groups of people. Those that can count and those that can't.
loukingjr
Volunteer
 
Posts: 8809
Joined: 30. Apr 2009, 09:45
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: just about all that run

Re: Plymouth Splash screen does not work for Debian Jessie

Postby Tejendra » 24. Aug 2015, 07:16

@loukingjr....

Sorry, i was asking about Plymouth Splash screen, i forgot to mention it. Please check edited question now.
Tejendra
 
Posts: 6
Joined: 24. Aug 2015, 05:50

Re: Plymouth Splash screen does not work for Debian Jessie

Postby loukingjr » 24. Aug 2015, 07:29

I realize that. My answer is the same.

BTW, editing all the VMWare references out was disingenuous and will make some wonder why I replied the way I did.
OSX, Linux and Windows Hosts & Guests
There are three groups of people. Those that can count and those that can't.
loukingjr
Volunteer
 
Posts: 8809
Joined: 30. Apr 2009, 09:45
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: just about all that run

Re: Plymouth Splash screen does not work for Debian Jessie

Postby Tejendra » 24. Aug 2015, 08:22

@loukingjr....

I wonder what wrong am i doing ! Well can you please tell me your vBox version, your host OS and the commands by which you are configuring Plymouth splash, so that i can try to replicate it myself.
Tejendra
 
Posts: 6
Joined: 24. Aug 2015, 05:50

Re: Plymouth Splash screen does not work for Debian Jessie

Postby loukingjr » 24. Aug 2015, 12:08

First let me say I was using the XFCE environment when I tested the splash screen. There is an app called "session and startup" which has a tab to configure the splash screen. When enabled I only saw the splash screen for a fraction of a second after I had logged in. I assume that's not the correct behavior. Most likely the problem has to do with the switch from init to systemd and virtual machines in general. Whether one can make the splash screen appear normally I can't say but I for one don't miss it.
OSX, Linux and Windows Hosts & Guests
There are three groups of people. Those that can count and those that can't.
loukingjr
Volunteer
 
Posts: 8809
Joined: 30. Apr 2009, 09:45
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: just about all that run

Re: Plymouth Splash screen does not work for Debian Jessie

Postby Tejendra » 3. Sep 2015, 13:09

Does any body has any information about latest version of plymouth not working with VirtualBox, what can be the reason and how to get it fixed ?
Tejendra
 
Posts: 6
Joined: 24. Aug 2015, 05:50

Re: Plymouth Splash screen does not work for Debian Jessie

Postby hykwok » 7. Sep 2015, 05:33

Tejendra wrote:Does any body has any information about latest version of plymouth not working with VirtualBox, what can be the reason and how to get it fixed ?

Plymouth does not work because the drm video linux driver (not xorg driver) is not loaded before Plymouth starts.
There is no simple solution at this moment.
hykwok
 
Posts: 2
Joined: 7. Sep 2015, 05:26

Re: Plymouth Splash screen does not work for Debian Jessie

Postby loukingjr » 7. Sep 2015, 06:12

hykwok wrote:Plymouth does not work because the drm video linux driver (not xorg driver) is not loaded before Plymouth starts.
There is no simple solution at this moment.

Thanks for the answer. Apparently Debian "feels" a need to be different.

It seems michael already gave the answer.
Last edited by loukingjr on 7. Sep 2015, 06:54, edited 2 times in total.
OSX, Linux and Windows Hosts & Guests
There are three groups of people. Those that can count and those that can't.
loukingjr
Volunteer
 
Posts: 8809
Joined: 30. Apr 2009, 09:45
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: just about all that run

Re: Plymouth Splash screen does not work for Debian Jessie

Postby Tejendra » 7. Sep 2015, 06:44

I have one more specific update on this issue posted by virtualBox peoples

https://www.virtualbox.org/ticket/14503#comment:1
Tejendra
 
Posts: 6
Joined: 24. Aug 2015, 05:50

Re: Plymouth Splash screen does not work for Debian Jessie

Postby loukingjr » 7. Sep 2015, 07:03

Yes, it seems michael gave the likely answer 4 days ago. The lack of a KMS driver in VirtualBox.
OSX, Linux and Windows Hosts & Guests
There are three groups of people. Those that can count and those that can't.
loukingjr
Volunteer
 
Posts: 8809
Joined: 30. Apr 2009, 09:45
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: just about all that run

Re: Plymouth Splash screen does not work for Debian Jessie

Postby Tejendra » 7. Sep 2015, 15:10

hykwok wrote:
Tejendra wrote:Does any body has any information about latest version of plymouth not working with VirtualBox, what can be the reason and how to get it fixed ?

Plymouth does not work because the drm video linux driver (not xorg driver) is not loaded before Plymouth starts.
There is no simple solution at this moment.


Prior to the jessie release, plymouth was working fine in VirtualBox as it was depending on plymouth-drm, but latest version of plymouth (0.9.0-9) depends on libdrm2.

I tried loading drm drivers early but it didn't work out ! :(
Tejendra
 
Posts: 6
Joined: 24. Aug 2015, 05:50


Return to Linux Guests

Who is online

Users browsing this forum: No registered users and 14 guests