Cannot mount VBoxAdditions 4.2.10

Discussions about using Linux guests in VirtualBox.

Cannot mount VBoxAdditions 4.2.10

Postby kapetros » 15. Mar 2013, 16:49

I have just upgraded to version 4.2.10, add another strange error emerged, cannot mount the additions.iso?
Is it faulty?

Code: Select all   Expand viewCollapse view
root@debian:~# mount /dev/sr0 /media/
mount: block device /dev/sr0 is write-protected, mounting read-only
mount: you must specify the filesystem type

Code: Select all   Expand viewCollapse view
root@slackware:~# mount /dev/sr0 /media/
mount: block device /dev/sr0 is write-protected, mounting read-only
NTFS signature is missing.
Failed to mount '/dev/sr0': Invalid argument
The device '/dev/sr0' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?


It is sad to see a great program, having bugs all the time :?
kapetros
 
Posts: 13
Joined: 26. Jul 2011, 23:29
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Gentoo, Archlinux, Debian, FreeBSD, other

Re: Cannot mount VBoxAdditions 4.2.10

Postby Perryg » 15. Mar 2013, 16:56

I guess you failed to see where to discuss issues with the new release. https://forums.virtualbox.org/viewtopic.php?f=1&t=54615

I just tested this and it works for me.

Code: Select all   Expand viewCollapse view
debian@debian:/media/cdrom$ sudo mount /dev/sr0 /media/cdrom
mount: block device /dev/sr0 is write-protected, mounting read-only
debian@debian:/media/cdrom$ ls
debian@debian:/media/cdrom$ cd ..
debian@debian:/media$ cd cdrom
debian@debian:/media/cdrom$ ls
32Bit  AUTORUN.INF  cert  runasroot.sh            VBoxSolarisAdditions.pkg        VBoxWindowsAdditions.exe
64Bit  autorun.sh   OS2   VBoxLinuxAdditions.run  VBoxWindowsAdditions-amd64.exe  VBoxWindowsAdditions-x86.exe
debian@debian:/media/cdrom$


You may have a corrupt download try the guest additions from here. http://download.virtualbox.org/virtualbox/4.2.10/
Perryg
Site Moderator
 
Posts: 34373
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Cannot mount VBoxAdditions 4.2.10

Postby kapetros » 15. Mar 2013, 18:39

After a clean install of VBox my weird problem, wasn't solved, I solved it by downloading the .iso itself and coping it into the windows folder !!
kapetros
 
Posts: 13
Joined: 26. Jul 2011, 23:29
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Gentoo, Archlinux, Debian, FreeBSD, other

Re: Cannot mount VBoxAdditions 4.2.10

Postby hnyman » 15. Mar 2013, 19:18

Same error here. VB 4.2.10 running in Win7x64.
I couldn't get the mount to work in Ubuntu 12.10 guest.

Downloaded the .ISO manually and that finally worked.
hnyman
 
Posts: 9
Joined: 30. Apr 2011, 10:50
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Ubuntu 20.04

Re: Cannot mount VBoxAdditions 4.2.10

Postby dsh21 » 16. Mar 2013, 03:58

i was getting the same error. downloading the guest additions .iso listed above and loading from secondary controller worked. thanks.
dsh21
 
Posts: 8
Joined: 23. Sep 2009, 06:19
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: mandriva

Re: Cannot mount VBoxAdditions 4.2.10

Postby Perryg » 16. Mar 2013, 04:03

Continue version 4.2.10 discussions here https://forums.virtualbox.org/viewtopic.php?f=1&t=54615
Perryg
Site Moderator
 
Posts: 34373
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX


Return to Linux Guests

Who is online

Users browsing this forum: No registered users and 7 guests