Fedora 15 (64bit), No Gnome 3

Discussions about using Linux guests in VirtualBox.

Fedora 15 (64bit), No Gnome 3

Postby WhippyLizard » 4. Aug 2011, 14:44

00:02.0 VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter

[root@F15VM ~]# lspci -v -s 00:02.0
00:02.0 VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter (prog-if 00 [VGA controller])
Flags: bus master, fast devsel, latency 64, IRQ 18
Memory at e0000000 (32-bit, prefetchable) [size=128M]
Expansion ROM at <unassigned> [disabled]

---

I have a fresh Fedora 15 installation that I have installed the additions into. I can resize/reshape correctly so I believe the adaptor is working correctly.

Host OS: Windows 7 SP1 - Intel 4500 (8.15.10.2361) installed
Guest: Fedora 15 64bit - 2048mb of ram
VirtualBox: 4.1.0, 3D Acceleration on, 128 set

I can not for the life of me get gnome to run in something other than fallback.

I have:

Flipped the switch in System Info to force a retry at full mode no joy
Reinstalled the additions

yum clean all
yum check-update
yum update

every patch that is available is installed and no errors are thrown when building the additions...

Anything that I am missing that must be plainly obvious, if I boot this machine with Fedora installed native, gnome 3 does indeed function in standard (not fallback) mode.
WhippyLizard
 
Posts: 4
Joined: 29. Jun 2011, 14:42
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Linux, Server 2008

Re: Fedora 15 (64bit), No Gnome 3

Postby Perryg » 4. Aug 2011, 15:15

Turn off SELinux
Perryg
Site Moderator
 
Posts: 25964
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Fedora 15 (64bit), No Gnome 3

Postby WhippyLizard » 4. Aug 2011, 19:27

Perryg wrote:Turn off SELinux


[developer@F15VM ~]$ cat /etc/selinux/config
# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
# enforcing - SELinux security policy is enforced.
# permissive - SELinux prints warnings instead of enforcing.
# disabled - SELinux is fully disabled.
SELINUX=disabled
# SELINUXTYPE= type of policy in use. Possible values are:
# targeted - Only targeted network daemons are protected.
# strict - Full SELinux protection.
SELINUXTYPE=targeted
#
SETLOCALDEFS=0
[developer@F15VM ~]$

should actually be off, status is reported as disabled as well.
WhippyLizard
 
Posts: 4
Joined: 29. Jun 2011, 14:42
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Linux, Server 2008

Re: Fedora 15 (64bit), No Gnome 3

Postby mauricio288 » 5. Aug 2011, 23:15

Same problem here, Gnome Shell is not running as should do.

SElinux is disabled and all the updates are installed, also I upgraded the Kernel.
mauricio288
 
Posts: 3
Joined: 2. Aug 2011, 16:50
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Fedora 15

Re: Fedora 15 (64bit), No Gnome 3

Postby robatino » 9. Aug 2011, 05:30

I'm also seeing this in a F15 x86_64 guest. It started recently (no more than about 2 weeks, I think). I thought it might be the new kernel but the same problem exists with the older one now.
robatino
 
Posts: 77
Joined: 17. Dec 2008, 21:15

Re: Fedora 15 (64bit), No Gnome 3

Postby robatino » 12. Aug 2011, 02:20

Today, Gnome shell is working in my F15 guest again. I have no idea why, there are no updates which appear to be related, same kernel, same guest additions (not rebuilt).

Edit: Now I seem to randomly get either Gnome shell or fallback mode on each login. Maybe a timing issue?
robatino
 
Posts: 77
Joined: 17. Dec 2008, 21:15

Re: Fedora 15 (64bit), No Gnome 3

Postby WhippyLizard » 18. Aug 2011, 13:15

robatino wrote:Today, Gnome shell is working in my F15 guest again. I have no idea why, there are no updates which appear to be related, same kernel, same guest additions (not rebuilt).

Edit: Now I seem to randomly get either Gnome shell or fallback mode on each login. Maybe a timing issue?


0o

Well I was never able to get it to function in VirtualBox, I am going to install 4.1.2 today and it's tools and see if that fixes the issues.
WhippyLizard
 
Posts: 4
Joined: 29. Jun 2011, 14:42
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Linux, Server 2008

Re: Fedora 15 (64bit), No Gnome 3

Postby kbook » 3. Sep 2011, 00:18

First, in order to install the guest addition you need to install the kernel development package first.
The package is called "Development package for building kernel modules to match kernel" look under add/remove software app or kernel-devel-2.6.40.3-0.fc15 (this is my current kernel ver)
After installing all the required packages then you can rerun the script again. In the script, you should see [ok] at the end of each task.

If you upgrade the linux-kernel you will need to recompile (rerun that guest addition script again) so it will rebuilt the driver. I am running Fedora 15 x86 on the virtualbox so it should not be different on the 64bit.
kbook
 
Posts: 3
Joined: 20. Nov 2009, 07:19
Primary OS: MS Windows Vista
VBox Version: OSE other
Guest OSses: Open Solaris


Return to Linux Guests

Who is online

Users browsing this forum: Perryg and 15 guests