Page 1 of 2

Build OpenGL support module failed in Scientific Linux 6

PostPosted: 18. Jun 2011, 05:22
by penyuan
Hello,
I have successfully installed Scientific Linux 6 (which is literally RHEL 6.0 without the branding) as a virtual machine guest in with VirtualBox 4.0.8 host in Mac OS X 10.6.7. I have also fully updated the guest system.
When I install the VirtualBox guest additions in the guest system, I get the following error:
Building the OpenGL support modules..... [FAILED]

All other steps seemed OK.
I checked /var/log/vboxadd-install.log, and got this.
Can someone please tell me what's wrong, and how I can correct this error? Thank you.

Re: Build OpenGL support module failed in Scientific Linux 6

PostPosted: 18. Jun 2011, 11:23
by Sasquatch
As you see multiple times in it, there are some configuration errors with the kernel that are required for certain features. It's likely that OpenGL is one of the things that fails because of incorrect kernel configuration. Does the rest work, like mouse integration, dynamic resolution and seamless mode? I am not experienced with kernel compilation and configuration, so I don't know how to change your kernel to accept OpenGL.

Re: Build OpenGL support module failed in Scientific Linux 6

PostPosted: 19. Jun 2011, 00:30
by penyuan
Sasquatch wrote:Does the rest work, like mouse integration, dynamic resolution and seamless mode?

Mouse integration and dynamic resolution are the only ones that work. There's no seamless mode, shared folders, nor clipboard sharing, etc...
I have no experience with kernel issues either, if anyone has insight, please help! Thanks.

Re: Build OpenGL support module failed in Scientific Linux 6

PostPosted: 19. Jun 2011, 12:11
by Sasquatch
Then it would appear that the Guest Additions did not install completely or correctly. If you have dynamic resolution, you should also have seamless mode. Shared Folders is a different module and it seems that didn't compile either. Clipboard is the same thing, but you have to know that not all applications in Linux use the same buffer and they clear it when you close the application you copied from. E.g. open a file in gedit, copy a piece of text and then close it, removes the copied text from clipboard.

Re: Build OpenGL support module failed in Scientific Linux 6

PostPosted: 19. Jun 2011, 15:58
by penyuan
Sasquatch wrote:Then it would appear that the Guest Additions did not install completely or correctly. If you have dynamic resolution, you should also have seamless mode. Shared Folders is a different module and it seems that didn't compile either. Clipboard is the same thing, but you have to know that not all applications in Linux use the same buffer and they clear it when you close the application you copied from. E.g. open a file in gedit, copy a piece of text and then close it, removes the copied text from clipboard.

Ooops, I just checked again and dynamic resolution is not working, that's probably part of why there's no seamless mode for me. And I checked again, there's definitely no shared folders nor clipboard sharing (I checked before an application is closed).....

Re: Build OpenGL support module failed in Scientific Linux 6

PostPosted: 20. Jun 2011, 19:01
by Sasquatch
Then it just shows that the Guest Additions aren't installed at all. Are you sure that all required packages are installed to create kernel modules?

Re: Build OpenGL support module failed in Scientific Linux 6

PostPosted: 23. Jun 2011, 23:59
by penyuan
Sasquatch wrote:Then it just shows that the Guest Additions aren't installed at all. Are you sure that all required packages are installed to create kernel modules?

I've installed GCC, GNU make, kernel-devel-[version number], kernel-headers-[version number]. Not sure if there's anything else I need??
My mouse pointer integration works though, so it looks like some components were installed?

Re: Build OpenGL support module failed in Scientific Linux 6

PostPosted: 24. Jun 2011, 19:53
by bits45
I'll be interesting in a fix or patch for this too. Seems like only RHEL6 has issues. I'm now on RHEL 6.1.

VB Extensions partially work. Can't dynamically resize window, but mouse seems to work.

Had same error as above during install, ONLY OpenGL mod failed. Same error.

Re: Build OpenGL support module failed in Scientific Linux 6

PostPosted: 25. Jun 2011, 12:44
by Sasquatch
penyuan wrote:
Sasquatch wrote:Then it just shows that the Guest Additions aren't installed at all. Are you sure that all required packages are installed to create kernel modules?

I've installed GCC, GNU make, kernel-devel-[version number], kernel-headers-[version number]. Not sure if there's anything else I need??
My mouse pointer integration works though, so it looks like some components were installed?

Does [version number] match your running kernel? It's of little use to install a kernel with number .42 when you run .41 or vice versa. They have to match exactly. There should be a meta package that depends on the latest version available and keeps you up to date.

Re: Build OpenGL support module failed in Scientific Linux 6

PostPosted: 1. Aug 2012, 12:20
by EllieM
Hi,

I am having the same problem with the OpenGL module.

I am running SL 6.2 as a guest. I have install the extension pack on the host machine. I am running Virtualbox 4.1.18

In SL, I have installed dkms, gcc and my kernel-headers & -devel match my kernel and everything is fully up to date. I am using the ls.repo and epel.repo

Mouse integration and shared folders seem to work, but my screen will only display 800x600 (too small) and 640x480 (really too small!)

Thanks in advance

Re: Build OpenGL support module failed in Scientific Linux 6

PostPosted: 1. Aug 2012, 14:50
by Perryg
EllieM wrote:Hi,
I am having the same problem with the OpenGL module.
I am running SL 6.2 as a guest. I have install the extension pack on the host machine. I am running Virtualbox 4.1.18
In SL, I have installed dkms, gcc and my kernel-headers & -devel match my kernel and everything is fully up to date. I am using the ls.repo and epel.repo
Mouse integration and shared folders seem to work, but my screen will only display 800x600 (too small) and 640x480 (really too small!)
Thanks in advance

Do you see errors when installing the Guest additions (in the guest)?

Re: Build OpenGL support module failed in Scientific Linux 6

PostPosted: 14. Aug 2012, 21:07
by kaychoro
I got the same thing and was able to resolve it by doing this before running the installer:

Code: Select all   Expand viewCollapse view
export MAKE='/usr/bin/gmake -i'


Google for freeoracletrainings and 15-install-guest-additions-building-the-opengl-support-module-failed to find the source (I'm a new forum member so I can't post the link now)

I got it all installed and then it worked. One thing that I did notice is that I couldn't change the resolution from within linux, but I could resize the window and have the window automatically adjust (even on full-screen) and it worked great.

Re: Build OpenGL support module failed in Scientific Linux 6

PostPosted: 11. Mar 2013, 00:44
by Wolfie
kaychoro wrote:I got the same thing and was able to resolve it by doing this before running the installer:

Code: Select all   Expand viewCollapse view
export MAKE='/usr/bin/gmake -i'

THANK YOU!

I installed CentOS 6.4 earlier and first had an issue with 'Building the main Guest Additions module' failing. Got that working then the OpenGL issue. Tried the line above and -poof- it worked!

Re: Build OpenGL support module failed in Scientific Linux 6

PostPosted: 20. Mar 2013, 16:28
by rwouters
Hi,

the -i flag, according to the man pages for gmake means : ignore all errors.
I have the same OpenGL issue on the official RHEL 6.4 distro. The build of the opengl support module fails.
Using the -i flag, the build "succeeds". However, I don't know if simply ignoring all errors is the right way to go ...

Regards,
Ronald Wouters

Re: Build OpenGL support module failed in Scientific Linux 6

PostPosted: 21. Mar 2013, 11:31
by dmischa
penyuan wrote:Hello,
I have successfully installed Scientific Linux 6 (which is literally RHEL 6.0 without the branding) as a virtual machine guest in with VirtualBox 4.0.8 host in Mac OS X 10.6.7. I have also fully updated the guest system.
When I install the VirtualBox guest additions in the guest system, I get the following error:
Building the OpenGL support modules..... [FAILED]

All other steps seemed OK.
I checked /var/log/vboxadd-install.log, and got this.
Can someone please tell me what's wrong, and how I can correct this error? Thank you.


because of a bug in the linux guestadditions the OpenGL support modules can't be build for RHEL6.4 and clones guests, you will have to apply the patch

--- vboxvideo_drm.c.ori 2013-03-01 12:11:52.146639050 +0100
+++ vboxvideo_drm.c 2013-03-01 12:18:57.231061446 +0100
@@ -70,6 +70,9 @@
# if RHEL_RELEASE_CODE >= RHEL_RELEASE_VERSION(6,3)
# define DRM_RHEL63
# endif
+# if RHEL_RELEASE_CODE >= RHEL_RELEASE_VERSION(6,4)
+# define DRM_RHEL64
+# endif
# endif
# endif

@@ -106,7 +109,7 @@
{
/* .driver_features = DRIVER_USE_MTRR, */
.load = vboxvideo_driver_load,
-#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 6, 0)
+#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 6, 0) && !defined(DRM_RHEL64)
.reclaim_buffers = drm_core_reclaim_buffers,
#endif
/* As of Linux 2.6.37, always the internal functions are used. */


or wait for 4.2.12