[Solved] No network on Ubuntu guest after installing update

Discussions about using Linux guests in VirtualBox.

[Solved] No network on Ubuntu guest after installing update

Postby bamim2 » 20. May 2011, 02:38

I have an Ubuntu 10.10 guest running inside of Windows 7 Pro 64bit OS & it WAS working fine until today when I installed the newest update, VB 4.08 & the Guest Additions & rebooted. Several times. Now I have no network connection on the Ubuntu guest. I didn't change anything. I've checked the VB configs & they're still the same, the Linux side of things looks ok, but it says have (duh) no network connection. I've tried installing the Guest Additions again & rebooted several times, but I still have no network.

Can anyone give me something to look at, try, stomp on, beat on, throw or look at? Even if you could ask me to tell you something that might help you understand more about my problem so you can help, that would be great. I don't even know where to look for this. I can't try unplugging the network cable & plugging it back in or looking for a link light or anything, for obvious reasons & all of the several other guests work fine after the update as does the client side. I'm stumped, which obviously doesn't take much, but any help would be greatly appreciated.
Last edited by bamim2 on 20. May 2011, 15:32, edited 3 times in total.
bamim2
 
Posts: 74
Joined: 4. Jan 2011, 20:48
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Win7 Pro 32-bit, WinXP, Ubuntu 10, Win2003, BSD, Win7Pro, Win2008, Win2003, Solaris 10

Re: No network on Ubuntu guest after installing latest VB update

Postby Frank Mehnert » 20. May 2011, 15:01

Perhaps for some reason the MAC address of you Ubuntu guest changed. In that case the guest will create a new interface with a different name (e.g. eth1 if the previous interface was eth0). You can undo this by removing any /etc/udev/rules.d/*persistent* rule files and then reboot.
Frank Mehnert
Oracle Corporation
 
Posts: 2523
Joined: 7. Jun 2007, 09:11
Location: Dresden, Germany
Primary OS: Debian Lenny
VBox Version: PUEL
Guest OSses: Linux, Windows

Re: No network on Ubuntu guest after installing latest VB update

Postby bamim2 » 20. May 2011, 15:29

Well, I think you must have thrown some fear into my NIC, because for NO reason at all, it now works. It didn't create a new NIC & I don't see any difference today from yesterday, except that now it just started working. Thank you for your response. I always love this site because I ALWAYS get help, no matter how dumb MY questions are. Thank you!
bamim2
 
Posts: 74
Joined: 4. Jan 2011, 20:48
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Win7 Pro 32-bit, WinXP, Ubuntu 10, Win2003, BSD, Win7Pro, Win2008, Win2003, Solaris 10


Return to Linux Guests

Who is online

Users browsing this forum: No registered users and 21 guests