Ubuntu install on Vista host results in scrambled display.

Discussions about using Linux guests in VirtualBox.

Ubuntu install on Vista host results in scrambled display.

Postby bradtgmurray » 15. Feb 2010, 01:02

Just installed latest version of Virtual box (3.1.6), mounted Ubuntu Desktop 3.1.6 CD and attempted to install. The first menu where you choose a language and livecd/install mode is fine, however when I go to install or launch the live cd the display is greatly zoomed in to the top left corner of the screen with scrambled/mostly pink colours.

http://i.imgur.com/SoJEc.png

Any help would be greatly appreciated.
bradtgmurray
 
Posts: 5
Joined: 15. Feb 2010, 00:42
Primary OS: MS Windows Vista
VBox Version: OSE other
Guest OSses: Ubuntu

Re: Ubuntu install on Vista host results in scrambled display.

Postby Perryg » 15. Feb 2010, 01:35

Well the latest version of VirtualBox is 3.1.4 and I have never heard of Ubuntu 3.1.6 but what you are describing has been seen from time to time.
What is the Host setup? Everything such as memory, 32/64 bit..Etc.
What is the video card on the host?
Perryg
Site Moderator
 
Posts: 25964
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Ubuntu install on Vista host results in scrambled display.

Postby bradtgmurray » 15. Feb 2010, 01:57

Whoops, I meant Virtual box 3.1.4 and Ubuntu desktop 9.10 32-bit. Thanks for your help.

Host operating system is Windows Vista Ultimate x64. Video card is a NVIDIA GeForce 9600 GT w/ Driver version 191.07. Processor is an AMD Athlon 64 X2 Dual Core 4200+ (2.2Ghz). 6gb of RAM installed.

Virtual Machine Settings:
General
Name:Ubuntu
OS Type:Ubuntu

System
Base Memory:2048 MB
Processor(s):1
Boot Order:Floppy, CD/DVD-ROM, Hard Disk
VT-x/AMD-V:Enabled
Nested Paging:Enabled

?Display
Video Memory:32 MB
3D Acceleration:Disabled
2D Video Acceleration:Disabled
Remote Display Server:Disabled

?Storage
IDE Controller
IDE Primary Master: Ubuntu2.vdi (Normal, 40.00 GB)
IDE Secondary Master (CD/DVD): ubuntu-9.10-desktop-i386.iso (689.97 MB)
Floppy Controller
Floppy Device 0:Empty

?Audio
Host Driver:Windows DirectSound
Controller:ICH AC97

?Network
Adapter 1:PCnet-FAST III (NAT)

?Serial Ports
Disabled
?
USB
Device Filters:0 (0 active)
?
Shared Folders
None
bradtgmurray
 
Posts: 5
Joined: 15. Feb 2010, 00:42
Primary OS: MS Windows Vista
VBox Version: OSE other
Guest OSses: Ubuntu

Re: Ubuntu install on Vista host results in scrambled display.

Postby Perryg » 15. Feb 2010, 04:16

From the looks of it this should work. I would run the MD5 checksum and see if it is correct. Otherwise you may need to download it again.
Question: Can you run this as a live CD, and does it work that way?
Perryg
Site Moderator
 
Posts: 25964
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Ubuntu install on Vista host results in scrambled display.

Postby bradtgmurray » 15. Feb 2010, 04:28

The screenshot is from running as a live cd (you can kind of make out the word "Applications" from the gnome toolbar in the screenshot). The same issue occurs in both the install application as well as on the desktop when running as a live cd. The boot menu and the console (80x25 character mode) work fine. Running the CD verification thing from the boot menu reports no errors.

Is there anything else I should try? There doesn't seem to be anything interesting in the log file.
bradtgmurray
 
Posts: 5
Joined: 15. Feb 2010, 00:42
Primary OS: MS Windows Vista
VBox Version: OSE other
Guest OSses: Ubuntu

Re: Ubuntu install on Vista host results in scrambled display.

Postby Perryg » 15. Feb 2010, 04:41

Yeah try booting it direct to the host PC (just don't hit the install button). See if it has the same thing as the VM install does.
Perryg
Site Moderator
 
Posts: 25964
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Ubuntu install on Vista host results in scrambled display.

Postby marten » 15. Feb 2010, 22:03

Interesting - I tried to install Ubuntu 9.10/32 under Windows 7 HomePremium/64 and got the same problems here ... and found your postings ... (VirtualBox 3.1.2).
marten
 
Posts: 19
Joined: 4. May 2008, 13:33

Re: Ubuntu install on Vista host results in scrambled display.

Postby Perryg » 15. Feb 2010, 22:18

Very strange. I would suggest that you try a different OS live CD and see if it preforms the same way. Also try to boot the live CD in native mode (direct from the main PC).
If it boots in native mode and not in the VirtualBox program then I would suggest that you post a ticket at bugtracker. You will need to setup an account there as it is on a different system.
It would also help if you can post the ticket number here so other can see the progress, add information, or see the final results.
Perryg
Site Moderator
 
Posts: 25964
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Ubuntu install on Vista host results in scrambled display.

Postby bradtgmurray » 20. Feb 2010, 21:05

Thanks for your help, I've submitted a bug in the tracker: http://www.virtualbox.org/ticket/6254

I unfortunately don't have any blank media to try burning the image to a disk to try running the OS natively.
bradtgmurray
 
Posts: 5
Joined: 15. Feb 2010, 00:42
Primary OS: MS Windows Vista
VBox Version: OSE other
Guest OSses: Ubuntu

Re: Ubuntu install on Vista host results in scrambled display.

Postby Darkblood18 » 26. Feb 2010, 15:57

I was having the exact same problem under the following system:

Host OS: Win 7 Professional 64
Guest: Ubuntu 9.10 32bit
Dell Vostro 1520 (core 2 duo p8600, 4Gb ram, NVidia GeForce 9300M 256mb)
Vbox:3.1.4 (x86/amd64)

After reading the bug tracker entry ( http://www.virtualbox.org/ticket/6254 ) i tried increasing the video memory from the default (12mb) to 32 mb.

It´s fine now, just posting this as a possible solution. Maybe the bug tracker should get an update
Darkblood18
 
Posts: 2
Joined: 26. Feb 2010, 15:48
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Ubuntu

Re: Ubuntu install on Vista host results in scrambled display.

Postby bradtgmurray » 27. Feb 2010, 16:39

Oh awesome, this worked for me too. I had already increased it from 12 to 32, but bumping it up again to 48mb or RAM fixed the issue.

Thanks!
bradtgmurray
 
Posts: 5
Joined: 15. Feb 2010, 00:42
Primary OS: MS Windows Vista
VBox Version: OSE other
Guest OSses: Ubuntu

Re: Ubuntu install on Vista host results in scrambled display.

Postby Darkblood18 » 9. Mar 2010, 23:30

Just to be exact: this solution I posted (above) is somewhat erratic. I had to use the live CD again and sometimes it works and sometimes it doesn´t (i keep changing the vram between 32 and 64 till it works).

I seems to works well with the installed Ubuntu though.
Darkblood18
 
Posts: 2
Joined: 26. Feb 2010, 15:48
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Ubuntu

Re: Ubuntu install on Vista host results in scrambled display.

Postby UndyingShadow » 21. Mar 2010, 03:47

I'm having this exact issue on Win 7, and so far, changing the graphics memory hasn't helped AT all, and I've tried everything from min graphic memory to max graphic memory. I can't install nor run Ubuntu in live mode.
UndyingShadow
 
Posts: 1
Joined: 21. Mar 2010, 03:32
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: MS Windows XP Pro, Ubuntu


Return to Linux Guests

Who is online

Users browsing this forum: No registered users and 25 guests