disable mouse pointer integration

Discussions about using Linux guests in VirtualBox.

disable mouse pointer integration

Postby t-dome » 19. Jan 2010, 12:06

Hi,

I'm using Ubuntu 9.10 as a guest and I just installed the guest additions. But the mouse pointer doesn't work in some full screen games anymore.
How can I disable the mouse pointer integration? This Ubuntu version uses no xorg.conf .

Thanks
t-dome
 
Posts: 3
Joined: 19. Jan 2010, 11:58
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Ubuntu 9.10

Re: disable mouse pointer integration

Postby vbox4me2 » 19. Jan 2010, 12:08

The VBox menu for the VM has such option, Host+I.
vbox4me2
Volunteer
 
Posts: 5218
Joined: 21. Nov 2008, 20:27
Location: Rotterdam

Re: disable mouse pointer integration

Postby t-dome » 19. Jan 2010, 12:12

vbox4me2 wrote:The VBox menu for the VM has such option, Host+I.


Host+I doesn't do anything for me and I also cannot find an option in the menus.
t-dome
 
Posts: 3
Joined: 19. Jan 2010, 11:58
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Ubuntu 9.10

Re: disable mouse pointer integration

Postby t-dome » 19. Jan 2010, 12:17

I managed to disable mouse pointer integration by pressind the host key and then disable that option by right clicking on the mouse icon.
But now I don't see the cursor in linux anymore when the mouse is captured.
I just want to uninstall the mouse driver from Linux.
t-dome
 
Posts: 3
Joined: 19. Jan 2010, 11:58
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Ubuntu 9.10

Re: disable mouse pointer integration

Postby vbox4me2 » 19. Jan 2010, 12:19

Its there.

naamloos1.jpg
naamloos1.jpg (33.42 KiB) Viewed 19146 times
vbox4me2
Volunteer
 
Posts: 5218
Joined: 21. Nov 2008, 20:27
Location: Rotterdam

Re: disable mouse pointer integration

Postby craigsn » 12. Feb 2010, 23:43

I have the opposite problem. I've installed the Lucid Linx on my Karmic Koala, using VBox 3.1.2. But the mouse integration does not work. Is it a Lucid problem or is there something else I should do?

Thanks
craigsn
 
Posts: 19
Joined: 30. Jun 2007, 23:48

Re: disable mouse pointer integration

Postby vale » 12. Dec 2015, 18:45

I have a similar problem. I'm using Win 7 as a guest in an Ubuntu 14.04 host. I'm using a wacom tablet and in order to see the cursor (the tablet works fine except for that) I need to disable mouse integration. I know that works because it's how I've been using it till now. But the other day I upgraded to VBox 5 (I wasn't able to run my VM otherwise) and since then, HOST+I hasn't worked, it does absolutely nothing, and I don't have the option in the VM menu either.
I already installed guest additions (I even tried, following an advice from this forum, installing an older version and even the build test version offered by VirtualBOx), but to no result.
Any ideas as to what might be happening and or how to solve this? I really need to get work done and it's really difficult to draw/paint without knowing where you are. :-(
I'll submit the log just in case.

EDIT: I've found a solution to my problem, I went to "Devices" and unticked the USB Tablet, that released it (it was captured) and now I see the cursor. But the Mouse integration still has no changes.
EDIT: Me again. Hurried to be happy. Now I have no pressure (I had without the cursor) and the wacom settings tells me there's no connected tablet. So the real solution still is disabling mouse integration.
Attachments
Windows 1-2015-12-12-16-38-12.log
(118.17 KiB) Downloaded 19 times
vale
 
Posts: 9
Joined: 15. Mar 2015, 23:44


Return to Linux Guests

Who is online

Users browsing this forum: Google [Bot] and 14 guests