Can't mount shared folder after upgrade to 3.1.0

Discussions about using Linux guests in VirtualBox.

Can't mount shared folder after upgrade to 3.1.0

Postby Kakao » 1. Dec 2009, 13:56

Windows XP host. Fedora 12 64 guest.

After upgrading from 3.0.10 to 3.1.0 I cant' mount the shared folder anymore. I did reinstall Linux Addtions after upgrade.

Code: Select all   Expand viewCollapse view
# mount -t vboxsf Downloads /mnt
mount: wrong fs type, bad option, bad superblock on Downloads,
       missing codepage or helper program, or other error
       (for several filesystems (e.g. nfs, cifs) you might
       need a /sbin/mount.<type> helper program)
       In some cases useful info is found in syslog - try
       dmesg | tail  or so
# dmesg | tail
sf_read_super_aux err=-22
Kakao
 
Posts: 21
Joined: 29. Jul 2009, 20:29
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu 11.10, 12.04 and Centos 6

Re: Can't mount shared folder after upgrade to 3.1.0

Postby pirm » 1. Dec 2009, 17:51

I have the same problem with OS X (Leopard) host, and Fedora 11 (64 bits) guest, with the same error.
pirm
 
Posts: 1
Joined: 1. Dec 2009, 17:46
Primary OS: Mac OS X Leopard
VBox Version: PUEL
Guest OSses: Fedora 11

Re: Can't mount shared folder after upgrade to 3.1.0

Postby Sasquatch » 1. Dec 2009, 18:00

That error usually means that the SF module isn't installed properly. Please install the GA again and see how that goes.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: Can't mount shared folder after upgrade to 3.1.0

Postby Kakao » 1. Dec 2009, 18:14

Reinstalled and the problem persists.

Code: Select all   Expand viewCollapse view
# ./VBoxLinuxAdditions-amd64.run
Verifying archive integrity... All good.
Uncompressing VirtualBox 3.1.0 Guest Additions for Linux........
VirtualBox Guest Additions installer
Removing installed version of VirtualBox Guest Additions...
Building the VirtualBox Guest Additions kernel modules
Building the main Guest Additions module                   [  OK  ]
Building the shared folder support module                  [  OK  ]
Building the OpenGL support module                         [  OK  ]
Doing non-kernel setup of the Guest Additions              [  OK  ]
You should restart your guest to make sure the new modules are actually used

Installing the Window System drivers
Installing experimental X.Org Server 1.7 modules           [  OK  ]
Setting up the Window System to use the Guest Additions    [  OK  ]
You may need to restart the hal service and the Window System (or just restart
the guest system) to enable the Guest Additions.

Installing graphics libraries and desktop services componen[  OK  ]
Kakao
 
Posts: 21
Joined: 29. Jul 2009, 20:29
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu 11.10, 12.04 and Centos 6

Re: Can't mount shared folder after upgrade to 3.1.0

Postby culicidae » 1. Dec 2009, 21:57

Hello everyone,

I'm experiencing the exact same problem.
Host: Windows 7 Professional 64 Bit German
Guest: Fedora 11 64 Bit.

Reinstall didn't work either.
Any help would be greatly appreciated.


Thanks in advance,

culicidae
culicidae
 
Posts: 4
Joined: 1. Dec 2009, 20:33
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Fedora 11 (64 Bit)

Re: Can't mount shared folder after upgrade to 3.1.0

Postby Raere » 2. Dec 2009, 00:18

Having a similar problem here. I can mount shares if i I do it manually, but they no longer mount at startup via my init.d script. I did get a strange error when I tried to install the GA, something about having an old version (not helpful, I know). To those of you having trouble mounting even manually, try repairing the GA's:
Code: Select all   Expand viewCollapse view
sudo /etc/init.d/vboxadd setup


Anyone have an idea as to why I can mount manually, but not during startup? The script worked fine until I updated the GA's.
Raere
 
Posts: 7
Joined: 27. Mar 2009, 21:01
Primary OS: MS Windows Vista
VBox Version: PUEL
Guest OSses: Ubuntu, Windows Server 2008, Windows XP

Re: Can't mount shared folder after upgrade to 3.1.0

Postby culicidae » 2. Dec 2009, 00:56

Hello Raere,

I've tried that and sadly it didn't work.

btw. "dmesg | tail" (as recommended by the error message) brings up the following.

Code: Select all   Expand viewCollapse view
[user@fedora11 ~]$ dmesg | tail
sf_read_super_aux err=-22
sf_read_super_aux err=-22
sf_read_super_aux err=-22
sf_read_super_aux err=-71
sf_read_super_aux err=-22
sf_read_super_aux err=-71
sf_read_super_aux err=-71
sf_read_super_aux err=-71
sf_read_super_aux err=-71
sf_read_super_aux err=-22


and when I add "-o uid=##,gid=##" to the mount command I get a protocol error (no, share and mount-point are not named the same).


Greetings,

culicidae

--------
Edit:
# rpm -qa | grep vbox
doesn't output anything, shouldn't the guestaddons be brought up here?
culicidae
 
Posts: 4
Joined: 1. Dec 2009, 20:33
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Fedora 11 (64 Bit)

Re: Can't mount shared folder after upgrade to 3.1.0

Postby Raere » 3. Dec 2009, 04:45

No solution for the people having trouble mounting manually, but I figured out why my shares weren't mounting on boot (does anyone else actually have this problem after upgrading to 3.1.0 as well?) In init.d, the share script was set to run before the vboxadditions module was loaded. I just changed the script to run after the vboxadditions module, and that fixed it. This is all on Ubuntu 9.10 server, by the way.
Raere
 
Posts: 7
Joined: 27. Mar 2009, 21:01
Primary OS: MS Windows Vista
VBox Version: PUEL
Guest OSses: Ubuntu, Windows Server 2008, Windows XP

Re: Can't mount shared folder after upgrade to 3.1.0

Postby Perryg » 3. Dec 2009, 04:51

Well usually you would use rc.local to load these mounts. I used to use fstab but that was not correct.
Try to mount them using rc.local and see if this works.
Perryg
Site Moderator
 
Posts: 25959
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Can't mount shared folder after upgrade to 3.1.0

Postby culicidae » 3. Dec 2009, 20:58

Hello again,

I still didn't have any luck in mounting a shared folder. Anyone else got a good idea? It's very annoying having to upload every file to my ftp in order to re-download it from within the box (if I don't have a thumb drive handy).

Any suggestions would be greatly appreciated!

culicidae
culicidae
 
Posts: 4
Joined: 1. Dec 2009, 20:33
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Fedora 11 (64 Bit)

Re: Can't mount shared folder after upgrade to 3.1.0

Postby bouteill » 4. Dec 2009, 01:15

Same problem here... Tried everythin, nothing worked... HELP NEEDED! Thanks!
bouteill
 
Posts: 1
Joined: 4. Dec 2009, 01:13
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: fedora12

Re: Can't mount shared folder after upgrade to 3.1.0

Postby elemdu » 4. Dec 2009, 03:04

I have the same problem. I am using Mac OsX as host and Fedora 12 as guest.
My /sbin/mount.vboxsf is a link to /usr/lib/VBoxGuestAdditions/mount.vboxsf which does not exist.
Where can I find mount.vbox.sf?
elemdu
 
Posts: 2
Joined: 4. Dec 2009, 02:59
Primary OS: Mac OS X Leopard
VBox Version: PUEL
Guest OSses: Fedora 12

Re: Can't mount shared folder after upgrade to 3.1.0

Postby Kakao » 4. Dec 2009, 14:39

culicidae wrote:I still didn't have any luck in mounting a shared folder. Anyone else got a good idea? It's very annoying having to upload every file to my ftp in order to re-download it from within the box (if I don't have a thumb drive handy).

Any suggestions would be greatly appreciated!

What I am doing is to connect to the host using Nautilus (Fedora guest) "Connect to Server..":
1. Open Nautilus.
2. Go to File -> Connect to Server...
3. As the service type chose Windows Share.
4. Enter the Host's network name or IP address.
5. Enter any optional information.
6. Click on Connect.

Edit: If your guest don' t have a similar graphical solution try samba client configuration.
Last edited by Kakao on 4. Dec 2009, 14:44, edited 1 time in total.
Kakao
 
Posts: 21
Joined: 29. Jul 2009, 20:29
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu 11.10, 12.04 and Centos 6

Re: Can't mount shared folder after upgrade to 3.1.0

Postby culicidae » 4. Dec 2009, 14:40

I solved the problem (at lease for my machine)!

Despite installing the GuestAddons for 64 Bit OS (Fedora 11 in my case) the link in /sbin/mount.vboxsf points to /usr/lib/... where it should be /usr/lib64/

Hope that helps!

Greetings,
culicidae
culicidae
 
Posts: 4
Joined: 1. Dec 2009, 20:33
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Fedora 11 (64 Bit)

Re: Can't mount shared folder after upgrade to 3.1.0

Postby Kakao » 4. Dec 2009, 15:01

Kakao
 
Posts: 21
Joined: 29. Jul 2009, 20:29
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu 11.10, 12.04 and Centos 6

Next

Return to Linux Guests

Who is online

Users browsing this forum: No registered users and 15 guests