Ubuntu Server Bridged Networking Not Working

Discussions about using Linux guests in VirtualBox.

Ubuntu Server Bridged Networking Not Working

Postby carloc » 24. Aug 2009, 17:07

Hi,

I have this dilemma whenever i try to install an ubuntu server into my machine.
It seems that the network always doesn't work properly.

I am using Virtualbox 3.0.4.

My host is linux mint 7, i tried it on vista as well.

I am installing a guest ubuntu server 9.0.4.
NAT works properly but Bridged Networking doesn't seem to work at all.

How can I get bridged networking to work for virtualbox ubuntu server guests?

Is there anything else I need to configure for ubuntu server?

Thanks
carloc
 
Posts: 4
Joined: 24. Aug 2009, 17:03
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Linux

Re: Ubuntu Server Bridged Networking Not Working

Postby Perryg » 24. Aug 2009, 17:25

Do you have a router?
Bridged will not work unless you do.
Perryg
Site Moderator
 
Posts: 34373
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Ubuntu Server Bridged Networking Not Working

Postby carloc » 24. Aug 2009, 17:36

Perryg wrote:Do you have a router?
Bridged will not work unless you do.


yes i have a router.
thanks
carloc
 
Posts: 4
Joined: 24. Aug 2009, 17:03
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Linux

Re: Ubuntu Server Bridged Networking Not Working

Postby Perryg » 24. Aug 2009, 17:54

Usually Bridge mode problems are due to improperly configured guest network settings or a problem with DNS.
If you are trying to use DHCP and it does not work then try setting Static address and see if this helps. Selecting an external DNS server can also help.
If you are still having problems send the results of ifconfig from the host and guest.
Perryg
Site Moderator
 
Posts: 34373
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX


Return to Linux Guests

Who is online

Users browsing this forum: No registered users and 1 guest