3D effects lag in Ubuntu 9.04 guest

Discussions about using Linux guests in VirtualBox.

3D effects lag in Ubuntu 9.04 guest

Postby alant » 3. Aug 2009, 15:51

I have searched and have not found any posts with an issue resembling mine. After installing the guest additions and upon reboot, the 3d effects in 9.04 work, however there is a lag where the menus will give a ghost image after closing it. The fading is not fading out I guess you could say. When going into preferences there is a delay when clicking on different tabs. If I disable effects everything works fine. Is this familiar to anyone?

Specs: Guest OS - Ubuntu 9.04 32bit
CPU: 2-cores of a quad core dedicated to machine
RAM: 3GB out of 8GB dedicated to virtual
Video: 100MB video memory- not 128 due to the login screen issue- but using 128 did not help my described problem
HDD: virtual is using one expanding 40 GB hdd

HOST OS: Windows 7 RC 64-bit
alant
 
Posts: 5
Joined: 30. Jul 2009, 22:06
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Ubuntu, Server 2008

Re: 3D effects lag in Ubuntu 9.04 guest

Postby Sasquatch » 3. Aug 2009, 19:55

Your problem is the Host. Windows 7, especially the 64 bit version, doesn't have full OpenGL features that are fast enough for the Guest to use. All that you see as 'ghosting', is the effects after-image because of the slowness of the whole system. SMP is also a possible cause, change the amount of cores back to 1, it might solve it for you. There are quite a few users who reported slower VM responses after they enabled SMP.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: 3D effects lag in Ubuntu 9.04 guest

Postby alant » 3. Aug 2009, 20:47

Thanks,

As I was typing my post I told myself I should try that since it is new and I never had the problem in 7 before. That will be the first thing I try and will post a result.
alant
 
Posts: 5
Joined: 30. Jul 2009, 22:06
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Ubuntu, Server 2008

Re: 3D effects lag in Ubuntu 9.04 guest

Postby alant » 5. Aug 2009, 19:39

I set the machine back to use 1 CPU and left all of the other settings to alone and still has a delay on the effects. I didn't mention the GPU eariler. I am using a GTS 250 with 512MB of RAM.

Are any other Windows 7 RC x64 users experiencing the same delay?
alant
 
Posts: 5
Joined: 30. Jul 2009, 22:06
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Ubuntu, Server 2008

Re: 3D effects lag in Ubuntu 9.04 guest

Postby alant » 5. Aug 2009, 19:49

I saw the below fix in the 3.0.4 Changelog.
"3D support: fix memory leaks when terminating OpenGL guest applications "

I will update later and see if that fixes the issue.

Any thoughts?
alant
 
Posts: 5
Joined: 30. Jul 2009, 22:06
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Ubuntu, Server 2008

Re: 3D effects lag in Ubuntu 9.04 guest

Postby alant » 10. Aug 2009, 18:09

After updating to 3.04 I did notice a slight decrease in 3d effects lag. I did a clean install of of Ubuntu 9.04 to a new virtual. There is still some delay on the menus which seems to be continuous. The windows effects seem to be a little bit better. I guess we will just need to wait a little bit longer and leave 3d effects off for now if we are going to use Windows 7 as a host. I didn't notice any issues in a Vista host a couple of months back.
alant
 
Posts: 5
Joined: 30. Jul 2009, 22:06
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Ubuntu, Server 2008

Re: 3D effects lag in Ubuntu 9.04 guest

Postby dawnh » 12. Aug 2009, 16:52

I've got exactly the same problem. Host OS is Win7 X64 Ultimate RTM, GPU is ATI HD36650, guest OS Ubuntu 9.04, virtualbox version 3.04.
Turn off or on SMP does no help.
So this issue must be fixed by MS?
dawnh
 
Posts: 1
Joined: 12. Aug 2009, 16:47
Primary OS: MS Windows 7
VBox Version: OSE Fedora
Guest OSses: Ubuntu 9.04

Re: 3D effects lag in Ubuntu 9.04 guest

Postby TheBigBabou » 12. Aug 2009, 20:32

I don't know whether MS is to blame. I am having the same lag or ghosting and I am running on a Windows XP 64bit host. The Problem occurs with an Ubuntu 9.04 64bit as well as an Ubuntu 9.10 alpha 64bit as guest. My System with a Core2 Quad and an nvidia 8800 GTS shouldn't be a limitation here.

The reason this problem didn't occur some month ago might be, that Virtualbox 2 didn't have this strange behaviour. Or at least I don't recall having problems with the same setup, except of the virtualbox version. I'm using the latest 3.0.4 version of virtualbox now.

So I didn't find any working solution, maybe someone else has?
TheBigBabou
 
Posts: 1
Joined: 12. Aug 2009, 20:22
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Ubuntu 9.04, 9.10 alpha

Re: 3D effects lag in Ubuntu 9.04 guest

Postby Cypher100 » 13. Aug 2009, 03:12

It also ghosts on the menu on my Nvidia 9800GTX+ Super clocked Edition. I am using windows 7 64bit and I updated the GPU drivers and it still does that ghost thing.
Cypher100
 
Posts: 1
Joined: 13. Aug 2009, 01:04
Primary OS: MS Windows 7
VBox Version: OSE Debian
Guest OSses: Ubuntu

Re: 3D effects lag in Ubuntu 9.04 guest

Postby killerclems » 13. Aug 2009, 12:00

Same problem with XP SP2 Host and Ubuntu 9.04 guest (last version of VBox), on a Core Duo 8500 + Nvidia 8800 GT (drivers up to date). Menus and windows are ghosting for a very short time (1-2 seconds) after being closed. And it happens randomly. But so far, it doesnt really prevent me to use my Ubuntu VM ;)

PS : This problem wasn't there a few version ago (before VBox 3)
killerclems
 
Posts: 15
Joined: 14. Apr 2009, 18:55
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu 10.04

Re: 3D effects lag in Ubuntu 9.04 guest

Postby speed8500 » 13. Aug 2009, 18:38

Same issue. Windows 7 RC x64 host with Ubuntu 9.04 x86 guest. Lots of noticeable lag in graphical effects.

I was very surprised when the Ubuntu guest had more graphical lag than my Vista x86 guest.
speed8500
 
Posts: 1
Joined: 13. Aug 2009, 18:33
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Ubuntu 9.04

Re: 3D effects lag in Ubuntu 9.04 guest

Postby Sasquatch » 13. Aug 2009, 20:33

speed8500 wrote:Same issue. Windows 7 RC x64 host with Ubuntu 9.04 x86 guest. Lots of noticeable lag in graphical effects.

I was very surprised when the Ubuntu guest had more graphical lag than my Vista x86 guest.

That's not so strange, because the Linux Guest used advanced 3D graphics to display them, while your Vista VM isn't even capable of Aero.


Just a note for those with issues, I fired up my Linux VM and enabled Compiz again and no lag or ghosting. This is on a Linux (Ubuntu 9.04) Host, nVidia 7800 GTX and the 185.18 nVidia driver. Along with that, I have Compiz-Fusion on my Host too. So it seems it's a Windows Host problem, either MS is at fault, or VB.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: 3D effects lag in Ubuntu 9.04 guest

Postby windsok » 14. Aug 2009, 11:33

Hi,

Just chiming in to say that I have the exact same problem with Windows 7 64bit Host and Ubuntu 9.04 Guest.

I get the same ghosting as described above, and there is noticable lag, even when simply typing into a terminal.

Turning off 3D support in VirtualBox made it very snappy again.
windsok
 
Posts: 2
Joined: 14. Aug 2009, 11:31
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Ubuntu 9.04

Re: 3D effects lag in Ubuntu 9.04 guest

Postby silvaran » 15. Aug 2009, 03:17

If I can offer a slightly different perspective on this. It almost seems like VirtualBox is being too premature on deciding when to stop video updates.

So I'm running Windows 7 RC 64-bit on an Asus M50Sv (4gb RAM, NVIDIA 9500M w/512MB discrete), VirtualBox 3.0.4. While creating the guest, here are the options I enabled that weren't enabled by default that may be relevant to this:

- Set 128MB video RAM available to guest.
- Enabled 3D support
- Enabled nested page tables (or whatever it's called).

Everything else is supported and enabled by default (like Intel VT instructions, ACPI support IO-APIC, and only 1 processor). I installed Ubuntu 9.04 64-bit, then installed the guest tools, rebooted, and the Compiz 3D effects were enabled as soon as I logged in. I noticed the lag that everyone else is describing, but I'd explain it differently.

So I go to load the appearance preferences window, and it fades into view. Is almost like it gets 95% of the way into view (visible, but a few colors are still off because the window hasn't fully drawn itself yet) and VirtualBox prematurely decides, that's enough, I don't need to track any more display changes for now, and it accepts that mostly-drawn window as the final thing it needs to track and display before it can just sit there waiting for more display changes. After a few seconds of idling, the display gets updated to what it should look like, without actually having used any significant amount of system resources during that waiting period. Or, the display could get updated immediately simply by moving the window (and presumably forcing a display update).

I disabled all the 3D effects and everything looks fine visually. No idea whose bug it is, just thought I'd offer this.
silvaran
 
Posts: 1
Joined: 15. Aug 2009, 03:05
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu 9.04 64-bit

Re: 3D effects lag in Ubuntu 9.04 guest

Postby gregory » 25. Aug 2009, 15:13

I have exactly the same problem using Vista Home 64 as host and Ubuntu 9.04 as guest. The problem appeared in VB 3.04. I updated VB yesterday from 2.2.x to 3.0.4. The 3D effects worked perfectly with VB 2.2.x.
I tend to agree with silvaran. The artifact occurs only when I close a window or close a menu. The ghost window/menu stays 1 or two seconds, but if I click on the desktop or move a window during this period of two seconds, the screen is updated and the problem disappears.
gregory
 
Posts: 3
Joined: 4. May 2009, 19:52
Primary OS: MS Windows Vista
VBox Version: PUEL
Guest OSses: Ubuntu

Next

Return to Linux Guests

Who is online

Users browsing this forum: No registered users and 19 guests