Page 1 of 1

Ubuntu 9.04 error vboxvideo

PostPosted: 27. Apr 2009, 15:50
by Jean-Mi
Hello

I ran a Ubuntu guest (8.10) in a Virtual Box (version 2.2.0) on my Win XP host.

After the upgrade of Ubuntu to new version 9.04, the Virtual Box has an error at startup.

The message is :
Ubuntu is running in low-graphics mode

The following error was encoutered. You may need
to update your configuration to solve it.

(EE) module ABI major version (4) doesn't match the
server's version (5)
(EE) failed to load module "vboxvideo" (module requirement
mismatch,0)
(EE) No drivers available.


None of the proposed options solve the problem.

What can I do to use my Ubuntu guest again ?

Thanks for the help.

Jean-Michel

Re: Ubuntu 9.04 error vboxvideo

PostPosted: 27. Apr 2009, 15:56
by Sasquatch
Install the GA again. Drop to a virtual terminal by hitting HOST+F2, then follow my howto at the top.

Re: Ubuntu 9.04 error vboxvideo

PostPosted: 30. Apr 2009, 11:52
by Binome
Where is your howto? Sorry for asking.

Re: Ubuntu 9.04 error vboxvideo

PostPosted: 30. Apr 2009, 13:48
by vbox4me2
Binome wrote:Where is your howto? Sorry for asking.

Are you blind?

howtoblindness.jpg
howtoblindness.jpg (25.97 KiB) Viewed 12851 times

Re: Ubuntu 9.04 error vboxvideo

PostPosted: 30. Apr 2009, 14:29
by Binome
I tried clicking on "User Howto and tutorials " in the end of your message but then I don't know what to look at.
And I'm not really blind but a bit visually impaired :-(

Re: Ubuntu 9.04 error vboxvideo

PostPosted: 30. Apr 2009, 15:15
by vbox4me2

Re: Ubuntu 9.04 error vboxvideo

PostPosted: 30. Apr 2009, 17:42
by Sasquatch
Binome wrote:Where is your howto? Sorry for asking.

Like I said, at the TOP of the page. First, second topic... You must really be visually impaired if you can't spot that, but you can see your own topic. Ah well, link is given.

Re: Ubuntu 9.04 error vboxvideo

PostPosted: 8. May 2009, 18:01
by karatedog
I got the same error as Binome after upgrading Ubuntu 8.1 to 9.04.

- select the offered low resolution startup mode,
- Ubuntu will complain that something is on display:0 and it will try to start the x server on display:1
- accept it, Ubuntu starts
- install Guest Additions,
- and finally restart the operating system.

If you don't install GA before restarting Ubuntu, you'll get into the same error cycle.

Re: Ubuntu 9.04 error vboxvideo

PostPosted: 8. May 2009, 23:54
by Sasquatch
karatedog wrote:I got the same error as Binome after upgrading Ubuntu 8.1 to 9.04.

- select the offered low resolution startup mode,
- Ubuntu will complain that something is on display:0 and it will try to start the x server on display:1
- accept it, Ubuntu starts
- install Guest Additions,
- and finally restart the operating system.

If you don't install GA before restarting Ubuntu, you'll get into the same error cycle.

What I did with my upgrade, was after the initial reboot for the upgrade to be completed, I dropped to a virtual terminal when X was giving the error and installed the GA again. So I hit Host+F2, log in on the command line, then followed the steps in my howto. With that, you don't need to reconfigure your xorg.conf file, or get it messed up.