Ubuntu 9.04 error vboxvideo

Discussions about using Linux guests in VirtualBox.

Ubuntu 9.04 error vboxvideo

Postby Jean-Mi » 27. Apr 2009, 15:50

Hello

I ran a Ubuntu guest (8.10) in a Virtual Box (version 2.2.0) on my Win XP host.

After the upgrade of Ubuntu to new version 9.04, the Virtual Box has an error at startup.

The message is :
Ubuntu is running in low-graphics mode

The following error was encoutered. You may need
to update your configuration to solve it.

(EE) module ABI major version (4) doesn't match the
server's version (5)
(EE) failed to load module "vboxvideo" (module requirement
mismatch,0)
(EE) No drivers available.


None of the proposed options solve the problem.

What can I do to use my Ubuntu guest again ?

Thanks for the help.

Jean-Michel
Jean-Mi
 
Posts: 1
Joined: 27. Apr 2009, 15:42
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Ubuntu

Re: Ubuntu 9.04 error vboxvideo

Postby Sasquatch » 27. Apr 2009, 15:56

Install the GA again. Drop to a virtual terminal by hitting HOST+F2, then follow my howto at the top.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: Ubuntu 9.04 error vboxvideo

Postby Binome » 30. Apr 2009, 11:52

Where is your howto? Sorry for asking.
Binome
 
Posts: 51
Joined: 18. May 2008, 16:54

Re: Ubuntu 9.04 error vboxvideo

Postby vbox4me2 » 30. Apr 2009, 13:48

Binome wrote:Where is your howto? Sorry for asking.

Are you blind?

howtoblindness.jpg
howtoblindness.jpg (25.97 KiB) Viewed 10991 times
vbox4me2
Volunteer
 
Posts: 5218
Joined: 21. Nov 2008, 20:27
Location: Rotterdam

Re: Ubuntu 9.04 error vboxvideo

Postby Binome » 30. Apr 2009, 14:29

I tried clicking on "User Howto and tutorials " in the end of your message but then I don't know what to look at.
And I'm not really blind but a bit visually impaired :-(
Binome
 
Posts: 51
Joined: 18. May 2008, 16:54


Re: Ubuntu 9.04 error vboxvideo

Postby Sasquatch » 30. Apr 2009, 17:42

Binome wrote:Where is your howto? Sorry for asking.

Like I said, at the TOP of the page. First, second topic... You must really be visually impaired if you can't spot that, but you can see your own topic. Ah well, link is given.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: Ubuntu 9.04 error vboxvideo

Postby karatedog » 8. May 2009, 18:01

I got the same error as Binome after upgrading Ubuntu 8.1 to 9.04.

- select the offered low resolution startup mode,
- Ubuntu will complain that something is on display:0 and it will try to start the x server on display:1
- accept it, Ubuntu starts
- install Guest Additions,
- and finally restart the operating system.

If you don't install GA before restarting Ubuntu, you'll get into the same error cycle.
karatedog
 
Posts: 8
Joined: 2. Apr 2009, 22:10
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Ubuntu 9.10, Windows XP, Windows 7, Debian 5 server 64-bit

Re: Ubuntu 9.04 error vboxvideo

Postby Sasquatch » 8. May 2009, 23:54

karatedog wrote:I got the same error as Binome after upgrading Ubuntu 8.1 to 9.04.

- select the offered low resolution startup mode,
- Ubuntu will complain that something is on display:0 and it will try to start the x server on display:1
- accept it, Ubuntu starts
- install Guest Additions,
- and finally restart the operating system.

If you don't install GA before restarting Ubuntu, you'll get into the same error cycle.

What I did with my upgrade, was after the initial reboot for the upgrade to be completed, I dropped to a virtual terminal when X was giving the error and installed the GA again. So I hit Host+F2, log in on the command line, then followed the steps in my howto. With that, you don't need to reconfigure your xorg.conf file, or get it messed up.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux


Return to Linux Guests

Who is online

Users browsing this forum: Google [Bot] and 13 guests