Ubuntu 9.04 installation fail

Discussions about using Linux guests in VirtualBox.
Boten
Posts: 6
Joined: 19. Dec 2008, 08:50
Primary OS: Ubuntu 8.10
VBox Version: VirtualBox+Oracle ExtPack
Guest OSses: Windows XP, Ubuntu Linux
Location: Tomsk, Russia
Contact:

Ubuntu 9.04 installation fail

Post by Boten »

I've tryed to install Ubuntu 9.04 beta (livecd) on fresh 2.2.0 VBox release. Loading and starting installation program finishes normally, but when the installation progress reaches hardware detection stage, the whole system stops respond during several seconds. In these seconds, the guest X server crashes, and there is a login screen shows. As a solution of this problem, I can install the alternate version, but it will take very much time to download it again :( My host system is Ubuntu 8.10. A hardware acceleration is enabled (now it's enabled by default in newly created machines), my hardware supports it (Athlon 64 X2 4200+). How can I solve this problem?
Sasquatch
Volunteer
Posts: 17798
Joined: 17. Mar 2008, 13:41
Primary OS: Debian other
VBox Version: VirtualBox+Oracle ExtPack
Guest OSses: Windows XP, Windows 7, Linux
Location: /dev/random

Re: Ubuntu 9.04 installation fail

Post by Sasquatch »

Disabled 3D during setup. That might prevent X from crashing when it's detecting hardware. I actually always use the alternate installer for Ubuntu, so I never had this issue.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Boten
Posts: 6
Joined: 19. Dec 2008, 08:50
Primary OS: Ubuntu 8.10
VBox Version: VirtualBox+Oracle ExtPack
Guest OSses: Windows XP, Ubuntu Linux
Location: Tomsk, Russia
Contact:

Re: Ubuntu 9.04 installation fail

Post by Boten »

3D accel is disabled during installation. It doesn't help me.
Lord_Phoenix
Posts: 9
Joined: 14. Apr 2009, 08:55
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: WinXP, Ubuntu
Location: Moscow, Russia
Contact:

Re: Ubuntu 9.04 installation fail

Post by Lord_Phoenix »

I've tried to install 9.04 beta and installation went well, but it cannot boot once it finished :-(
---
If only I could virtulize myself
AleWi
Posts: 5
Joined: 22. Apr 2009, 16:48
Primary OS: MS Windows Vista
VBox Version: VirtualBox+Oracle ExtPack
Guest OSses: Windows XP, 7, 98, 95 and Ubuntu

Re: Ubuntu 9.04 installation fail

Post by AleWi »

No, its Ubuntu 9.04 finnished, but i dont get to install.
Its only a black screen.
spybot
Posts: 7
Joined: 4. Mar 2008, 14:24
Primary OS: MS Windows 7
VBox Version: VirtualBox+Oracle ExtPack
Guest OSses: Ubuntu 9.10, Fedora 11
Location: Russia
Contact:

Re: Ubuntu 9.04 installation fail

Post by spybot »

I've just installed Ubuntu 9.04 on virtualbox 2.2.0 under windows. I didn't notice any errors during setup. But I found some bug after installing guest additions - cursor doesn't appear on screen. I can move it, do something as usual, but cursor itself, as an image, doesn't appear :(
AleWi
Posts: 5
Joined: 22. Apr 2009, 16:48
Primary OS: MS Windows Vista
VBox Version: VirtualBox+Oracle ExtPack
Guest OSses: Windows XP, 7, 98, 95 and Ubuntu

Re: Ubuntu 9.04 installation fail

Post by AleWi »

No the window starting, but the setup close after 1 secound.
Lakelander
Posts: 6
Joined: 23. Apr 2009, 19:50
Primary OS: MS Windows 7
VBox Version: VirtualBox+Oracle ExtPack
Guest OSses: Ubuntu, Windows XP, Jolicloud
Location: Helsinki, Finland

Re: Ubuntu 9.04 installation fail

Post by Lakelander »

spybot wrote:I've just installed Ubuntu 9.04 on virtualbox 2.2.0 under windows. I didn't notice any errors during setup. But I found some bug after installing guest additions - cursor doesn't appear on screen. I can move it, do something as usual, but cursor itself, as an image, doesn't appear :(
I have same problem: no mouse integration, no mouse cursor.

My host: Windows Vista Ultimate 64bit SP1
My guest: Ubuntu 9.04 32 bit
My VirtualBox: 2.2.0
Perryg
Site Moderator
Posts: 34369
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Ubuntu 9.04 installation fail

Post by Perryg »

You should not need this, but older versions needed the following in their XORG.CONF file for the mouse to work properly. You can try to see if this will work around your problem. Let me know if this works or not.

Code: Select all

Section "InputDevice"
        Identifier  "vboxmouse"
        Driver          "vboxmouse"
        Option          "CorePointer"
        Option          "Device"        "/dev/input/mice"
EndSection
spybot
Posts: 7
Joined: 4. Mar 2008, 14:24
Primary OS: MS Windows 7
VBox Version: VirtualBox+Oracle ExtPack
Guest OSses: Ubuntu 9.10, Fedora 11
Location: Russia
Contact:

Re: Ubuntu 9.04 installation fail

Post by spybot »

Problem solved, thanks mate :)
AleWi
Posts: 5
Joined: 22. Apr 2009, 16:48
Primary OS: MS Windows Vista
VBox Version: VirtualBox+Oracle ExtPack
Guest OSses: Windows XP, 7, 98, 95 and Ubuntu

Re: Ubuntu 9.04 installation fail

Post by AleWi »

It now works after i update my 8.10 install.
sej7278
Volunteer
Posts: 1003
Joined: 5. Sep 2008, 14:40
Primary OS: Debian other
VBox Version: VirtualBox+Oracle ExtPack
Guest OSses: Solaris, Linux, Windows, OS/2, MacOSX, FreeBSD
Contact:

Re: Ubuntu 9.04 installation fail

Post by sej7278 »

9.04 desktop final 64-bit installation went fine for me - had to edit the xorg.conf as above to get my mouse pointer back after GA install.

compiz works out-of-the-box now though, better than 8.10
anfo.at
Posts: 6
Joined: 16. Apr 2009, 10:50
Primary OS: MS Windows Vista
VBox Version: VirtualBox+Oracle ExtPack
Guest OSses: XP SP3, CentOS 5.3
Contact:

Re: Ubuntu 9.04 installation fail

Post by anfo.at »

Same mouse problem here - Ubuntu 9.04 64Bit final, Vista x64 SP1 Host -; thanks Perryg!
Lakelander
Posts: 6
Joined: 23. Apr 2009, 19:50
Primary OS: MS Windows 7
VBox Version: VirtualBox+Oracle ExtPack
Guest OSses: Ubuntu, Windows XP, Jolicloud
Location: Helsinki, Finland

Re: Ubuntu 9.04 installation fail

Post by Lakelander »

Problem with lost mouse cursor and mouse integration solved by adding "InputDevice" section to xorg.conf as Perryg suggest. Thanks a lot!
Lord_Phoenix
Posts: 9
Joined: 14. Apr 2009, 08:55
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: WinXP, Ubuntu
Location: Moscow, Russia
Contact:

Re: Ubuntu 9.04 installation fail

Post by Lord_Phoenix »

Just installed final release and no problem so far. Works very fast on VB 2.1.4.
---
If only I could virtulize myself
Post Reply