Page 1 of 1

Black Screen/Blinking Cursor on Ubuntu Start

PostPosted: 25. Oct 2021, 19:12
by jh0003
Hello, I ran into a "disk is full" message a few days ago. I was trying to do run some programs in the VM. It hanged and stayed unresponsive for a very long time so I forced quit virtual box on my mac. I cant seem to reboot the system after that. I get the Ubuntu splash screen (black with the Ubuntu logo rotating), then a quick flash of logs, then either a black screen or a black screen with a blinking cursor that takes no input.

I have tried the following fixes :
- increased and decreased the amount of RAM, VRAM, and CPU cores available
- increased the disk size from 10gb to 13gb
- exported then imported it to another vm machine
- create a new vm, then attach vdi disk to new vm.

None seemed to work and I am still stuck in this state after hours of trouble shooting.
I am currently rushing to complete an assignment, all my files are in this VM. Creating a new vm didnt work for me. I am very new to virtualbox...would appreciate any help/ guidance. Thank you so much !!

log files :

Re: Black Screen/Blinking Cursor on Ubuntu Start

PostPosted: 25. Oct 2021, 19:19
by scottgus1
A quick look at the log did not show me any problems in running the VM's "hardware", this is probably a problem in the OS.

Ubuntu is known to black-screen if the disk fills up. Then the desktop environment does not have space to load. Happens in real PC's too. Web-search how to log onto the VM OS text-only, then delete stuff. Also see How to resize a Virtual Drive on how to get more disk space.

Re: Black Screen/Blinking Cursor on Ubuntu Start

PostPosted: 25. Oct 2021, 19:56
by jh0003
hello, thank you for the prompt response.

I have increased the disk size from 10gb to 13gb, applied the change, but unfortunately im still stuck on the black screen.
- after changing disk size, I tried to reboot directly, it didnt work. I tried restarting the virtualbox application then reboot the vm. I also tried restarting my mac, but that didnt work too D;

I tried googling how to launch vm os text-only, and managed to find one page that I understand. It involves using headless start. I tried following the steps but nothing happened too. It launched the vm without launching a new window like it normally does. There is a small preview window in the dashboard which shows what's going on. I could see that it got stuck on the same black screen.

The page i followed can be retrieved by google searching "start-a-vm-in-virtualbox-without-gui superuser". It should be the first response that pops out ( a post from 4 years ago ). I attached a screenshot of the steps. (im a new user on this forum so I cant post u r l)

what else can i try ? can i possibly delete files from the disk without actually loading the disks?

edit : i cant add screenshots of the file because its too big ;(

Re: Black Screen/Blinking Cursor on Ubuntu Start

PostPosted: 25. Oct 2021, 20:09
by scottgus1
jh0003 wrote:increased the disk size from 10gb to 13gb

There are two steps in the "How to Resize a Drive" tutorial. You got Step 1. What about Step 2?

jh0003 wrote:launch vm os text-only

is not
scottgus1 wrote:log onto the VM OS text-only

You don't have to start the VM headless. You have to access the VM's OS through the Ubuntu OS's command line. This can be done in a regular VM.

Did you web-search how to fix an Ubuntu PC that won't start the desktop because the disk is filled up? That's your problem, not anything in Virtualbox. If it happens on a real PC too, then you fix it like you're sitting at a real PC.

Note that I am not a Linux guru, so I don't know how to log onto a Linux OS text-only and delete stuff. I think it involves an option in the grub loader to get access to the OS's command line. The above web-search will tell you what to do.

This issue isn't being caused by Virtualbox, so there's no Virtualbox changes that can fix it.

If you get really stuck, and you only need the files on the drive, you can try making a new VM with a new OS installation, then attach the old VM's drive file to the new VM as a second drive and get the files. On a Windows host, 7-zip may be able to access the VM's disk files and allow extracting files. A Mac zip archive program may be able to do the same thing.