Display resolution limited to 640x480 after installation of GA in RHEL 4

Discussions about using Linux guests in VirtualBox.
Post Reply
Posts: 13
Joined: 16. Mar 2023, 13:34

Display resolution limited to 640x480 after installation of GA in RHEL 4

Post by Rotator »

Dear all,

a long time ago we have got a VM that has been set up for VmWare Player (probably version 4.x.x). That VM contains a Red Hat Enterprise Linux 4 installation that involves multiple virtual disks. That VM has been provided by a supplier and contains software that is tailored to that O/S and that is very important to us. There is currently no chance to upgrade that software or to make it run on a newer Linux system.

I have managed to create a virtual machine in VirtualBox so that the system started without any issue. Then I removed the VmWare tools, which worked fine. Finally, I installed the VirtualBox guest additions (GA). That worked as well (e.g. seamless mouse integration, shared folders), but since that installation, the display resolution is limited to 640x480. I have tried to change this by re-configuring the X server and via the KDE system settings, but nothing helps. The KDE system settings show 640x480 as the only option.

I have tried to change the kind of display adapter in the VM configuration, but to no avail (tried every option, but none made the guest offer additional display resolutions).

Any ideas about how to solve that problem?

Side note: We could go without the most part of the GA, e.g. the seamless mouse integration. However, we can't go without shared folders, because the software in the VM doesn't work without them. That's the primary reason for installing the GA in the first place.

Thank you very much, and best regards.
Site Moderator
Posts: 20945
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: VirtualBox+Oracle ExtPack
Guest OSses: Windows, Linux

Re: Display resolution limited to 640x480 after installation of GA in RHEL 4

Post by scottgus1 »

I'd lean towards trying (on a test copy of the VM) using the old-school VboxVGA video card (not VboxSVGA, note the S) which was all that was available in Virtualbox after RHEL 4 came out.

Uninstall GAs, reboot, then shut down.
Switch the video card to VboxVGA.
Start, log in, and shut down the VM a couple times so the new video card gets recognized.
Start the VM, install GAs again.
See what happens.

Also, like in your other post on this RHEL 4 VM, try a brand-new RHEL 4 VM and see if GAs work correctly. If they do in the new VM, then the problem is in the old VM's OS, not in Virtualbox.
Rotator wrote:we can't go without shared folders
You could always put a Bridged or Host-Only network in the VM and use the host OS's real shared folders, instead of Virtualbox Shared Folders.
Post Reply