VMSVGA + 3d Acceleration = White icons, white desktop, blocky text?

Discussions about using Linux guests in VirtualBox.

VMSVGA + 3d Acceleration = White icons, white desktop, blocky text?

Postby williamsdyyz » 4. Aug 2021, 15:33

Hi. Wondering if anyone can shed any light on this or suggest a way of diagnosing?

Mint/Cinnamon Guest on Windows 10 host (21H1 19043.1151)

The VM has been running fine with VMSVGA+3d Acceleration for months, now after a Windows update it boots to a messed up desktop:
Screenshot 2021-08-04 092812.png
Screenshot 2021-08-04 092812.png (29.58 KiB) Viewed 1985 times


If I turn off 3d acceleration, everything is OK, but obviously slow.

Tried updating to latest VirtualBox & guest additions, but no change.
I don't see anything obviously wrong in the VB log.
williamsdyyz
 
Posts: 8
Joined: 27. Nov 2019, 16:16

Re: VMSVGA + 3d Acceleration = White icons, white desktop, blocky text?

Postby scottgus1 » 4. Aug 2021, 19:43

Looks very weird. Did you try reinistalling the existing version of Virtualbox?

3D acceleration uses host video drivers to work. Maybe host video drivers aren't good after the update?

williamsdyyz wrote:I don't see anything obviously wrong in the VB log.

We could take a look at them.

Start the VM from full power off, not save-state. Run until you see the problem happen, then shut down the VM from within the VM OS if possible. If not possible, close the Virtualbox window for the VM with the Power Off option set.

Please right-click the VM in the main Virtualbox window's VM list, choose Show Log. Save the far left tab's log, zip the log file, and post the zip file, using the forum's Upload Attachment tab.
scottgus1
Site Moderator
 
Posts: 13016
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Linux

Re: VMSVGA + 3d Acceleration = White icons, white desktop, blocky text?

Postby GrahamV » 4. Aug 2021, 21:02

I've also had this problem and it appears to be an issue with a specific driver update (Mesa VDPAU Video Acceleration Driver 21.0.3-0ubuntu0.2-20.04.1) in Linux Mint Cinnamon.

There is also a discussion on the Linux Mint Forum about it: Linux Mint Forum

I have a machine running LM20 Cinnamon which is fine, but running in a VM on Windows has this issue.
GrahamV
 
Posts: 5
Joined: 16. Nov 2018, 02:34

Re: VMSVGA + 3d Acceleration = White icons, white desktop, blocky text?

Postby Sumarious » 5. Aug 2021, 00:26

Just had this exact issue when running updates on mint.

Before you login, change your session to software rendering.

Once you're logged in, attach the guest utils cd, and run the installer to reinstall them.

For some reason on this latest kernel update, the guest utils don't get applied to the latest kernel..

sudo /sbin/rcvboxadd quicksetup all

Reboot, and you should be golden.
Sumarious
 
Posts: 1
Joined: 5. Aug 2021, 00:23

Re: VMSVGA + 3d Acceleration = White icons, white desktop, blocky text?

Postby williamsdyyz » 5. Aug 2021, 13:45

Thanks for your help. The log is attached.

The login screen renders just fine. Things only go wrong once it gets to the desktop.
Attachments
Linux Mint 20 Dev-2021-08-05-07-43-09.zip
(38.07 KiB) Not downloaded yet
williamsdyyz
 
Posts: 8
Joined: 27. Nov 2019, 16:16

Re: VMSVGA + 3d Acceleration = White icons, white desktop, blocky text?

Postby williamsdyyz » 5. Aug 2021, 14:02

Sumarious wrote:Just had this exact issue when running updates on mint.

Before you login, change your session to software rendering.

Once you're logged in, attach the guest utils cd, and run the installer to reinstall them.

For some reason on this latest kernel update, the guest utils don't get applied to the latest kernel..

sudo /sbin/rcvboxadd quicksetup all

Reboot, and you should be golden.


Gave this a shot, but it didn't help unfortunately
williamsdyyz
 
Posts: 8
Joined: 27. Nov 2019, 16:16

Re: VMSVGA + 3d Acceleration = White icons, white desktop, blocky text?

Postby williamsdyyz » 5. Aug 2021, 14:10

GrahamV wrote:I've also had this problem and it appears to be an issue with a specific driver update (Mesa VDPAU Video Acceleration Driver 21.0.3-0ubuntu0.2-20.04.1) in Linux Mint Cinnamon.

There is also a discussion on the Linux Mint Forum about it: Linux Mint Forum

I have a machine running LM20 Cinnamon which is fine, but running in a VM on Windows has this issue.



Thanks for linking to the Mint forum. It does look like that driver update is the problem
williamsdyyz
 
Posts: 8
Joined: 27. Nov 2019, 16:16

Re: VMSVGA + 3d Acceleration = White icons, white desktop, blocky text?

Postby klaus » 31. Aug 2021, 20:15

The latest test builds contain a workaround for this issue. The bug is actually in the Mesa 21 code which came to your Mint install with an update. It appears to use a texture format (probably in the compositing window manager) which Mesa doesn't know how to translate, making it pick an "unknown" value. Appears that the corresponding changes were not tested to work with VMSVGA/3D at VGPU9 feature level (which VirtualBox currently offers).
klaus
Oracle Corporation
 
Posts: 832
Joined: 10. May 2007, 14:57


Return to Linux Guests

Who is online

Users browsing this forum: No registered users and 9 guests

cron