HOW-TO enable GNOME-shell 3D desktop effects in Fedora 16

HOW-TO enable GNOME-shell 3D desktop effects in Fedora 16

Postby Technologov » 9. Nov 2011, 12:01

F16 is now out !

But it has one nasty bug -- SELinux. It results in GNOME always running in fall-back mode, even with 3D acceleration enabled and GA installed.

You need to disable SELinux. Either via "/etc/selinux/config" permanently, or for single boot via:
Code: Select all   Expand viewCollapse view
# setenforce 0


then restart GNOME3:
Code: Select all   Expand viewCollapse view
gnome-shell –replace &


And Voilla ! It works !

Host: Windows 7 x64, NVIDIA GeForce GTX 560 + VBox 4.1.6.
Guest: Fedora 16 x64 + GA 4.1.6.

Related article(s):
https://aspratyush.wordpress.com/tag/fe ... irtualbox/

How-to install GA on Fedora 15/16:
http://www.sysprobs.com/install-fedora- ... -fedora-15

-Technologov
Technologov
Volunteer
 
Posts: 3316
Joined: 10. May 2007, 16:59
Location: Israel

Re: HOW-TO enable GNOME-shell 3D desktop effects in Fedora 1

Postby Malechai » 24. Nov 2011, 15:54

i'm not sure if my problem is related to this or not? I can't seem to install the guest additions in F16 at all. When attempting to launch the installer, the terminal window flashes open and then closes - nothing happens.

Any thoughts?

/edit .. i've installed all the prereq packages as per the FAQ guide on this board here for Fedora:
viewtopic.php?f=29&t=15679
Malechai
 
Posts: 3
Joined: 14. Sep 2011, 15:53
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu, Fedora, Windows

Re: HOW-TO enable GNOME-shell 3D desktop effects in Fedora 1

Postby Perryg » 24. Nov 2011, 16:14

You can open a terminal and install the guest additions as SU manually.
Install instructions are located in chapter 4.2 Installing and Maintaining Guest Additions in your VirtualBox users manual.
Perryg
Site Moderator
 
Posts: 34373
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: HOW-TO enable GNOME-shell 3D desktop effects in Fedora 1

Postby Malechai » 24. Nov 2011, 17:07

interesting enough the issue was the fact that I had the CDROM on the SATA controller. I added an IDE controller, put the CDROM on that and now the additions are installing just fine.
Malechai
 
Posts: 3
Joined: 14. Sep 2011, 15:53
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu, Fedora, Windows

Re: HOW-TO enable GNOME-shell 3D desktop effects in Fedora 1

Postby Dragonfire00 » 30. Nov 2011, 04:15

Technologov wrote:F16 is now out !

But it has one nasty bug -- SELinux. It results in GNOME always running in fall-back mode, even with 3D acceleration enabled and GA installed.

You need to disable SELinux. Either via "/etc/selinux/config" permanently


Registered to say thanks and it worked for me. Had to manually install the guest additions, used this:

http://www.sysprobs.com/install-fedora- ... -fedora-15
Dragonfire00
 
Posts: 1
Joined: 30. Nov 2011, 04:11
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Fedora/Mint/CentOS/Arch

Re: HOW-TO enable GNOME-shell 3D desktop effects in Fedora 1

Postby mcasperson » 30. Dec 2011, 04:20

You can see a screencast stepping you through the process of enabling the gnome-shell under VirtualBox here.
mcasperson
 
Posts: 5
Joined: 29. Dec 2011, 00:17
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Fedora

Re: HOW-TO enable GNOME-shell 3D desktop effects in Fedora 1

Postby raffamaiden » 17. Feb 2012, 15:46

gnome-shell –replace &


It tells me that -replace is not a valid option
raffamaiden
 
Posts: 1
Joined: 17. Feb 2012, 15:46

Re: HOW-TO enable GNOME-shell 3D desktop effects in Fedora 1

Postby Twisted Lucidity » 18. Feb 2012, 14:11

Once you have used "setenforce 0" as root (i.e. su)
You then need to restart gnome-shell as the user. There is a minor typo in the OP and the command should be:
Code: Select all   Expand viewCollapse view
gnome-shell --replace &
Note the double hyphens.

Remember that on GNU/Linux you can always get documentation on any command from right in the terminal with "man". So to find out how to use "gnome-shell" one would use this command
Code: Select all   Expand viewCollapse view
man gnome-shell
Then page up/down and "q" to exit. You can use "man man" to find out more about "man" too.

This worked perfectly for me, now I can try out Gnome-shell a bit more before I decide if I want to upgrade to that, Unity or something else.
A new account for an old user.
Twisted Lucidity
 
Posts: 168
Joined: 18. Feb 2012, 12:42
Location: Here
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Various GNU/Linux

Re: HOW-TO enable GNOME-shell 3D desktop effects in Fedora 1

Postby pau » 23. Sep 2012, 09:09

Hi all.
I installed Fedora 16, VBox guest additions (4.1.18) and everything was just fine.
I decided to enable Gnome shell:
Code: Select all   Expand viewCollapse view
[user@fedora ~]$ su -
Password:
[root@fedora ~]# restorecon -R -v /opt
...
[root@fedora ~]# gnome-shell --replace &

After reboot I see Gnome shell and try to login as a user:
Oh no! Something has gone wrong. A problem has occured and the system can't recover. Please log out and try again. Log out.

But when I am doing so (logout) the system hangs - I see background picture, wait cursor and nothing is happening.
I can not login as a root user via Gnome - authentication failure. But when I use runlevel 3 and the same password for root it works - I can login as a root in console mode. What should I do?
Thank you very much in advance.
pau
 
Posts: 12
Joined: 16. Aug 2012, 08:07


Return to Linux Guests

Who is online

Users browsing this forum: No registered users and 2 guests