Page 1 of 1


Posted: 25. Mar 2020, 14:34
by scottgus1
This error happens because a Windows service that uses Microsoft Hyper-V is enabled. Hyper-V is blocking Virtualbox on your host. (Some Windows hosts seem to allow Hyper-V and Virtualbox to coexist for some small range of VM types, but yours appears to not be one of the blessed.)

But I turned off all the Hyper-V features in Windows Features!
Many of Microsoft's security features use Hyper-V, not only the "Hyper-V" feature. Microsoft also changes the names of things in their "Windows Features" box at times. You may not specifically see a "Hyper-V" checkbox, or may have unchecked the "Hyper-V" checkbox, but anything based on the underlying Hyper-V hypervisor will turn on Hyper-V and cause trouble. Generally, trying to disable Hyper-V by unchecking boxes in "Windows Features" often does not disable Hyper-V.

But I'm running Windows Home and don't have Hyper-V!
Yes, you do. Windows Home can't run Hyper-V virtual machines, but it has most of the other Windows services that can enable Hyper-V and block Virtualbox.

To turn Hyper-V off completely, do this:

1. Shut down all programs. You will have to shut down, unplug, and restart your host.

2. Look into I have a 64bit host, but can't install 64bit guests, 2nd post, points 2 & 3 and ensure that none of these things are running:
Windows Defender's Core Isolation

3. Find the Command Prompt icon, right click it and choose Run As Administrator.

4. Enter this command:

bcdedit /set hypervisorlaunchtype off

Some report this command was needed also:

DISM /Online /Disable-Feature:Microsoft-Hyper-V

5. Enter this command:

shutdown -s -t 2

6. When the computer turns off, unplug it for 20 seconds. Then plug it in again and boot up again. (Some laptops have built-in unremovable batteries. These devices may have a BIOS switch that can "deactivate" the battery, which could cause the unplug needed for this step.

Your Virtualbox should be running now. If you still get the error, post back exactly what you did and we'll try to help some more.

If your computer is running in a corporate environment with IT overlords, they may have forced Hyper-V, and none of the above will help. You will have to get IT to turn off Hyper-V so that you can run Virtualbox.

For further info, and a method to switch Hyper-V on or off at boot so you can run Hyper-V or Virtualbox (not both at the same time), see ... puter.html. Also see ... windows-10, found by user "B1tm4p75".


Posted: 14. Jun 2022, 17:20
by scottgus1
User "InfoSecDr" reports that further disabling of one of Windows' "DeviceGuard" settings in the registry might be necessary to get Hyper-V to disable:

Disabling DeviceGuard is one of the things called for to disable Hyper-V.