HMR3Init: Attempting fall back to NEM (Hyper-V is active)

HMR3Init: Attempting fall back to NEM (Hyper-V is active)

Postby scottgus1 » 11. Aug 2020, 15:24

If your log contains these lines:

{timestamp} HM: HMR3Init: Attempting fall back to NEM: VT-x is not available
{timestamp} NEM: WHvCapabilityCodeHypervisorPresent is TRUE, so this might work...

or

{timestamp} HM: HMR3Init: Attempting fall back to NEM: AMD-V is not available
{timestamp} NEM: WHvCapabilityCodeHypervisorPresent is TRUE, so this might work...


This is because a service that uses Microsoft Hyper-V is running on your host PC.

Windows Home users:
Hyper-V exists on Home too, and several services can be made to use it. Only the ability to run Hyper-V virtual machines is not available in Home.

About the "Windows Features" box:
Microsoft changes the names of things in their "Windows Features" box at times. You may not specifically see a "Hyper-V" checkbox, but anything based on the underlying Hyper-V hypervisor will turn on Hyper-V and cause trouble. Generally, trying to disable Hyper-V by unchecking boxes in "Windows Features" often does not disable Hyper-V.

You might notice in the guest window's Status Bar the green turtle: Image The choice of animal is appropriate: Your guest is running, just really slow. Or it might guru-meditate or crash. Or guest OS's won't properly hash their update files or ISOs.

Normally Hyper-V blocks Virtualbox. Hyper-V is a type-1 hypervisor, which accesses the hardware first before any OS runs, and therefore interferes with other programs that need "virtualization technology", like Virtualbox, which is a type-2 Hypervisor.

Your PC is of the type and OS where Virtualbox can attempt to run the guest using the Hyper-V engine. This arrangement is still being developed and isn't 100% yet.

If VirtualBox is running without Hyper-V enabled, and nothing else is interfering with hardware virtualization (VT-x / AMD-V), then the usual virtualization icon (Image) will be seen in the Status Bar.

To turn Hyper-V off completely, do this:

1. Shut down all programs. You will have to shut down, unplug, and restart your host.

2. Look into I have a 64bit host, but can't install 64bit guests, 2nd post, points 2 & 3 and ensure that none of these things are running:
DeviceGuard
CredentialGuard
Windows Defender's Core Isolation


3. Find the Command Prompt icon, right click it and choose Run As Administrator.

4. Enter this command:

bcdedit /set hypervisorlaunchtype off

Some report this command was needed also:

DISM /Online /Disable-Feature:Microsoft-Hyper-V

5. Enter this command:

shutdown -s -t 2

6. When the computer turns off, unplug it for 20 seconds. Then plug it in again and boot up Windows 10.

Your Virtualbox should be running now. If the green turtle still appears and the tell-tale lines are in the log, try all the steps again. If you don't get the standard virtualization icon, post back exactly what you did and we'll try to help some more.

If your computer is running in a corporate environment with IT overlords, they may have forced Hyper-V, and none of the above will help. You will have to get IT to turn off Hyper-V so that you can run Virtualbox.

For further info, and a method to switch Hyper-V on or off at boot so you can run Hyper-V or Virtualbox (not both at the same time), see https://www.tenforums.com/tutorials/139 ... puter.html. Also see https://petri.com/how-to-disable-hyper- ... windows-10, found by user "B1tm4p75".
scottgus1
Site Moderator
 
Posts: 13235
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Linux

Return to Windows Hosts

Who is online

Users browsing this forum: No registered users and 2 guests