Catalina 10.15.2 does not start

Discussions about using Mac OS X guests (on Apple hardware) in VirtualBox.

Catalina 10.15.2 does not start

Postby Vietwoojagig3 » 19. Dec 2019, 13:23

I have a MacBook Air with MacOS Mojave 10.14.6.
I use VirtualBox 6.1, but had the same problems with 6.0.14.
I'm running a virtual machine with MacOS 10.15.1 without any problems.

For me it is not possible to update the virtual machine to 10.15.2.

I tried these things:
  • Chose the update in System Preferences / Software Update
  • Download the 10.15.2 combo update and install that
  • Create an ISO from the 10.15.2 Installer Application and boot from DVD/ISO Image
For the updates, after reboot and for the boot from ISO-disk, all activities on hard drive or DVD stop at the Apple Logo a second after boot.

Going to EFI and searching for the boot.efi in the macos_updates folder does not help. After failing, it is still possible to boot into the 10.15.1 version by manually selecting the correct entry in the Boot selection of EFI. Log files don't show anything.

Was anyone able to update to 10.15.2 or install a clean 10.15.2? Can someone confirm the problem?
Vietwoojagig3
 
Posts: 5
Joined: 19. Dec 2019, 13:08

Re: Catalina 10.15.2 does not start

Postby socratis » 19. Dec 2019, 13:39

Vietwoojagig3 wrote:For me it is not possible to update the virtual machine to 10.15.2.
Not only for you, for everyone that's tried it. It's just that you're the first one that reported it... ;)

Vietwoojagig3 wrote:all activities on hard drive or DVD stop at the Apple Logo a second after boot
From the developers I talked to, there seems to be an "internal crash" on 10.15.2, something that shows up as a stuck VM.

Vietwoojagig3 wrote:I use VirtualBox 6.1, but had the same problems with 6.0.14.
You couldn't be having the same problem in 6.0.14, unless you were doing some sort of hacking. The VirtualBox 6.0.14 EFI did not even support APFS...
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Catalina 10.15.2 does not start

Postby Vietwoojagig3 » 19. Dec 2019, 14:13

socratis wrote:Not only for you, for everyone that's tried it.

Thanks for that info.

socratis wrote:
Vietwoojagig3 wrote:I use VirtualBox 6.1, but had the same problems with 6.0.14.
You couldn't be having the same problem in 6.0.14, unless you were doing some sort of hacking. The VirtualBox 6.0.14 EFI did not even support APFS...

I would call it, loading the APFS support in startup.nsh, which I'm happy to not need anymore.

I mentioned that aspect only to figure out that the problem likely was not introduced by 6.1. Sometimes thinks get broken with a new version, e.g. the APFS support could have a bug. But it seems from the fact that it works for 6.0.14/10.15.1 and also not for 6.0.14/10.15.2, that the problem was not introduced by 6.1.
Vietwoojagig3
 
Posts: 5
Joined: 19. Dec 2019, 13:08

Re: Catalina 10.15.2 does not start

Postby socratis » 20. Dec 2019, 12:05

Vietwoojagig3 wrote:I would call it, loading the APFS support in startup.nsh, which I'm happy to not need anymore.
6.1.0 is the first release that can boot 10.14/15 with no hacks. It's also the first release that supports fully up-to-date 10.12/13/14/15 Guests. The only thing that fails (so far) is the 10.15.2 update. :(

Vietwoojagig3 wrote:the problem was not introduced by 6.1.
Au contraire! :)
VirtualBox 6.1.0 Changelog wrote:
  • EFI: Switch to newer firmware code base and add NVRAM support, should improve compatibility with OSes significantly
  • EFI: Added support for booting from APFS
  • EFI: Added support for non-standard SATA and NVMe boot device paths created by OS X
  • EFI: Modified updated EFI code base to support older OS X guests again
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Error on Installing macOS Catalina on a Mac Host

Postby JM127 » 20. Dec 2019, 17:55

I've been working on trying to create a MacOS Virtual Box VM for the past few days. I've downloaded ISO files, created my own from the Install macOS Catalina.app.

Each time I get to the point of starting the VM, I setup everything according to what I've found online and I either have had it go to a UEFI Interactive Shell, and even when I add the AFPS Boot Image to the VM I'm still not able to enter the commands to move past that screen. (That was with the downloaded iso file).

The other result, with the iso file I created from the Install macOS Catalina.app is just a straight black screen with no options for any commands in the VM Window.

I'm somewhat tech savvy, but these are some of my first ventures into terminal commands and this side of the computer. So part of what I need help with is even just diagnosing what is going wrong so I can know what question to ask to find out what needs fixing.

Let me know if you need any log files or screen shots in order to have a better picture of what's happening.

Thanks for any help!
JM127
 
Posts: 2
Joined: 20. Dec 2019, 17:48

Re: Error on Installing macOS Catalina on a Mac Host

Postby socratis » 20. Dec 2019, 23:44

First of all, this post belongs to the "OSX Guests" area, not the "OSX Hosts". You're having a Guest problem...

JM127 wrote:even when I add the AFPS Boot Image to the VM
What "AFPS Boot Image"?

JM127 wrote:That was with the downloaded iso file
What "downloaded iso file"?

JM127 wrote:The other result, with the iso file I created from the Install macOS Catalina.app is just a straight black screen
Are you sure that there's a black screen only? I want to see the recipe of the VM, the ".vbox" file. Right-click on the VM in the VirtualBox Manager, select "Show in Finder". ZIP the selected ".vbox" file and attach it to your response.

JM127 wrote:these are some of my first ventures into terminal commands
What "terminal commands"?

JM127 wrote:with the iso file I created from the Install macOS Catalina.app
1) How? 2) Which version? 10.15.2?

I have a feeling that you're following a Hackintosh guide...
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Error on Installing macOS Catalina on a Mac Host

Postby JM127 » 21. Dec 2019, 03:07

I'm sorry for the lack of clarity in the initial questions. I'm new to VM's and am working on learning. I still am not completely sure how to describe the issue via text, so I took videos of the process I went to to get where I am. Hopefully will provide some clarity on the issues I'm having or what I'm missing in the VM Creation Process.

The first video addresses how I made the Catalina.iso file from Install macOS Catalina.app file that contains MacOS version 15.2.02. https://www.youtube.com/watch?v=y-6DCznhR6w

The second video shows what I did to create the VM itself in VirtualBox, using the .iso file that was created in the first video. Without the .iso file installed it opened to a UEFI Shell screen, after closing the VM and adding the .iso file in the Settings>Storage and restarting the VM it opened to a black screen. https://www.youtube.com/watch?v=sUZ0h135ox4

I then closed the VM, opened the VM location in finder and have uploaded the "MacOS Video Example.vbox.zip" file as requested.

Thank you for your help on this.
Attachments
MacOS Video Example.vbox.zip
(1.52 KiB) Downloaded 296 times
Last edited by socratis on 21. Dec 2019, 09:22, edited 1 time in total.
Reason: Added missing URL.
JM127
 
Posts: 2
Joined: 20. Dec 2019, 17:48

Re: Error on Installing macOS Catalina on a Mac Host

Postby socratis » 21. Dec 2019, 09:29

  1. You might find it easier to create the ISO using InstallerApp2ISO.
  2. You shouldn't be selecting the generic "Mac OS X (64-bit)", but the latest one "macOS 10.13 High Sierra", until 10.14/15 becomes an option.
  3. It seems that you downloaded 10.15.2. This version does not work at the moment. Either find a 10.15/10.15.1 installer, or wait for a fix (hopefully).
Based on the last part, I'm going to merge your post with a similar thread in the "OSX Guests" area.

Personally, I wouldn't have a problem giving you a 10.15.iso, just because Apple screwed up (once again). You wouldn't be able to use it unless you're an actual OSX user, and I definitely don't see it as immoral, illegal or unethical. Just don't try to upgrade it to 10.15.2, you'll be in the same position...
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Catalina 10.15.2 does not start

Postby Todd Almighty » 23. Dec 2019, 20:46

I can confirm I've hit this as well, and wasted a lot of time.

I don't think it's APFS-related, though that's what I thought initially. I created a HFS+ boot USB stick with the BaseInstall.dmg from this update, and it fails in exactly the same way as the volume created by the update itself automatically from my working 10.15.1 install - you're taken immediately to a black screen.

So, is this a VirtualBox bug or an Apple software bug? Obviously, getting Apple to fix it even if it's slopping coding may be difficult so it will probably end up being required that VB make a fix.
Todd Almighty
 
Posts: 37
Joined: 13. Nov 2013, 13:44

Re: Catalina 10.15.2 does not start

Postby danrb » 28. Dec 2019, 02:32

Has anyone made any progress on getting a 10.15.2 guest to work?
Does anyone know if a 10.15.2 guest on VMware fusion works (sorry I know this is a Virtualbox forum but just wondering)?
danrb
 
Posts: 2
Joined: 28. Dec 2019, 02:12
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Mac OSX 10.15.1, Windows 10x64, Ubuntu Bionic

Re: Catalina 10.15.2 does not start

Postby Todd Almighty » 28. Dec 2019, 06:36

Has someone filed a ticket for this? I don't see an exact match for this. Just something about a "kernel panic" - but I'm not getting a kernel panic here that I can see, but a freeze with a black screen immediately upon boot.
Todd Almighty
 
Posts: 37
Joined: 13. Nov 2013, 13:44

Re: Catalina 10.15.2 does not start

Postby danrb » 28. Dec 2019, 06:59

I just filed a ticket. Ticket number 19188.
danrb
 
Posts: 2
Joined: 28. Dec 2019, 02:12
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Mac OSX 10.15.1, Windows 10x64, Ubuntu Bionic

Re: Catalina 10.15.2 does not start

Postby lanN87 » 4. Jan 2020, 04:00

I have exactly same issue, command <UUID>\com.apple.installer\boot.efi doesn't output anything and just hanging there.
lanN87
 
Posts: 1
Joined: 4. Jan 2020, 03:58

Re: Catalina 10.15.2 does not start

Postby prenez » 4. Jan 2020, 21:52

@iann87 my issue also. This is where it hangs after an attempted software update to 15.2

https://www.dropbox.com/s/5kffj77cccw36 ... M.jpg?dl=0

and note 15.3 is riiiight around the corner...
prenez
 
Posts: 8
Joined: 8. Oct 2019, 20:15

Re: Catalina 10.15.2 does not start

Postby tcosmos » 14. Jan 2020, 06:45

Bumping, was digging into this all day, glad it isn't just me. Any boot media created from 10.15.2 isn't starting.
tcosmos
 
Posts: 1
Joined: 14. Jan 2020, 06:44

Next

Return to Mac OS X Guests

Who is online

Users browsing this forum: Google [Bot] and 2 guests