Page 2 of 2

Re: Mouse dragging fails with 10.15 guest

PostPosted: 21. Aug 2019, 21:55
by Poulpix
Short update: I found a workaround by connecting to the VM using the built-in Screen Sharing macOS app from the host. It doesn't solve the problem but at least when drag-and-dropping is mandatory to achieve something, it works.

Re: Mouse dragging fails with 10.15 guest

PostPosted: 21. Aug 2019, 21:58
by socratis
Poulpix,
As you might have noticed, I merged your posts with the prominent thread on the subject. Speaking of "subject", I changed the thread's subject from "USB trackpad problems with macOS guest." to something more appropriate.

Re: Mouse dragging fails with 10.15 guest

PostPosted: 21. Aug 2019, 22:02
by Poulpix
Yes, no problem. It was my first post here although I've been using VirtualBox for several years. And I wasn't really aware of the "only speak of 10.15 Beta" stuff, but I'll be more cautious next time.
Glad to see that this problem is seen by other VBox users anyway.
Thanks socratis

Re: Mouse dragging fails with 10.15 guest

PostPosted: 21. Aug 2019, 22:06
by socratis
Poulpix wrote:And I wasn't really aware of the "only speak of 10.15 Beta" stuff, but I'll be more cautious next time.

Now that 10.15 is in public beta, we can definitely talk about it. The "caution" was when the first testers had signed an NDA to not discuss it in public, no harm here, only from Apple. ;)

Re: Mouse dragging fails with 10.15 guest

PostPosted: 6. Oct 2019, 21:24
by culler
I have just installed the Catalina "Gold master" beta on a VirtualBox 6.0.12 VM and can happily report that it is now possible to drag windows and use scrollbars using the usual USB Tablet input device.

Re: Mouse dragging fails with 10.15 guest

PostPosted: 7. Oct 2019, 06:36
by socratis
So I take it that this means it was an OSX 10.15 issue then. I guess Parallels can remove that Knowledge Base of theirs as well... ;)

Re: Mouse dragging fails with 10.15 guest

PostPosted: 10. Jan 2020, 21:40
by mp101
Is there any solution for this?

Just installed 10.15 guest and no mouse dragging.

Re: Mouse dragging fails with 10.15 guest

PostPosted: 6. May 2020, 10:56
by BenZr
mp101 wrote:Is there any solution for this?

Just installed 10.15 guest and no mouse dragging.


I got the same problem moving from 10.13 to 10.15
The USB on the VM should be set to USB 3.0 xHCI
I found a workaround but not a solution. If you connect a second mouse, it will be directly handled as an USB device by the VM.
If you click the "Devices" menu on top of the VM display, then click "USB" , the second mouse should appear, just select it.
The second mouse will only work inside the VM window. I agree it is not a long term solution ...