Keyboard and mouse don't work after creating snapshot (#18440)

Discussions about using Mac OS X guests (on Apple hardware) in VirtualBox.

Keyboard and mouse don't work after creating snapshot (#18440)

Postby Ee » 18. Apr 2019, 19:01


ModEdit; related ticket: #18440: Keyboard and mouse don't work after creating snapshot

Host: 10.12.6 Sierra
Guests: 10.11 El Capitan, 10.13 High Sierra

Bug description:
Mouse and keyboard are not captured
  • Immediately after taking a snapshot
  • Restoring from a snapshot
  • Restoring a saved state
Rebooting enables mouse and keyboard.

I've had this problem in VirtualBox versions after 6.0.0. (6.0.0 does NOT have this problem.)

I've attached mac.vbox and VBox.log. They pertain to 10.11 El Capitan, given that it's much easier to install than High Sierra, but the same problem exists for High Sierra.

Setting higher RAM, video memory, number of processors, and USB version do not fix anything. Neither does installing Guest Additions. The only thing that works is downgrading to v6.0.0.

I can manually attach external USB mice and keyboards. However, this is not an acceptable workaround. The system trackpad and keyboard remain unattachable.
Attachments
Mac.vbox.gz
(1.77 KiB) Downloaded 36 times
VBox.log.gz
(29.54 KiB) Downloaded 32 times
Last edited by socratis on 18. Apr 2019, 19:12, edited 1 time in total.
Reason: Added ticket related information.
Ee
 
Posts: 6
Joined: 18. Apr 2019, 18:20

Re: Keyboard and mouse don't work after creating snapshot (#18440)

Postby socratis » 19. Apr 2019, 04:20

I tried it with two hosts, 10.11.6 and 10.13.6, with a 10.11.6 guest. Couldn't reproduce it under normal operations. And I don't know what might be causing this, both your VBOX and your VBox.log look fine.

I'd like to understand a bit better the conditions that you lose the mouse as far as the snapshots go...
Ee wrote:Immediately after taking a snapshot
Do you mean a "live" snapshot?

Ee wrote:Restoring from a snapshot
Again a live one? Because right after this you say:
Ee wrote:Restoring a saved state
which does sound like the previous one.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 26728
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Keyboard and mouse don't work after creating snapshot (#18440)

Postby Ee » 19. Apr 2019, 17:08

Do you mean a "live" snapshot?

I'm assuming "live" means a snapshot of the guest while it is powered on. Yes, this pertains to live snapshots. After taking a snapshot of a powered on guest, the guest becomes unresponsive because it doesn't capture the mouse and keyboard.

Regarding the two restoration scenarios, the same unresponsiveness occurs in these distinct cases, both involving states where the guest is powered on:
    1. If I try restoring from the live snapshot described earlier.
    2. If I save a state while closing the guest window (not taking a snapshot) and then try restoring that saved state.
Last edited by Ee on 19. Apr 2019, 17:13, edited 1 time in total.
Ee
 
Posts: 6
Joined: 18. Apr 2019, 18:20

Re: Keyboard and mouse don't work after creating snapshot (#18440)

Postby Ee » 19. Apr 2019, 17:12

Some more info on my host:

MacBook Pro (Retina, 15-inch, Mid 2015)
Intel Core i7-4980HQ @ 2.80GHz
16 GB 1600 MHz DDR3
macOS Sierra 10.12.6

I'm not sure if this matters, but I see you didn't test on a Sierra host. My troubleshooting routine will have me try a different Mac, and then later macOS versions. I'll let you know how it goes.
Ee
 
Posts: 6
Joined: 18. Apr 2019, 18:20

Saving my running mac OS El Capitan v10.11.6 guest's snapshot freezes its inputs.

Postby ant » 25. Apr 2019, 02:42

This is a weird one ever since I upgraded VirtualBox v6.0.4 to v6.0.6 (including guest additions) in a 13.3" MacBook Pro (mac OS Sierra v10.12.6). Every time I do a snapshot of mac OS El Capitan v10.11.6 guest session, its cursor and key input freezes. I noticed its clock still ticks in the background to see if it was totally locked or not. It's only my inputs are not responding. I tried resetting and same problem at its login screen. I am forced to revert back to an older snapshot. I can reproduce this issue if I snapshot again even at mac OS' login screen. I can't reproduce it if I save a snapshot before booting up and after shutting down (basically not in mac OS). It only reproducable when mac OS guest is running. I attached a zipped log file up to ending the session.

I tried again with a 64-bit W7 HPE SP1 guest VM. No problems. It's only happening with my mac OS VM. :( I have all updates in both guest and host machines. I even rebooted the host too.

What's up? Is anyone else having this problem too or just me? :(
Attachments
Mac OS X v10.11.6 El Capitan-2019-04-24-17-34-00.log.zip
(30.72 KiB) Downloaded 16 times
ant
 
Posts: 226
Joined: 9. Jul 2007, 20:02
Location: An Ant Farm
Primary OS: Debian other
VBox Version: OSE Debian
Guest OSses: Updated Windows (XP Pro. SP3 & 64-bit W7 HPE SP1) & Mac OS X v10.11.x El Capitan

Re: Keyboard and mouse don't work after creating snapshot (#18440)

Postby Ee » 25. Apr 2019, 23:14

I tried on an iMac with a 10.12.6 Sierra host os. This was to see if the built-in keyboard and trackpad was the problem, given that the iMac does not have them built-in. I still got this bug.

I tried on another MacBook Pro, this time with a freshly installed macOS 10.14.4 Mojave host os. This had no additional software that could interfere with VirtualBox 6.0.6. I still got this bug.
Ee
 
Posts: 6
Joined: 18. Apr 2019, 18:20

Re: Keyboard and mouse don't work after creating snapshot (#18440)

Postby Ee » 20. May 2019, 14:52

This is still a bug in VirtualBox 6.0.8.
Ee
 
Posts: 6
Joined: 18. Apr 2019, 18:20

Re: Keyboard and mouse don't work after creating snapshot (#18440)

Postby socratis » 20. May 2019, 18:45

@ant
I merged your thread with this one and deleted the superfluous messages to keep it clean.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 26728
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Keyboard and mouse don't work after creating snapshot (#18440)

Postby ant » 20. May 2019, 18:55

socratis wrote:@ant
I merged your thread with this one and deleted the superfluous messages to keep it clean.
OK and thanks. :)
ant
 
Posts: 226
Joined: 9. Jul 2007, 20:02
Location: An Ant Farm
Primary OS: Debian other
VBox Version: OSE Debian
Guest OSses: Updated Windows (XP Pro. SP3 & 64-bit W7 HPE SP1) & Mac OS X v10.11.x El Capitan

Re: Keyboard and mouse don't work after creating snapshot (#18440)

Postby ant » 20. May 2019, 18:56

Ee wrote:This is still a bug in VirtualBox 6.0.8.
I didn't see it fixed so I assume v6.0.8 hasn't fixed it. I hope they fix it really soon since it's annoying. :(
ant
 
Posts: 226
Joined: 9. Jul 2007, 20:02
Location: An Ant Farm
Primary OS: Debian other
VBox Version: OSE Debian
Guest OSses: Updated Windows (XP Pro. SP3 & 64-bit W7 HPE SP1) & Mac OS X v10.11.x El Capitan

Re: Keyboard and mouse don't work after creating snapshot (#18440)

Postby krishen » 9. Oct 2019, 17:57

Still an issue with VirtualBox 6.0.12 r133076 (Qt5.6.3). This is with a Mac host (MacBook Pro Retina 13" Early 2015) running macOS Catalina (10.15.0 [19A583]), attempting to run a macOS High Sierra (10.13.5) guest. Indeed rebooting works around the issue. I did notice that choosing VirtualBox VM -> Devices > USB > selecting my mouse (in my case, 'Logitech USB Optical Mouse [6300]'), immediately after restoring a snapshot allowed me to gain access to the mouse (might be a clue into how to fix the issue), but the keyboard remained uncaptured by the guest. So rebooting immediately after restoring the snapshot is probably still the best workaround procedure, as it gives access to the keyboard. My guess at what is happening here is the list of USB devices changes between the time the snapshot was taken and when the snapshot is restored, and there's no longer a connection... and rebooting the VM reestablishes that mapping.
krishen
 
Posts: 1
Joined: 9. Oct 2019, 17:53

Re: Keyboard and mouse don't work after creating snapshot (#18440)

Postby ant » 10. Oct 2019, 00:07

Interesting. I really wished our issue would get fixed since it had been six months according to https://www.virtualbox.org/ticket/18440 bug report and last modified five months ago. I use snapshots during running sessions a lot. :(
Last edited by socratis on 10. Oct 2019, 00:34, edited 1 time in total.
Reason: Removed unnecessary verbatim quote of the whole previous message.
ant
 
Posts: 226
Joined: 9. Jul 2007, 20:02
Location: An Ant Farm
Primary OS: Debian other
VBox Version: OSE Debian
Guest OSses: Updated Windows (XP Pro. SP3 & 64-bit W7 HPE SP1) & Mac OS X v10.11.x El Capitan

Re: Keyboard and mouse don't work after creating snapshot (#18440)

Postby Ee » 11. Oct 2019, 12:26

I've been testing each release for this bug as well, and have been forced to remain on version 6.0.0, since December of last year!

My particular use-case for Mac guest on Mac host is to test fresh installations of my job's applications in a Mac environment. I can imagine there are many more affected by this than just the 4 of us who've chimed in on this forum. Hopefully this gets resolved soon so I can take advantage of the improvements made in the versions since 6.0.0.
Ee
 
Posts: 6
Joined: 18. Apr 2019, 18:20

Re: Keyboard and mouse don't work after creating snapshot (#18440)

Postby vGX9Ne36 » 1. Nov 2019, 02:23

Just to add another datapoint.
Same thing (keyboard/mouse input not being recognized anymore in guest after taking a "live" snapshot happens for me as well.
Virtualbox version: 6.0.14 on host (extension pack 6.0.14r33895), guest extensions in client (also 6.0.14) installed.

Downgrading to 6.0.0 solved the problem same as for OP.

Scenario details:
Host: macOS 10.13.x highsierra, macOS 10.14.6 mojave
Guest: macOS 10.13.x highsierra, macOS 10.14.6 mojave

meaning I tried all 4 combinations of host/guest highsierra&mojave
This is original apple hw, not a hackintosh.
vGX9Ne36
 
Posts: 1
Joined: 1. Nov 2019, 02:18


Return to Mac OS X Guests

Who is online

Users browsing this forum: No registered users and 5 guests