[HowTo] Install OSX 10.13 in a VM

Discussions about using Mac OS X guests (on Apple hardware) in VirtualBox.

Re: [HowTo] Install OSX 10.13 in a VM

Postby ZachyDaddy » 23. May 2019, 17:14

I went through all of the steps successfully, after second setup and installation (through the boot maintenance manager I go through the menu to select "boot.efi" I get through all the steps loading in terminal.) The apple logo and progress bar load. The "Install macOS" screen pops up, then it goes away and I get a round picture of "high Sierra" and the following message:
macOS could not be installed on your computer
An error occurred while loading the installer resources.
Quit the installer to restart your computer and try again.

I've tried this multiple times. Any insights?!
ZachyDaddy
 
Posts: 6
Joined: 23. May 2019, 06:38

Re: [HowTo] Install OSX 10.13 in a VM

Postby socratis » 23. May 2019, 19:37

ZachyDaddy wrote:macOS could not be installed on your computer

What's your computer? You're a little bit light on the details...
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 24282
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: [HowTo] Install OSX 10.13 in a VM

Postby ZachyDaddy » 23. May 2019, 20:18

The message is inside my VM so the computer referred to in the error prompt is my virtual machine. My host machine though is a 2018 Mac Mini 6 core i7 32gb ram.

My VM has 40gb dynamic storage. 8gb ram. 4 processor cores assigned. I believe the video card has the full amount assigned which is 128mb or whatever the default card on my mini is. I don’t have it in front of me so I can’t say for sure.

My account is less than a day old so I can’t post links or anything yet.
ZachyDaddy
 
Posts: 6
Joined: 23. May 2019, 06:38

Re: [HowTo] Install OSX 10.13 in a VM

Postby socratis » 24. May 2019, 00:36

@ZachyDaddy
We need to see a complete VBox.log, from a complete VM run, where the problem occurs:
  • Start the VM from cold-boot (not from a paused or saved state) / Observe problem / Shutdown the VM (force close it if you have to).
  • With the VM completely shut down (not paused or saved), right-click on the VM in the VirtualBox Manager and select "Show Log".
  • Save only the first "VBox.log", ZIP it and attach it to your response. See the "Upload attachment" tab below the reply form.
Image
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 24282
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: [HowTo] Install OSX 10.13 in a VM

Postby ZachyDaddy » 24. May 2019, 03:15

I uploaded 2 different VM's that have slightly different settings but the same results. Thanks!


HighSierra VM-2019-05-23-18-10-46.log.zip
(33.49 KiB) Downloaded 8 times


HS VM-2019-05-23-08-30-29.log.zip
(33.88 KiB) Downloaded 5 times
ZachyDaddy
 
Posts: 6
Joined: 23. May 2019, 06:38

Re: [HowTo] Install OSX 10.13 in a VM

Postby socratis » 24. May 2019, 03:55

Instead of two logs, I would have preferred the <VM>.vbox file for either of the VMs. But we can have both. Can you do that? Grab the .vbox file for each VM and ZIP them. You can find them by right-clicking on the VM in the VirtualBox Manager and select "Show in Finder".
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 24282
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: [HowTo] Install OSX 10.13 in a VM

Postby socratis » 24. May 2019, 04:31

@ZachyDaddy
Here's a thing I discovered from the logs; you're using USB2 for your VM. USB3 became a requirement at some point. I have a ticket open since 10.12.4 came out (ticket #16644), where I discovered that USB3 *is* a requirement, otherwise the installation wouldn't proceed. Can you try with USB3 enabled?

And max out the VRAM to 128 MB from the current 16 MB.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 24282
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: [HowTo] Install OSX 10.13 in a VM

Postby ZachyDaddy » 24. May 2019, 06:29

I tried USB3 on both VMs and no bones. I've included one of the VM's here. at this point they're identical. Maybe I messed up when I created the High Sierra ISO? I have no idea.

HighSierra VM.vbox.zip
(1.55 KiB) Downloaded 11 times



Thanks!
ZachyDaddy
 
Posts: 6
Joined: 23. May 2019, 06:38

Previous

Return to Mac OS X Guests

Who is online

Users browsing this forum: No registered users and 3 guests