Solaris 11 Guest crash on 6.1.8 guest additions

Discussions about using Solaris guests in VirtualBox.
Post Reply
spbarrett
Posts: 25
Joined: 6. Jul 2016, 15:48

Solaris 11 Guest crash on 6.1.8 guest additions

Post by spbarrett »

Hopefully someone else can replicate this issue.
I upgraded my Windows 10 and Linux7.8 host to VBox 6.1.8. Solaris 11.4 VMs (SRU 19/20/21) all fail with a memory error after installing the latest guest additions. The VM boots and shows a logon screen, but immediately after logging on the VM displays a error in Windows and just vanishes in Linux.
Reverting to VBox 6.1.6 and the VM functions.
Installing VBox 6.1.8 and the VM functions.
Installing VBox 6.1.8 guest additions the VM boots but no logon.
Tried a new Solaris 11.4Trunk70 VM with the same results.
I have log files.
Attachments
Screen capture in Windows appears to show a memory error.
Screen capture in Windows appears to show a memory error.
VBox618@Solaris11SRU21.gif (14.14 KiB) Viewed 10674 times
paulson
Oracle Corporation
Posts: 27
Joined: 6. Jun 2019, 20:16

Re: Solaris 11 Guest crash on 6.1.8 guest additions

Post by paulson »

I upgraded my Windows 10 and Linux7.8 host to VBox 6.1.8. Solaris 11.4
VMs (SRU 19/20/21) all fail with a memory error after installing the
latest guest additions. The VM boots and shows a logon screen, but
immediately after logging on the VM displays a error in Windows and
just vanishes in Linux.
This is a regression in the VBox 6.1.8 Guest Additions which affects
guests using X11 and the VBoxVGA graphics controller. Changing the
graphics controller to be 'VBoxSVGA' for Solaris guests and 'VMSVGA' for
Linux guests (the recommended default) will allow the VMs to work with
the 6.1.8 GAs. For the record, another user ran into this with a Debian
guest and filed a ticket here:

https://www.virtualbox.org/ticket/19610

A fix is in progress.

.
paulson
Oracle Corporation
Posts: 27
Joined: 6. Jun 2019, 20:16

Re: Solaris 11 Guest crash on 6.1.8 guest additions

Post by paulson »

Another user ran into this with a Debian guest and filed a ticket here:

https://www.virtualbox.org/ticket/19610

A fix is in progress.
This issue has been addressed now and updated builds are now available
from https://www.virtualbox.org/wiki/Testbuilds as outlined
in the above ticket.
Post Reply