[Solved] Solaris 10 guest ridiculously slow

Discussions about using Solaris guests in VirtualBox.

[Solved] Solaris 10 guest ridiculously slow

Postby NeilE » 27. Nov 2017, 12:52

Hi,

Hoping someone can help me here - this has been happening over multiple versions of VBox and only seems to affect Solaris 10 guest hosts.

The entire system is really slow. You can see even the GRUB screen is drawn line-by-line. Once you get into the OS it's just as slow. The Solaris installer is also slow (e.g. the dots at the start go really slowly) so it's nothing to do with the OS itself.

Things I have tried/confirmed:

* 1 to many CPUs, no execution cap (i.e. set to 100%)
* Tried assigning 1-3GB memory
* Increase video memory to 128MB
* Different chipsets, turning PAE on/off
* Re-creating new VMs, 32bit, 64bit
* Dynamic/fixed size VDI HDD
* Different releases of Solaris 10, including latest Sol10 u11 1/13
* Downloading and importing the prebuilt Solaris 10 OVM from oracle dot com
* Checking all virtualisation options are enabled in the BIOS (dell xps 13)
* Enable/disable various things like audio/network
* Changing SATA to IDE for storage

I tried attaching a video capture (webm/mp4) but the extension isn't allowed, animated gifs over 128KB are not allowed either!

If anybody can help it would be really appreciated!

Thanks!
Attachments
Sol10Sandbox_showvminfo.txt
(4.78 KiB) Downloaded 2 times
Last edited by socratis on 30. Nov 2017, 12:15, edited 1 time in total.
Reason: Marked as [Solved].
NeilE
 
Posts: 8
Joined: 27. Nov 2017, 12:20
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Solaris,RHEL,Win7

Re: Solaris 10 guest ridiculously slow

Postby mpack » 27. Nov 2017, 17:00

Please post a VM log file. With the VM fully shut down, right click and "Show Log" in the GUI, save "VBox.log" (no other file) to a zip, and attach the zip here.
mpack
Site Moderator
 
Posts: 25501
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Solaris 10 guest ridiculously slow

Postby NeilE » 27. Nov 2017, 18:25

Hi,

Attaching a fresh log taken by turning on the VM up to the point the GRUB screen has been drawn.

Thanks in advance!
Attachments
VBox.log
(105.46 KiB) Downloaded 5 times
NeilE
 
Posts: 8
Joined: 27. Nov 2017, 12:20
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Solaris,RHEL,Win7

Re: Solaris 10 guest ridiculously slow

Postby mpack » 27. Nov 2017, 19:24

It would be great if you zipped the attachment next time as asked.

1536MB doesn't sound like a lot to give to a 64bit OS.

With a dual core host, you have assigned 2 cores to the VM, which leaves 0 cores for the host. This can cause poor performance. CPU Cores versus Threads.

What kind of drive is the VDI located on? The brief uses I've seen strike me as a bit slow, which could mean that something on the host is hogging disk bandwidth.

The entire uptime of the session you posted was only 46 seconds. I can't tell much more from that.
mpack
Site Moderator
 
Posts: 25501
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Solaris 10 guest ridiculously slow

Postby NeilE » 28. Nov 2017, 11:37

Hi mpack, thanks for the response.

To reply to to your points:

* Apologies for not zipping.
* I've also tried assigning 2 and 2.5GB to no avail.
* I've tried assigning both 1 and 2 CPUs. My slider goes up to 4 CPUs to I set it at 2 which I thought was a good trade-off.
* VDI is located on an M2 SSD, so plenty fast enough and I've checked and there's no bandwidth contention on the disk
* This issue only affects Solaris 10 hosts - all my other VMs are fine, including Sol11.
* I only included the bootup up to the GRUB menu as I thought that would be a good example (and as this happens on bootup I thought a log with the OS running would be superfluous).
* I have uploaded another VBox.log with 2.5GB RAM and let it boot all the way into the OS, waited a few minutes, then issued an ACPI shutdown. Hopefully that will give some more info.
* You can see the bootup sequence here: www . youtube . com/watch?v=ZPJbc7dtiUc

EDIT: just tried assigning 4GB of RAM and it's the same problem (log is with 2.5GB RAM)

Thanks again,

Neil
Attachments
VBox.zip
(21.41 KiB) Downloaded 2 times
NeilE
 
Posts: 8
Joined: 27. Nov 2017, 12:20
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Solaris,RHEL,Win7

Re: Solaris 10 guest ridiculously slow

Postby mpack » 28. Nov 2017, 12:07

NeilE wrote:* I've tried assigning both 1 and 2 CPUs. My slider goes up to 4 CPUs to I set it at 2 which I thought was a good trade-off.

Did you read the link I provided on this? And have you noticed that the slider is divided into green and red portions and considered what this means?

Ultimately I can't help you much more with this. I have no use for and therefore no experience with a Solaris 10 VM, you may have to wait until a Solaris expert comes along.
mpack
Site Moderator
 
Posts: 25501
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Solaris 10 guest ridiculously slow

Postby NeilE » 28. Nov 2017, 12:48

mpack wrote:Did you read the link I provided on this? And have you noticed that the slider is divided into green and red portions and considered what this means?

Yes I did - 1 and 2 CPUs are within the green portion and as I said previously, I have tried 1 and 2 CPUs, leaving plenty for the host.
NeilE
 
Posts: 8
Joined: 27. Nov 2017, 12:20
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Solaris,RHEL,Win7

Re: Solaris 10 guest ridiculously slow

Postby michaln » 28. Nov 2017, 16:35

The VM configuration looks reasonable, nothing obviously wrong with it. As a rule, if the defaults don't work well at all, any changes you make will probably only make it worse.

The behavior sounds like the host CPU is severely overloaded or otherwise not performing as it should. The host CPU is not exactly beefy, but I have an i5-6300U with Windows 10 here and Solaris 10U11 runs in a VM reasonably well. That is to say it's not super fast, but not noticeably slower than real hardware.

You might want to try to find out where the CPU cycles are going on the host, and definitely try some different host system for comparison.
michaln
Oracle Corporation
 
Posts: 2841
Joined: 19. Dec 2007, 15:45
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Any and all

Re: Solaris 10 guest ridiculously slow

Postby NeilE » 29. Nov 2017, 12:51

Hi michaln,

Thanks for the response. I've had perfmon running while switching on the VM and memory is at 70% usage, no paging and CPU at 52% so really strange. Sol10 VMs have worked on this laptop in the past so something's gone awry... it's been like it for about 8 months but it's got to the point where the VMs are unworkable... I'll try and backup the SSD, reinstall Windows and see if that makes a difference, just to see...

So annoying!!

Thanks!
NeilE
 
Posts: 8
Joined: 27. Nov 2017, 12:20
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Solaris,RHEL,Win7

Re: Solaris 10 guest ridiculously slow

Postby socratis » 29. Nov 2017, 14:50

Antivirus running on the host? We've had reports that lately they cripple VMs because they're trying to take a look inside the VM.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 12746
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Solaris 10 guest ridiculously slow

Postby michaln » 29. Nov 2017, 18:06

NeilE wrote:CPU at 52% so really strange

What does that mean? 2 out of 4 logical processors fully pegged? If those are the ones running the VM, then yeah, it's going to be slow...
michaln
Oracle Corporation
 
Posts: 2841
Joined: 19. Dec 2007, 15:45
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Any and all

Re: Solaris 10 guest ridiculously slow

Postby NeilE » 30. Nov 2017, 10:48

michaln wrote:
NeilE wrote:CPU at 52% so really strange

What does that mean? 2 out of 4 logical processors fully pegged? If those are the ones running the VM, then yeah, it's going to be slow...


Start > Run > resmon (or Task Manager > Performance tab) and as a percentage, CPU Usage/Utilization. So all cores basically, covering host system as well as resources taken by the guest VM. Resmon is particularly handy but there's not much over 7MB/sec (It's an M2 SSD), CPU not going over ~50% (the Virtualbox process is taking no more than 25% CPU so I don't think it's maxing out its two assigned vCPUs), little-to-no-paging and most other applications all shut down.

socratis wrote:Antivirus running on the host? We've had reports that lately they cripple VMs because they're trying to take a look inside the VM.

AV shut down...

Sol10 guests used to work at the start of the year, something's changed in the background somewhere and I just can't figure out what! :( I can have another couple of guest VMs running with the Sol10 guest also running and they're absolutely fine, say a Windows 7 host and a RedHat host - it's just Solaris 10 guests!! :x
NeilE
 
Posts: 8
Joined: 27. Nov 2017, 12:20
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Solaris,RHEL,Win7

Re: Solaris 10 guest ridiculously slow [SOLVED]

Postby NeilE » 30. Nov 2017, 11:54

Sorted it - even though I had disabled AVG by right clicking it and stopping its service, it clearly still had processes/services running when looking at procexp. I uninstalled it completely and it fixed it straight away.

Thanks to everyone for their input!
NeilE
 
Posts: 8
Joined: 27. Nov 2017, 12:20
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Solaris,RHEL,Win7

Re: Solaris 10 guest ridiculously slow

Postby socratis » 30. Nov 2017, 12:15

Great, thanks for the feedback. Marking as [Solved].
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 12746
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: [Solved] Solaris 10 guest ridiculously slow

Postby michaln » 30. Nov 2017, 12:29

AV software... the cure worse than the disease. Sigh.

Thanks for figuring this out and letting us know!
michaln
Oracle Corporation
 
Posts: 2841
Joined: 19. Dec 2007, 15:45
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Any and all

Next

Return to Solaris Guests

Who is online

Users browsing this forum: No registered users and 1 guest