Solaris 11.1 update to 11.2: no GUI

Discussions about using Solaris guests in VirtualBox.

Solaris 11.1 update to 11.2: no GUI

Postby mike004 » 9. Oct 2014, 12:00

Win 7 host, VirtualBox 4.3.12
Solaris 11.1 guest works fine, so I decided to update the guest from Solaris 11.1 -> 11.2
Package update went well, no problems.

Now, every time I boot up the VM I see the text-based Solaris login.
This despite the graphical login service is running on Solaris.
The Solaris desktop package solaris-desktop is installed OK. But there is no way to display the Solaris desktop GUI.
Running svcadm enable gdm, followed by a reboot has no effect.

Anyone else seen this?
mike004
 
Posts: 57
Joined: 29. Oct 2008, 14:13

Re: Solaris 11.1 update to 11.2: no GUI

Postby jay22 » 18. Nov 2014, 16:56

I have exactly the same issue. gdm is running fine and can connect to the virtual machine via X with a full graphical interface. If I try and start X manually I get the following .....

(EE) module ABI major version (12) doesn't match the server's version (14)
(EE) Failed to load module "vboxvideo" (module requirement mismatch, 0)
(EE) module ABI major version (16) doesn't match the server's version (19)
(EE) Failed to load module "vboxmouse" (module requirement mismatch, 0)
(EE) No drivers available.
Fatal server error:

As such, it's X failing and I cant seem to find out how to reinstall the VBox extensions!

Any ideas?
jay22
 
Posts: 1
Joined: 18. Nov 2014, 16:32

Re: Solaris 11.1 update to 11.2: no GUI

Postby Rogalsky » 24. Dec 2014, 16:30

Hi Dude!

I has the same issue, but with a little problem, NO GUI on server boot :( only a black screen...

I connected on putty, and I remove the vbox additions like the manual and reinstall...:

4.2.3.1. Installing the Solaris Guest Additions -> pkgadd -G -d ./VBoxSolarisAdditions.pkg ( in /cdrom/vbox... )

4.2.3.2. Uninstalling the Solaris Guest Additions ( this first!!! ) -> pkgrm SUNWvboxguest

So I rebooted the Server and "voilà"...

Everything come back to normal :)

Tks and Cheers!!!
Rogalsky
 
Posts: 1
Joined: 24. Dec 2014, 16:25

Re: Solaris 11.1 update to 11.2: no GUI

Postby awk-m4 » 3. Mar 2015, 19:40

Thank you! That did the trick!

Regards
Paul D
awk-m4
 
Posts: 1
Joined: 21. Sep 2013, 03:59


Return to Solaris Guests

Who is online

Users browsing this forum: No registered users and 1 guest