[SOLVED] Long mode not supported

Discussions about using Solaris guests in VirtualBox.

[SOLVED] Long mode not supported

Postby jmorcate » 19. Nov 2011, 00:57

Hi,

I am trying to install Solaris 11 on mi VirtualBox but I get always the message Long mode not supported, rebooting Press any key to reboot. at the very beginning of the installation. This is my environment:

Host: MS Windows 7 (64 bits)
Virtual Box : 4.1.6
Guest: Oracle Solaris 11 11/11 Live Media for x86

I have the same problem with Ubuntu. I have download la ISO for Solaris 11 a cuple of times and I dont know what else to try. Any idea?

Thank you very much

J. Morcate
Last edited by jmorcate on 21. Nov 2011, 09:52, edited 1 time in total.
jmorcate
 
Posts: 3
Joined: 19. Nov 2011, 00:41
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Solaria

Re: Long mode not supported

Postby Perryg » 19. Nov 2011, 01:25

Solaris 11-11 only supports 64 bit, so you need to have VT-x/AMD-v enabled in your bios (hardware virtualization)
Also text mode install didn't work for me and i needed to use the LiveCD to install from.
Perryg
Site Moderator
 
Posts: 34267
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Long mode not supported

Postby jmorcate » 21. Nov 2011, 09:52

Great Perryg!

I enabled the hardware virtualization in the BIOS and the virtual machine booted. Thank you very much for your help.

Joaquin
jmorcate
 
Posts: 3
Joined: 19. Nov 2011, 00:41
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Solaria

Re: [SOLVED] Long mode not supported

Postby tullio » 28. Nov 2011, 20:34

Since Solaris11 refused to install on my Opteron1210 for lack of "long mode support", I simply downloaded an Oracle Virtual Machine including Solaris 11 and it works. I am using it now.
tullio
 
Posts: 39
Joined: 7. Aug 2010, 05:29
Primary OS: openSUSE
VBox Version: PUEL
Guest OSses: OpenSolaris

Re: [SOLVED] Long mode not supported

Postby driverA » 9. Apr 2012, 20:25

I was having the same issue, even though I already enabled the Virtualization Setting on the laptop.
I was able to get around this by selecting Solaris 64-bit as the Guest O.S.in Virtual Box. The default setting was Solaris10 or higher (32-bit).
The installer is currently working.
driverA
 
Posts: 1
Joined: 9. Apr 2012, 20:21

Re: [SOLVED] Long mode not supported

Postby Spiffykat404 » 1. Jun 2014, 22:07

Although this is an already a 'SOLVED' case here is a quick update. (Using VirtualBox Version 4.3.12 Edition)

Solaris 11 will run w. no problems if the VM created during 'Name and Operating System' has the selection 'Solaris' in type and 'Solaris 11' in Version.

EOF>
Spiffykat404
 
Posts: 1
Joined: 1. Jun 2014, 21:37


Return to Solaris Guests

Who is online

Users browsing this forum: No registered users and 1 guest