GNOME desktop does not start up

Discussions about using Solaris guests in VirtualBox.

GNOME desktop does not start up

Postby robinky » 11. Aug 2009, 04:21

Hello all,

I am facing a trouble on my VirtualBox environment, and really appreciate if someone could give me some advice and guidance how to handle it.

I am trying to start OpenSolaris 2006.09 Live CD to install it on my VirtualBox in a newly created a virtual machine; however, GNOME desktop does not come up unfortunately. The Live CD screen stops showing these messages at the bottom. (Please see attached for details)


Aug 11 03:39:54 opensolaris ufs: NOTICE: realloccg /: file system full
Aug 11 03:39:54 opensolaris ufs: NOTICE: alloc /: file system full


These messages show up after selecting desktop language. I also see the vm struggling to make the GNOME screen start running twice or so right after the desktop language selection, but it fails coming up and then put out these errors.
The system itself seems alive. I can login by using jack on the character interface basis, but
GNOME never comes up.

I created another vm for OpenSolaris 2009.06 yesterday on the same host with the same configuration, and it works fine. However this second one, no good. :(

< My host environment >
Windows XP Professional Version 2002 SP2, 32-bit
3GB RAM
Machine: Dell OPTIPLEX 745

< VirtualBox Version >
3.0.2 r49928

<Virtual Machine log>
Please see attached.

I appreciate if someone in-the-know could tell me how to fix it.

Thank you,
Robinky
Attachments
iST-2009-08-11-10-25-11.log
(35.9 KiB) Downloaded 21 times
CannotStartUp.PNG
CannotStartUp.PNG (24.68 KiB) Viewed 4389 times
robinky
 
Posts: 10
Joined: 21. Sep 2008, 10:51
Location: Japan

Re: GNOME desktop does not start up

Postby Perryg » 11. Aug 2009, 04:44

Only way I have ever been able to install OpenSolaris is with 1024 meg set in the guest for RAM. It looks like you are trying to do it with less.
Perryg
Site Moderator
 
Posts: 34373
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: GNOME desktop does not start up

Postby robinky » 12. Aug 2009, 05:21

This problem was solved, and now the GNOME desktop appears as it should be. Moreover OpenSolaris is now successfully installed in the vm as well.

Actually I did not make any changes on VirtualBox or the vm at all. So I am not so for sure what did the trick. I did close some other applications running at the same time on the same host PC, but my PC resource was not stretched too thin anyway.

Perryg,
Thanks for the advice. My RAM setting of this vm is 768MB as you pointed out. I will try to increase RAM size when I encounter the same problem again.

Thanks,
Robinky
robinky
 
Posts: 10
Joined: 21. Sep 2008, 10:51
Location: Japan

Re: GNOME desktop does not start up

Postby DaveLevy » 19. Nov 2009, 16:38

I have had an eventually sucessfull a.m. I have just installed OS 2009.06 into a Virtual Box VM hosted on Windows Vista 32 Bit Business SP2. I solved my problem by increasing the VM RAM to 1024 Gb. N.B.I have 4 Gb of RAM, of which the Host OS can address 3.45 Gb

So I firstly tried with VB3.0.10 and got the bug documented in the vboxguest issue with 3.0.10 thread, so no problems I upgrade the VB software to 3.0.12

When it launches, there's no window manager, fortunately I find this thread, increase the memory in the VM definition and the instance comes up just fine :D Thanks for documenting it.

The problem is that the default is 768 Mb.

I think something should be changed, either a warning on the config pane that the window manager won't start if RAM is less than 1024 Mb, or increase the default to 1024 (with a warning if you want), or some notes in the User Manual. (Not that it would have helped, I assume I know how to install OS into a VBox VM and didn't read the manual.) Ooops :oops:
--
Dave,
Windows 10, and also using Mac OS 10.11 on Mac Book Pro 5.1
DaveLevy
 
Posts: 56
Joined: 1. May 2008, 08:24
Location: London
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Ubuntu, Fedora


Return to Solaris Guests

Who is online

Users browsing this forum: No registered users and 1 guest