Windows guests with SerialPorts won't boot in 6.x (#18789)

Discussions about using Windows guests in VirtualBox.

Re: Windows guests with SerialPorts won't boot in 6.x (#18789)

Postby socratis » 18. Nov 2019, 09:37

scottgus1 wrote:There's a post somewhere on the forum tonight, I think it's Socratis', and I can't find it again, that shows there were changes in 6.0 to the serial code.
Actually the post was about USB, not serial... ;)

@'eelstrebor1'
The Serial code was re-written with 6.0.0 and there were issues, like in every complete re-write. You have opened a ticket. Developers are aware of that.
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27693
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Windows guests with SerialPorts won't boot in 6.x (#18789)

Postby ftab » 16. Dec 2019, 22:30

I'm also running into this. I just have a single serial port on the host, at /dev/ttyS0, and I've tried setting it up as host device or raw file, but no luck either way.

The log stops at
00:00:20.464185 Serial#0: Failed to change parameters to 1200,EVEN,7,1 -> VERR_DEV_IO_ERROR
ftab
 
Posts: 1
Joined: 16. Dec 2019, 22:26

Previous

Return to Windows Guests

Who is online

Users browsing this forum: No registered users and 24 guests