Win 10 on VBox v6.0.8 audio off sync (Mac OS X host 10.11.6)

Discussions about using Windows guests in VirtualBox.

Win 10 on VBox v6.0.8 audio off sync (Mac OS X host 10.11.6)

Postby rcastnyc » 3. Jun 2019, 22:12

Win7 or Win10 guest on VirtualBox 6 (Mac OS X host) has noticeable lag between audio and video. Only works with version Virtualbox 5.0.6. All other versions after 5.2 are off-sync. Any help/advice is much appreciated.
rcastnyc
 
Posts: 4
Joined: 3. Jun 2019, 21:59

Re: Win 10 on VBox v6.0.8 audio off sync (Mac OS X host 10.11.6)

Postby socratis » 3. Jun 2019, 23:11

Audio/video is an ongoing battle unfortunately, and the reason is proper timing/buffering/synchronization, which is not a virtual machine's forte. And believe me, nobody is going to notice glitches in the disk I/O or the CPU, but everyone will notice the audio lagging, even by a few msec.

But, we need to see a complete VBox.log, from a complete VM run, where the problem occurs:
  • Start the VM from cold-boot (not from a paused or saved state) / Observe problem / Shutdown the VM (force close it if you have to).
  • With the VM completely shut down (not paused or saved), right-click on the VM in the VirtualBox Manager and select "Show Log".
  • Save only the first "VBox.log", ZIP it and attach it to your response. See the "Upload attachment" tab below the reply form.
Image
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25943
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Win 10 on VBox v6.0.8 audio off sync (Mac OS X host 10.11.6)

Postby rcastnyc » 7. Jun 2019, 16:02

Thank you socratis. Your right, looks like buffering issue. Tried playing audio sync test video from YT and audio seemed to lag by frames. Tested with different/older versions of VBox, only works with 5.0.6 r103037. See attached log. Thanks!
Attachments
RCastnyc_VBox.log.zip
(38.69 KiB) Downloaded 11 times
rcastnyc
 
Posts: 4
Joined: 3. Jun 2019, 21:59

Re: Win 10 on VBox v6.0.8 audio off sync (Mac OS X host 10.11.6)

Postby mpack » 7. Jun 2019, 17:40

00:00:01.096652 NumCPUs <integer> = 0x0000000000000004 (4)
...
00:00:01.318733 CPUM: Physical host cores: 4

And again.
mpack
Site Moderator
 
Posts: 29832
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Win 10 on VBox v6.0.8 audio off sync (Mac OS X host 10.11.6)

Postby socratis » 7. Jun 2019, 18:54

mpack wrote:And again.
:D :twisted:
mpack's expected and understandable frustration comes from the fact that no one read previous posts, where we specifically warn user against using every core that they have on their host and assign it to their guests. That leaves the host starving for resources. Your Intel i7-3770 CPU has 4-cores/8-threads. Follow the link to Intel's site, and click on the "?" to further educate yourself.

VirtualBox cares about physical processors (cores), not logical ones (threads). See "CPU Cores versus threads" and "Why is it a bad idea to allocate as many VCPUs as there are physical CPUs?".

00:00:01.096744 [/Devices/ahci/0/LUN#0/Config/] (level 5)
00:00:01.096745 BlockCache <integer> = 0x0000000000000001 (1)
Go to the VM Settings » Storage » select your SATA controller » Enable Host I/O Cache: enable that.

00:00:01.096802 [/Devices/efi/0/] (level 3)
00:00:01.096803 Trusted <integer> = 0x0000000000000001 (1)
Just out of curiosity, why did you chose to modify the template defaults, and go with the experimental EFI implementation, instead of the more solid traditional BIOS?

00:00:01.096909 3DEnabled        <integer> = 0x0000000000000000 (0)
00:00:01.096914 VRamSize <integer> = 0x0000000008000000 (134 217 728, 128 MB)
00:00:01.839135 GUI: 2D video acceleration is disabled
Go to the VM Settings » Display » Screen. Enable 2D and 3D acceleration. Increase the VRAM to the max 256 MB.

BTW, all the changes are meant to be done with the VM completely shutdown, from within the VM. Not paused. Not saved-state.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25943
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Win 10 on VBox v6.0.8 audio off sync (Mac OS X host 10.11.6)

Postby rcastnyc » 10. Jun 2019, 15:28

Thanks for your replies and recommendations. Will apply and test these today...
rcastnyc
 
Posts: 4
Joined: 3. Jun 2019, 21:59

Re: Win 10 on VBox v6.0.8 audio off sync (Mac OS X host 10.11.6)

Postby rcastnyc » 10. Jun 2019, 16:12

Applied all recommended settings but audio still lags by number of frames. Not as bad as before though. Had to modify and enable EFI— getting this error "FATAL: No bootable medium found! System halted" when unchecked. See attached new log. Thanks.
Attachments
RCastnyc_Vbox2.zip
(40.76 KiB) Downloaded 14 times
rcastnyc
 
Posts: 4
Joined: 3. Jun 2019, 21:59

Re: Win 10 on VBox v6.0.8 audio off sync (Mac OS X host 10.11.6)

Postby WadeChu » 18. Aug 2019, 01:05

Hi,

Has anyone found a fix for this Windows 10 guest audio synce delay issue ? Thanks.
WadeChu
 
Posts: 1
Joined: 18. Aug 2019, 00:43

Re: Win 10 on VBox v6.0.8 audio off sync (Mac OS X host 10.11.6)

Postby socratis » 18. Aug 2019, 03:33

rcastnyc wrote:Had to modify and enable EFI— getting this error "FATAL: No bootable medium found! System halted"
You can't be switching from BIOS to EFI and vice versa. That's the expected message even in real life.

WadeChu wrote:Has anyone found a fix for this Windows 10 guest audio synce delay issue?
Not really, and don't expect it any time soon. Audio is a really time/timing sensitive operation, and Virtual Machines literally suck at this (and graphics). You'll never notice if your spreadsheet takes 100 ms more, or your download is jittery, but audio/video? Yeah, you'll notice that...
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25943
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5


Return to Windows Guests

Who is online

Users browsing this forum: No registered users and 9 guests