Page 6 of 6

Re: Guest Bluescreen using shared folders in VirtualBox > 6.0.9 (#18766)

PostPosted: 15. Aug 2019, 02:30
by socratis
scottgus1 wrote:One other thing, there will be a matching test build Extension Pack, too. The version numbers must match.

They should match for the releases (by definition), not for the Test/Development builds. Actually it's a 60/40 to see the exact match, especially if they're working on an active problem. That goes for the Guest Additions as well...

Re: Guest Bluescreen using shared folders in VirtualBox > 6.0.9 (#18766)

PostPosted: 15. Aug 2019, 04:35
by wye
Well, I have 6.0.11 running on a Win 7 Pro SP1 Host and it mostly works. XP, WIN7, WIN2000, and three different WIN10 guests are able to handle Shared Folders as before.

I HAVE noticed that Shared Folders seem to be defaulting to Z: since 6.0.10 came along. I've had to go back and specify mount points for the first time.

One of my Win10 guests BSOD'ed after installing the Guest Additions but another re-boot seems to have cured that. Guests MAY be a little flakey with 6.0.11, but at least they can properly access the shared folder.

Thanks for your help.

Re: Guest Bluescreen using shared folders in VirtualBox > 6.0.9 (#18766)

PostPosted: 15. Aug 2019, 17:17
by scottgus1
socratis wrote:not for the Test/Development builds

Interesting. I'll try to rememeber that.

VirtualBox 6.0.10 causes BSOD in Windows 7 SP1 x64 guest during execution of USMT scanstate.exe

PostPosted: 16. Aug 2019, 20:31
by ek-dyoder
I'm brand spanking new to the VirtualBox forums (be gentle), but have been using the product for many years now.

I'm working on testing some scripts for working with Microsoft's User State Migration Tool (USMT). Short story - this is used to migrate user profiles and data to new computers or whatever.

Anyway, after several days of creating snapshots, reverting, restoring, etc., I get a notification that 6.0.10 is available. I download and install the update, boot my VM's and upgrade VirtualBox tools, make new snapshots for my base images, and continue testing. On my first attempt at running the USMT utility scanstate.exe, I get a BSOD in Windows 7 x64. The guest VM (Windows 7 SP1 x64) then creates a ~250Kb minidump and restarts the VM. I try it a second and third time - same result.

I figured it was the update, so I uninstall VirtualBox on my Windows 10 x64 1903 host, reinstall VirtualBox 5.2.32, boot the VM's and uninstall the VirtualBox tools and install the ones for 5.2.32, and make my new snapshots for the base images. Then I try to run scanstate.exe again and it works perfectly fine.

I'm no bug hunter, and I really wouldn't know where to go to start tracking this down. All I know is that I was getting a BSOD when using 6.0.10 and did not get a BSOD in 5.2.32. Not only was this my initial experience, but I can reproduce it. I have a copy of the minidump that Windows 7 made.

I just wasn't sure if I should post here or to the bug tracker. At this point I'm not really inclined to go bug hunting either - if I had more time right now I would definitely go back and grab all the logs I could find (maybe I can do that in a few weeks if you need me to...?). I just wanted to make someone aware of the issue.

Re: Guest Bluescreen using shared folders in VirtualBox > 6.0.9 (#18766)

PostPosted: 16. Aug 2019, 23:55
by socratis
@ek-dyoder
I think what you're describing has to do with a Shared Folders bug in 6.0.10, that's why I merged your thread with the prominent thread on the subject. Please read it from the beginning and confirm that this is the case.

Re: Guest Bluescreen using shared folders in VirtualBox > 6.0.9 (#18766)

PostPosted: 17. Aug 2019, 03:16
by ek-dyoder
Looks like this thread might be what's happening. Please see attached 7z archive.

I included a screenshot of the BSOD itself because I think mine looks different than what others were describing. I've included VBox.log for the complete run of the problem - cold start, to BSOD and restart, then to shutdown again. Lastly, not sure if it helps at all, but I also included the mini dump file the Windows 7 guest generated.

Re: Guest Bluescreen using shared folders in VirtualBox > 6.0.9 (#18766)

PostPosted: 30. Aug 2019, 17:39
by CTR2019
Hi.

I have also been experiencing bluescreens from a Windows 7 x64 guest running on a fully update Windows 10 x64 host.
I can trigger the fault by using explorer in the guest to copy a pair of files from %TEMP% and pasting them to a shared folder \\vboxsvr\vm_shared\...path here...\ Moments after I press CTRL-V, I get a windows bugcheck error.

I tried updating to the latest 6.0.x test build (Windows 6.0.x revision 132999) but this has NOT resolved the problem.

I attach a zip of my logs.

The error from windows is IRQL_GT_ZERO_AT_SYSTEM_SERVICE

Is there anything else I can do to help?

Best wishes,

Chris.

Logs_20190830_1627.zip
(171.16 KiB) Downloaded 9 times

Re: Guest Bluescreen using shared folders in VirtualBox > 6.0.9 (#18766)

PostPosted: 30. Aug 2019, 18:59
by Martin
00:00:35.112832 VMMDev: Guest Additions information report: Version 6.0.10 r132072 '6.0.10'

You didn't update the Guest Additions inside your Windows 7 guest.

Re: Guest Bluescreen using shared folders in VirtualBox > 6.0.9 (#18766)

PostPosted: 30. Aug 2019, 19:40
by CTR2019
Thanks for spotting. I upgraded the guest additions. Then I tried one copy-paste that always crashed before, and it didn't crash this time.

Re: Guest Bluescreen using shared folders in VirtualBox > 6.0.9 (#18766)

PostPosted: 31. Aug 2019, 08:48
by socratis
@ALL
The issue has been fixed in the latest test builds, give it a shot.

Also, try to remember to check the status of known bugs by checking the "Known Issues" for each release, in this case the "Discuss the 6.0.10 release", I try to keep it as up-to-date as possible...

See also: